Bug 604007 (fx40-p12n-ru)

[ru] Firefox 4.0 productization review for Russian

RESOLVED FIXED

Status

Mozilla Localizations
ru / Russian
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: stas, Assigned: Alexander L. Slovesnik)

Tracking

({productization})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [update l10n-src-verification])

Attachments

(1 attachment, 1 obsolete attachment)

11.49 KB, patch
Seth Bindernagel
: review+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
As you might have seen in the newsgroups or on the Mozilla blog, there's a couple of changes to search engines planned for the 4.0 release for en-US: <http://groups.google.com/group/mozilla.dev.l10n/msg/81073d8d67e1c4c3>. We would like to use this opportunity to review the current productization setup for Russian and make any changes that you think will be good for our users.

What is a productization review?
================================

Here's what we're interested in:
* search engines,
* protocol handlers,
* feed readers,
* live bookmark.
You can see what your locale currently ships with at <http://hg.mozilla.org/l10n/l10n-src-verification/file/default/reference/browser/2.0/ru>

Please take a moment and review the choice of services available by default in your locale. If there have been any new services that have recently gained popularity and that offer good value for the users, please suggest adding them to your locale. On the other hand, if there are services that lost credibility (e.g. display too many adds) or have poor user experience, consider suggesting that we remove them. If in doubt, feel free to make a suggestion and we'll look at it together. You might find the guidelines at <https://wiki.mozilla.org/L10n:Productization> and <https://wiki.mozilla.org/L10n:Firefox/Productization> helpful, too.

Required changes
================

There's two things I would like to draw your attention to (if applicable):

1) if you have a google.xml file in your `searchplugins` directory, please remove it,

2) Bloglines is closing down on November 1st and we need to remove it from the feed reader options for all locales (see bug 595485). We suspect that it will make sense to move Google Reader up to the first position (if your locale has it). We will be offering technical help with this change, either in form of ready-made patches or a mass-landing by one of the l10n-drivers. If you don't think that moving Google Reader up is a good idea for your locale, please let us know!

Changes in en-US and en-GB
==========================

Here's the changes that we will be making in en-US and en-GB:
* add Bing as the 3rd general search engine (see bug 603298),
* remove Answers,
* remove Creative Commons.

We're making these changes in en-US and en-GB because we feel that they follow the recent market trends and user preferences in the US and the UK. We would like to go through the same thought process for your locale and see if any of these changes would make sense in Russian builds as well. If you decide that implementing these changes would be in your users' best interest then please go ahead and include them in the patch you'll attach to this bug.


Implementation
==============

Please make suggestions for changes and attach patches that Seth, Axel or I will review. Please note that since Bing provides a global plugin which does the locale detection itself, you will only need to add "bing" to your list.txt if you decide to include it. The XML file will be automatically pulled from en-US.

Once a review is granted, you can land the patch on l10n-central if your locale actively maintains it. Otherwise, please wait for further instructions which will be put in the comments of this bug and announced in mozilla.dev.l10n (we're still unsure when the branching will happen). Please do not land any changes except for the required ones (google.xml, Bloglines) on 1.9.2.

If you do not wish to make any changes, let us know, and we'll only work on removing Bloglines.

Thanks!
(Assignee)

Updated

7 years ago
Duplicate of this bug: 587206
(Assignee)

Comment 2

7 years ago
Created attachment 482888 [details] [diff] [review]
Patch v.0.5

Summary of changes:
1) Add OZON.ru and remove torg.mail.ru as discussed in Bug 539312
2) Add search suggestions to Yandex.Slovari as requested in Bug 587206
3) Remove Bloglines and move Google Reader on its place

I defer to Konstantin's opinion on Bing issue.
(Assignee)

Comment 3

7 years ago
(In reply to comment #0)
> You can see what your locale currently ships with at
> <http://hg.mozilla.org/l10n/l10n-src-verification/file/default/reference/browser/2.0/ru>
Please note, that Rambler has been replaced with Mail.ru in Bug 474226 on mozilla-central. You may want to update reference list.
(Assignee)

Comment 4

7 years ago
(In reply to comment #2)
> 1) Add OZON.ru and remove torg.mail.ru as discussed in Bug 539312
s/Bug 539312/Bug 595312

Comment 5

7 years ago
Comment on attachment 482888 [details] [diff] [review]
Patch v.0.5

Not necessary to do anything to browser.search.order or to firefox-l10n.js.  Please submit a new patch that simply removes Bloglines (as you did here) and replaces torg.mail.ru with Ozon, amending list.txt appropriately.

Also, what parameter are you trying to add to the Yandex search plugin?
Attachment #482888 - Flags: review-
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> Comment on attachment 482888 [details] [diff] [review]
> Also, what parameter are you trying to add to the Yandex search plugin?
This is search suggestion feature for Yandex.Slovari. See Bug 587206

Comment 7

7 years ago
Comment on attachment 482888 [details] [diff] [review]
Patch v.0.5

1)  We do not need to add Ozon to browser.search.order
2)  There should be no changes to firefox-l10n.js

Updated

7 years ago
Whiteboard: [update l10n-src-verification]
(Assignee)

Comment 8

7 years ago
Created attachment 487374 [details] [diff] [review]
Patch v.2

1) browser.search.order.3 in region.properties is removed
2) Changes in firefox-l10n.js are removed
Attachment #482888 - Attachment is obsolete: true

Comment 9

7 years ago
Before checking in this change, Konstantin is going to put me in touch with the Ozon team to confirm that they are OK with this change. I assume you have already chatted with them since you have included a parameter for them to identify searches with the param value = "firefox".  Konstantin, please make the intro via email and we'll take it from there.  I believe you also mentioned setting up a meeting with the team.  Let me know if that is going to happen.  After all is cleared, we can check in these changes.  Thanks!

Comment 10

7 years ago
Comment on attachment 487374 [details] [diff] [review]
Patch v.2

Before I approve this, can you tell me what the Param changes are to the Яндекс.Словари plugin?  We hadn't discussed that yet.  Is this something that Yandex wants to include to help track searches from Mozilla?
(Assignee)

Comment 11

7 years ago
(In reply to comment #10)
> Comment on attachment 487374 [details] [diff] [review]
> Patch v.2
> 
> Before I approve this, can you tell me what the Param changes are to the
> Яндекс.Словари plugin?
See comment 6

> We hadn't discussed that yet.  Is this something that
> Yandex wants to include to help track searches from Mozilla?
I want to include this, because I think search suggestions feature is useful for users. It was provided by Yandex team in Bug 587206 comment 1
Do you need separate letter from Yandex with permission to use search suggestions in Яндекс.Словари search plugin?

Comment 12

7 years ago
No need to get permission.  I just hadn't seen any conversation on this change and wanted to know about it so all understand what is going on.
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> No need to get permission.  I just hadn't seen any conversation on this change
> and wanted to know about it so all understand what is going on.
I have learned that Yandex has added search suggestion feature in Yandex.Slovari service and I've asked Yandex to provide url for this feature to add it in Yandex.Slovari search plugin. I was under impression that Mozilla is cool with addition search suggestion in existing search plugins if search plugin provider has no objections.
If addition of search suggestion feature needs separate discussion, let's have it.

Comment 14

7 years ago
Comment on attachment 487374 [details] [diff] [review]
Patch v.2

Please check in this change on l10n-central *only*.  Please add a comment to the checkin that references this change and Bug 604007.

We can finish the 1.9.2. work in bug 604076.
Attachment #487374 - Flags: review+
(Assignee)

Comment 15

7 years ago
Fixed in http://hg.mozilla.org/l10n-central/ru/rev/f887429dd98c
(Assignee)

Updated

7 years ago
Assignee: nobody → unghost
Status: NEW → ASSIGNED

Comment 16

7 years ago
Closing this bug.  Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.