Last Comment Bug 610714 - Add nsIDOMGlobalPropertyInitializer that allows "JavaScript Global Properties" to know about the window they're being attached to
: Add nsIDOMGlobalPropertyInitializer that allows "JavaScript Global Properties...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla2.0b8
Assigned To: Johnny Stenback (:jst, jst@mozilla.com)
:
Mentors:
: 334875 (view as bug list)
Depends on:
Blocks: 334876 340604 341283 lazy-console
  Show dependency treegraph
 
Reported: 2010-11-09 10:23 PST by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2014-12-12 17:06 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
betaN+


Attachments
JST's patch from bug 568629 (4.29 KB, patch)
2010-11-09 12:50 PST, David Dahl :ddahl
mrbkap: review+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2010-11-09 10:23:56 PST
See bug 568629 comment 78.
Comment 1 David Dahl :ddahl 2010-11-09 12:50:26 PST
Created attachment 489259 [details] [diff] [review]
JST's patch from bug 568629

Blake: you already marked this r+ - just wanted to get this bug opened so things are more clear and organized
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-11-11 17:31:13 PST
Landed, with a couple of comment tweaks:
http://hg.mozilla.org/mozilla-central/rev/0e1d126d7f7c
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-11-11 18:07:28 PST
*** Bug 334875 has been marked as a duplicate of this bug. ***
Comment 4 Eric Shepherd [:sheppy] 2010-11-16 13:37:21 PST
Documented here:

https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsIDOMGlobalPropertyInitializer

Note You need to log in before you can comment on or make changes to this bug.