Closed Bug 613606 Opened 10 years ago Closed 10 years ago

Tab view breaks the Aero glass effect

Categories

(Firefox Graveyard :: Panorama, defect, P4)

x86
Windows 7
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 4.0b11

People

(Reporter: faaborg, Assigned: fryn)

References

Details

(Whiteboard: [fixed by bug 591652])

Attachments

(1 file)

I just realized that we are breaking the Aero glass effect related to window size in tab view.  Easiest way to describe what is happening is to attach a video.

expected behavior: the effect is based only on the actual size of the window, and not the position of a tab or tab group.
Blocks: 598154
OS: Windows 7 → Windows XP
Priority: -- → P4
OS: Windows XP → Windows 7
Duplicate of this bug: 622338
See Also: → 623092
It seems to be related to the focussed tab/group. 
For some reason Microsoft Windows Areo seems to want to move the highlight bar based on focus. May be because it is fooled by the way the rendering engine uses windows handles?
bugspam (moving b9 to b10)
Blocks: 608028
bugspam (removing b9)
No longer blocks: 598154
Punting
No longer blocks: 608028
OS: Windows 7 → Windows XP
Target Milestone: --- → Future
OS: Windows XP → Windows 7
Duplicate of this bug: 597298
I'm actually not seeing the bug with the currently nightly build.  Did anything change that might have independently solved this?
(In reply to comment #7)
> I'm actually not seeing the bug with the currently nightly build.  Did anything
> change that might have independently solved this?

I see this with the current nightly build. :(
Install my Nautipolis theme to better see the effect. 
It seems to happen not always, one needs to select another tabgroup and move that around sometimes.
Try using this CSS code to see what is happening better :

@-moz-document url("chrome://browser/content/tabview.html"){
#bg{display:none}
}
I don't notice this bug anymore on Firefox 4 Beta 9, with Windows 7 x32.

Strange, I always thought this was a feature :P
The patch for bug 591652 seems to fix this.
Reopen if you can confirm that isn't fixed somehow.
Assignee: nobody → fryn
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 591652]
Target Milestone: Future → Firefox 4.0b11
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.