Closed Bug 614556 Opened 11 years ago Closed 11 years ago

Can not return to tab browser and can not close the browser, when I closed tab group in Panorama

Categories

(Firefox Graveyard :: Panorama, defect)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 4.0

People

(Reporter: alice0775, Assigned: aza)

References

Details

(Keywords: regression)

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre)
Gecko/20101124 Firefox/4.0b8pre


Can not return browser and can not close the browser, when it passes for back 15 seconds when I closed tab group in Panorama.

workaround: 
* create group and create new tab
* undo closed tab, Do not use Ctrl + T due to Bug 614545.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Enter Panorama (Ctrl + E)
4. Close all groups, and close all standalone tabs(if any)
5. Wait 15 seconds
6. Try to retirn tab browser (Ctrl + E)
7. try to close the browser, 

Actual Results:  
 * Can not return to tab browser
 * Can not close the browser

Expected Results:  
 * Should be able to return tab browser.
 * Should be able to close the browser.

Regression window(cached hourly);
Works(but browser closes automatically):
http://hg.mozilla.org/mozilla-central/rev/7a62a113eeb0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101105 Firefox/4.0b8pre ID:20101105132006
Fails:
http://hg.mozilla.org/mozilla-central/rev/c609be50b0b2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101105 Firefox/4.0b8pre ID:20101105170428
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6f059cc830cc&tochange=c609be50b0b2
Sorry, It is not necessary to wait for 15 seconds

It seems that  this behavior may be intentional by Bug 595521.

However, I think that
*It should close the browser when i click Close button at the top-right corner of window.
*It should return to tab browser when I push ctrl + E (a new tab will be added).
Summary: Can not return to tab browser and can not close the browser, when it passes for 15 seconds when I closed tab group in Panorama → Can not return to tab browser and can not close the browser, when I closed tab group in Panorama
We found that most users expected the be returned to Firefox when closing Panorama. It's useful to think of Panorama as a window on top of firefox.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
The problem is that, in this case, you cannot close Panorama to get back to browsing in Firefox. You can't close Firefox as a whole, either. You are locked in the Panorama window until you either 'Undo Close Group' or create a new tab.

In my opinion you should always be able to get out of Panorama. If there are no tab groups or orphan tabs left, clicking the close Panorama button should simply create a new tab and send you back to browsing.

I ran into this problem yesterday and was surprised to see WONTFIX when I went searching for it today. I think there was a misunderstanding of what this bug was about. Hopefully someone is willing to look into this again?
Ah. If what you are looking for is either a way to exit Firefox while in Panorama, this is currently available on the Mac via cmd+q and we have a bug for it in Windows is bug 608330. 

If the bug is for changing the behavior so that it is possible to close the Panorama UI with the undo close group notification still up, I'd be interested. We have, however, made an explicit decision to make it difficult to close the browser from the Panorama UI.
Yes, making the "exit Panorama" command (cmd-E, ESC, the button, etc.) synonymous with "create new tab" when there is nothing left but a "undo close group" on the screen seems like a great suggestion.  Assigning to Aza for design approval.
Assignee: nobody → aza
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Thanks.

This bug appears to be fixed via bug 608158.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Verified in recent nightly minefield build
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.