Last Comment Bug 614721 - Remove some DirectDraw left overs
: Remove some DirectDraw left overs
Status: VERIFIED FIXED
[good first bug]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla7
Assigned To: Matheus Kerschbaum
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 562746 606990
Blocks: 614720 664311
  Show dependency treegraph
 
Reported: 2010-11-24 18:03 PST by Matheus Kerschbaum
Modified: 2011-08-30 15:21 PDT (History)
8 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.40 KB, patch)
2010-11-30 17:37 PST, Matheus Kerschbaum
bugzillamozillaorg_serge_20140323: feedback-
Details | Diff | Splinter Review
patch (4.78 KB, patch)
2010-11-30 22:20 PST, Matheus Kerschbaum
joe: review+
jmuizelaar: review+
Details | Diff | Splinter Review
patch for checkin (4.03 KB, patch)
2011-06-08 21:59 PDT, Matheus Kerschbaum
matjk7: review+
mounir: checkin+
Details | Diff | Splinter Review

Description Matheus Kerschbaum 2010-11-24 18:03:31 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre
Build Identifier: 

See bug 606990 comment 9.

Reproducible: Always
Comment 1 Serge Gautherie (:sgautherie) 2010-11-24 23:28:00 PST
(In reply to comment #0)
> See bug 606990 comment 9.

{
Serge Gautherie (:sgautherie)      2010-11-24 15:05:59 PST

Indeed, it looks like a few more occurrences could be remove, see
http://mxr.mozilla.org/mozilla-central/search?string=DDRAW&case=1
"Found 14 matching lines in 6 files"
}
Comment 2 Matheus Kerschbaum 2010-11-30 17:37:48 PST
Created attachment 494259 [details] [diff] [review]
patch
Comment 3 Serge Gautherie (:sgautherie) 2010-11-30 18:29:06 PST
Comment on attachment 494259 [details] [diff] [review]
patch

>diff --git a/gfx/cairo/cairo/src/cairo-ddraw.h b/gfx/cairo/cairo/src/cairo-ddraw.h

I'm not sure that cairo files should be touched.

>diff --git a/gfx/cairo/d2d.patch b/gfx/cairo/d2d.patch
> @@ -2009,7 +2010,8 @@ typedef enum _cairo_surface_type {
>-+    CAIRO_SURFACE_TYPE_DDRAW,

Morevover, you can't modify a patch number of lines without updating its header.
Comment 4 Matheus Kerschbaum 2010-11-30 22:20:29 PST
Created attachment 494316 [details] [diff] [review]
patch

Serge's comments addressed.
Comment 5 Serge Gautherie (:sgautherie) 2010-12-04 01:12:18 PST
Comment on attachment 494316 [details] [diff] [review]
patch

(In reply to comment #3)
> >diff --git a/gfx/cairo/cairo/src/cairo-ddraw.h b/gfx/cairo/cairo/src/cairo-ddraw.h
> 
> I'm not sure that cairo files should be touched.

This file may be a Mozilla file rather than a (imported) Cairo file actually,
so it might be fine to remove it.
In that case, you would need to "update"
http://mxr.mozilla.org/mozilla-central/search?string=cairo-ddraw.h&case=1&find=%2Fgfx%2Fcairo%2Fcairo%2Fsrc%2F
{
/gfx/cairo/cairo/src/Makefile.in
    * line 170 -- EXPORTS_cairo += cairo-ddraw.h
}
too.
A reviewer will tell you...
Comment 6 Joe Drew (not getting mail) 2011-03-14 10:58:30 PDT
Comment on attachment 494316 [details] [diff] [review]
patch

Looks good. I'm not sure if we still need _STRETCH32/_STRETCH24, though. Jeff can look at this too.
Comment 7 Jeff Muizelaar [:jrmuizel] 2011-04-01 14:19:57 PDT
I'd rather the cairo change wait for the cairo update.
Comment 8 Jeff Muizelaar [:jrmuizel] 2011-06-06 08:07:42 PDT
Comment on attachment 494316 [details] [diff] [review]
patch

This may need to be rebased, but the content is good.
Comment 9 Matheus Kerschbaum 2011-06-08 21:59:02 PDT
Created attachment 538170 [details] [diff] [review]
patch for checkin

Updated to tip and added commit message.
Comment 10 Mounir Lamouri (:mounir) 2011-06-10 09:59:07 PDT
Comment on attachment 538170 [details] [diff] [review]
patch for checkin

Pushed to inbound.
Comment 11 :Ehsan Akhgari (away Aug 1-5) 2011-06-10 13:17:24 PDT
http://hg.mozilla.org/mozilla-central/rev/635d71b87150
Comment 12 Mihaela Velimiroviciu (:mihaelav) 2011-08-29 07:10:05 PDT
Verified the files 

gfx/thebes/gfxWindowsPlatform.cpp
gfx/thebes/gfxWindowsPlatform.h
widget/src/windows/nsWindowGfx.cpp 

were updated in mozilla-central repository.
Is this enough to verify the fix?

Thank you!

Note You need to log in before you can comment on or make changes to this bug.