Last Comment Bug 664311 - Remove WinCE code from gfx/
: Remove WinCE code from gfx/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla7
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on: 614721
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-06-14 15:31 PDT by Ed Morley [:emorley]
Modified: 2011-06-18 02:52 PDT (History)
0 users
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from gfx (25.54 KB, patch)
2011-06-14 16:13 PDT, Ed Morley [:emorley]
jmuizelaar: review+
Details | Diff | Splinter Review
Remove WinCE code from gfx (25.47 KB, patch)
2011-06-16 00:47 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-06-14 15:31:54 PDT
WinCE & Windows Mobile code has almost completely been removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the gfx/* parts of the removal, and continues on from the DDRAW removal in bug 614721.

http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/gfx/
Comment 1 Ed Morley [:emorley] 2011-06-14 16:13:14 PDT
Created attachment 539356 [details] [diff] [review]
Remove WinCE code from gfx

Also removes MOZ_FT2_FONTS ifdefs in gfxWindowsPlatform.h, since MOZ_FT2_FONTS is no longer defined: http://mxr.mozilla.org/mozilla-central/search?string=MOZ_FT2_FONTS

The changes to cairo are only to parts that did not come from upstream in the first place (they were added by wince-fixes.patch, which itself is rm'd in this patch).

http://dev.philringnalda.com/tbpl/?tree=Try&rev=361426a16bb8

Thanks :-)
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-06-14 16:53:17 PDT
Comment on attachment 539356 [details] [diff] [review]
Remove WinCE code from gfx

I only took a quick look and provided this doesn't break anything it looks good.
Comment 3 Dão Gottwald [:dao] 2011-06-15 21:44:31 PDT
patching file gfx/thebes/gfxWindowsPlatform.cpp
Hunk #1 FAILED at 53
1 out of 7 hunks FAILED -- saving rejects to file gfx/thebes/gfxWindowsPlatform.cpp.rej
Comment 4 Ed Morley [:emorley] 2011-06-16 00:47:01 PDT
Created attachment 539741 [details] [diff] [review]
Remove WinCE code from gfx

Fix failed hunk due to bug 663784 landing after checkin-needed was set. No other changes, carrying forwards r+.
Comment 5 Ed Morley [:emorley] 2011-06-18 02:51:26 PDT
http://hg.mozilla.org/mozilla-central/rev/4a20515c93d5

Note You need to log in before you can comment on or make changes to this bug.