Firefox (Fx) menu button doesn't appear in panorama view

RESOLVED WONTFIX

Status

defect
P3
normal
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: aravind, Unassigned)

Tracking

({helpwanted})

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [visual][ux])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Build identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101203 Firefox/4.0b8pre

Steps to reproduce:
==================
Open Firefox and go to panorama view

Actual Result:
==============
Firefox(Fx) button does not appear

Expected Result:
================
Firefox(Fx) button should appear

Comment 1

9 years ago
That seems bad to me. Anyone else on linux confirm?
Blocks: 597043
blocking2.0: --- → ?
Priority: -- → P1

Comment 2

9 years ago
(In reply to comment #1)
> That seems bad to me. Anyone else on linux confirm?

Yes, I can confirm on Linux.

Updated

9 years ago
Blocks: 598154

Comment 3

9 years ago
Beta8 has 1 bug left on it, moving our blockers to b9
No longer blocks: 597043
If Panorama was a potential default view (ie, you could start the browser and be in it, or browse while in it), then I'd consider blocking on this. But since it's a transient view, I'm not concerned about the Firefox menu being present. Well, not concerned enough to hold the release for this change.
blocking2.0: ? → -
(In reply to comment #4)
> If Panorama was a potential default view (ie, you could start the browser and
> be in it, or browse while in it), then I'd consider blocking on this. But since
> it's a transient view, I'm not concerned about the Firefox menu being present.
> Well, not concerned enough to hold the release for this change.

For what it's worth, you can start in it if you quit in it (or at least you will be able once bug 608330 or bug 617352 lands), if sessionrestore is on.

Comment 6

8 years ago
bugspam (moving b9 to b10)
Blocks: 608028

Comment 7

8 years ago
bugspam (removing b9)
No longer blocks: 598154
Blocks: 627096
No longer blocks: 608028
Keywords: helpwanted
Whiteboard: [visual][ux]
Priority: P1 → P3
[bugspam: mitcho's late-night betaN triage; feel free to comment or reverse]
Blocks: 603789
No longer blocks: 627096
Target Milestone: --- → Future
The best way for us to address this is with bug 513159, drawing the Firefox button in the title bar on Linux.

Comment 10

8 years ago
bugspam
Target Milestone: Future → ---
No longer blocks: 603789
bugspam
No longer blocks: 653099
Summary: Firefox (Fx) button doesnot appear in panorama view → Firefox (Fx) menu button doesn't appear in panorama view
bugspam

(Fx7 was branched, removing open bugs from Fx7 meta bug, we won't create new meta bugs for upcoming Fx versions)
No longer blocks: 660175
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.