Two tabs showing in Panorama while one appearing on tab bar

RESOLVED WORKSFORME

Status

defect
P2
normal
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: icecold, Unassigned)

Tracking

unspecified
Future
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101204 Firefox/4.0b8pre

Close button appears when I have only one tab, and the button that open a tab don´t work correctly, it depends on the position of the cursor.
But when I click on Panorama button it displays two tabs: current one and another one which I closed sometime before.
When I click on tab to close in Panorama, it closed whole browser, like there was only one tab instead of two.

Both tabs were in same group in Panorama.

This happens randomly.


Reproducible: Couldn't Reproduce
Happened to me too, only 1 tab was shown in the the tab bar, but 2 in the panorama group.

Comment 2

9 years ago
This is worrisome, but without steps to reproduce, I am not sure we can do much with this. If we can get a reliable STR, I think this should block. 

Until then, keeping this around for ff4.0
Blocks: 585689
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
I'm unable to reproduce this, and there's no STR. It's also possible that recent work has made this much less likely, if not impossible.

Oskar, have you still seen this in more recent builds?
Blocks: 627096
No longer blocks: 585689
Keywords: qawanted
Whiteboard: [WFM?]
Reporter

Comment 4

9 years ago
Yep, I'm still seeing it. But still no STR...
I had few (4-5) tabs opened, and somehow I couldn't close one tab. (blank page)
When I got into Panorama, the blank page was actually a previous closed tab, which I couldn't even close in Panorama.
So only option was to exit Firefox.
This happened today, and last time it happened was the date I reported bug.
Btw. I'm not using Panorama.
We're going to need a concrete STR or perhaps a video to really try to reproduce this.

Oskar, does this happen on a clean profile for you?
[bugspam: mitcho's late-night betaN triage; feel free to comment or reverse]
Blocks: 603789
No longer blocks: 627096
Target Milestone: --- → Future
Reporter

Comment 7

9 years ago
Sorry for late reply.
Even with new profile - it didn't happen.
Great. Thanks for letting us know.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Keywords: qawanted
Resolution: FIXED → WORKSFORME
Whiteboard: [WFM?]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.