Last Comment Bug 622410 - Vertical scrolling with trackpoint (Thinkpad, Synaptics drivers) still won't work
: Vertical scrolling with trackpoint (Thinkpad, Synaptics drivers) still won't ...
Status: RESOLVED WORKSFORME
[widgetremoval]
: qawanted, regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 17 votes (vote)
: ---
Assigned To: Cameron McCormack (:heycam) (away Jun 25 – Jul 10)
:
Mentors:
: 644377 645135 670301 (view as bug list)
Depends on:
Blocks: 594977
  Show dependency treegraph
 
Reported: 2011-01-02 04:56 PST by Ivan Ičin
Modified: 2012-11-26 17:08 PST (History)
53 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
-


Attachments

Description Ivan Ičin 2011-01-02 04:56:31 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110101 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20110101 Firefox/4.0b9pre

As bug 594977 is fixed and scrolling still doesn't work for me, I am filing this bug.

There is something strange though: When I start Firefox with many tabs open and it is busy and doesn't react to commands immediately, I can see Firefox reacting to Thinkpad Nav, and scrolling (with a lag as it is busy, but in right direction).

Other than that with ui.trackpoint_hack.enabled I get following results from Winspector Spy:
- I see no Scrollbar class, and I don't see any messages to Mozilla UI Window Class

Reproducible: Always
Comment 1 Ivan Ičin 2011-01-02 05:03:43 PST
With hack set to 0, I see faketrackpointscrollable class, and it receives message: WM_MOUSEWHEEL on scrolling with trackpoint. But it doesn't scroll

And my driver version is 13.2.3. And I would really like to update it to something newer and scroll like a normal man, but if someone is willing to take on this bug, I am still waiting.
Comment 2 Ivan Ičin 2011-01-02 05:04:23 PST
(In reply to comment #1)
> With hack set to 0
I was to quick in writing this, it is not 0, but -1, default value
Comment 3 Ed Morley [:emorley] 2011-01-02 07:36:21 PST
Does scrolling work fine using 3.6.13? (If so will mark as regression)
Comment 4 Ivan Ičin 2011-01-02 07:42:30 PST
Yes it works fine with 3.6!

But after that fix in bug 594977 I see some improvements, so I get some brief scrollings now.
Comment 5 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-02 13:45:25 PST
It's quite possible the driver's heuristics changed between v11 and v13.  Is there somewhere the v13 drivers can be downloaded from?
Comment 6 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-01-02 13:48:02 PST
Ivan, is your build using D3D9? If you turn off acceleration completely, does scrolling work?
Comment 7 Ivan Ičin 2011-01-02 14:07:40 PST
I am not so much into Mozilla development to answer that without searching. But if you give me some guidelines it won't be a problem.

Just to mention again, but with one more specific detail, that scrolling somewhat works briefly while page is loading (not just browser start), after that there is no way to make it work. And I have that brief scroll even with hack set to -1.
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-01-02 14:13:03 PST
In the Options dialog, select the Advanced panel. Then open the General tab for the setting to turn off hardware acceleration.
Comment 9 Ivan Ičin 2011-01-02 14:28:07 PST
OOps, I knew those dialogs when it was Firefox 1, funny I don't know there is option now :)

Anyway, yes, I have accelerated graphics enabled.

I think it is the same when I disable it. But I discovered some more. 

Scrolling works quite frequently on this page:
http://www.myspace.com/timomaas/music/songs/we-are-nothing-29445364

(well find some other tune there if you like more, it should be the same ;) )

What I want to say is that I can scroll there very frequently, but not always.
Comment 10 Ivan Ičin 2011-01-05 13:42:10 PST
Now, I found one incredible thing:
horizontal scrolling, which never worked before, now works! Not briefly, not now and then, but really works.

All with hack set to -1
Comment 11 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-06 18:53:22 PST
I have tried one (random) revision each of v11, v12, v13, v14 and v15 of the stock Synaptics drivers, and with all of them scrolling works properly.  With the stock drivers, the hack isn't turned on by default, since it is looking for some UltraNav-specific registry keys.  I tried a few of those versions with the hack forced on, and it still worked.

I will see if I can obtain a v13 of the UltraNav-specific version of the driver.
Comment 12 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-06 20:08:53 PST
Found one.  The Lenovo site said it was for Windows 7 only, but it seems to install OK on XP.  For me, its behaviour is the same as the v11 UltraNav-specific driver: scrolling works in 3.6, is broken in 4.0b7, and works again in a nightly.

I will try to get my hands on a ThinkPad running Windows 7 next.
Comment 13 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-06 23:25:49 PST
I've got a Thinkpad T41p running Windows 7.  With v13.2.4.12 of the UltraNav driver (which is what it already had installed) and with v13.2.3 (which I replaced it with), scrolling works for me.
Comment 14 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-01-09 20:34:39 PST
I'm going to remove blocking status based on that research.

If we get more information indicating there's a large population of users still suffering from this, we can renominate.
Comment 15 Ivan Ičin 2011-01-10 14:05:21 PST
If someone doesn't think it is a bad idea, I will be updating to new version of Synaptics driver at the end of the week. Actually as things are unclear now, I think it would be useful information whether this works with new version of drivers on my Thinkpad or not.
Comment 16 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-10 14:47:23 PST
OK, thanks for your patience and efforts, Ivan.
Comment 17 Navid 2011-01-10 17:19:27 PST
The scrolling in the latest version of Minefield wasn't working for me, until I updated my Synaptics driver to the latest version.  Should there be some documentation or errata indicating the requirement of a new driver?
Comment 18 Tad 2011-01-14 04:19:33 PST
I have same problems in the Minefield(4.0b10pre buildID:20110111030357).
Using Windows XP(SP3) and Lenovo's ThinkPad USB Keyboard with TrackPoint(http://www-307.ibm.com/pc/support/site.wss/MIGR-73183.html),

I know that keyboard's driver sends Ctrl+K when user tries to scroll,
so I disabled Ctrl+K with keyconfig.
and also configured 'ui.trackpoint_hack.enabled' from -1 to 1,
but scrolling is still not working.

In Firefox 3.6 in same computer(with Ctrl+k disabled,hack enabled),
scrolling is working very fine.
So, i think that there's something wrong with 'ui.trackpoint_hack.enabled'in latest Minefield.
Comment 19 Ivan Ičin 2011-01-14 04:44:47 PST
Hey, I think that I know why my bug report couldn't been reproduced.

I don't use touchpad, but trackpoint (and I think it is somewhere referenced as Thinkpad Nav as I have called it). Anyway, touchpad works, I have tried it now. But trackpoint doesn't. You have probably tested only with touchpad Cameron?
Comment 20 Ivan Ičin 2011-01-14 07:54:05 PST
As there are two more confirmations that it doesn't work on Trackpoint and that it works on touchpad (which probably led to confusion that it works), I think this should be renominated.
Comment 21 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-16 13:53:58 PST
With the stock Synaptics drivers, the Trackpoint doesn't work at all (which is kind of to be expected).  As for the UltraNav drivers, the only versions I have available to me are

  * v11.1.21.2, which bug 594977 fixes with the hack
  * v13.2.3.0, which works for me without the hack
  * v15.1.19, which works without the hack

This is for both the trackpad and the trackpoint.
Comment 22 Ivan Ičin 2011-01-16 15:42:26 PST
I have just updated through Windows update to TnikPad Nav driver version 15.0.8... and surprise... it still doesn't work with or without hacked enabled (I have expected it to work, according to previous reports).

I can think only of the fact that my Thinkpad came with Vista and I updated it with Lenovo update disk to Windows 7. I have no idea if it can cause any difference, but that is the only thing I can think of now.
Comment 23 Ivan Ičin 2011-01-16 15:50:06 PST
Some more games:

with new driver touchpad scrolling doesn't work any more. Except in one case:
- when I move pointer with trackpoint and try to scroll with touchpad at the same time, scrolling always works!
Comment 24 jerelahtinen 2011-01-19 23:58:24 PST
I´m using the latest synaptics driver (v15_1_22_2) and I am confirming that vertical nor horizontal scrolling is not working.
Comment 25 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-01-20 17:57:12 PST
Ivan/jerelahtinen, what model laptops are you on?
Comment 26 Leandro Lameiro 2011-01-20 19:30:24 PST
I can confirm that the *touchpad* doesn't work for me in Beta 9. I tried disabling hardware acceleration, setting the hack to -1, 0 and 1.

This is a regression from Firefox 3.6, which worked fine.

Synaptics *touchpad* driver version is 14.0.3.0 27/08/2009.

I also have the same behavior described by Ivan in comment #1, when firefox starts up and has a lot of tabs to load, scrolling works for some seconds, then stops working. 

Using Windows XP SP3, laptop is an HP Elitebook 8530w. 

Let me know if you need more info.
Comment 27 jerelahtinen 2011-01-20 23:16:28 PST
HP ProBook 5320m, windows 7 pro 64-bit.
Comment 28 Ivan Ičin 2011-01-21 02:10:12 PST
I think I sent you that info, but it is Lenovo ThinkPad SL500 type 2746-ABG, Windows 7 Professional 32-bit upgraded from Windows Vista Business.
Comment 29 jerelahtinen 2011-01-26 11:07:49 PST
Fixed in 4.0b10 :)
Comment 30 Dale 2011-01-26 13:18:56 PST
I added a Thinkpad keyboard to my Windows XP Dell laptop.  Trackpoint uses Lenovo driver 1.0.0.0 (6/17/2009).

The middle button on the keyboard is configured to scroll vertically, but what happens is the scrolling messages are going to the search widget, even though my cursor is over the web page.

In other words, when I click the middle button and adjust the trackpoint joystick, all of the searches I've done recently begin showing, and they get highlighted.  Its as if I selected the search drop down and hit down, down, down..

Here's a work-around:
If I right click the page and get to the context menu, then click the middle button and adjust the trackpoint joystick, the page scrolls properly.

Will this be fixed in 4.0b10?  I'm running 3.6.13.
Comment 31 Alexander Weber 2011-02-07 16:50:12 PST
same issue on W7x64 w/ Minefield 4.0b12pre (2011-02-07) x64 and Synaptics driver 15.1.6.2 (2010-06-08) for Dell.
SynTPEnh.exe and the pointer hangs with ~13 CPU. A restart of the process solves the problem and mouse moves again until the first scroll in FF....
Comment 32 Brad Huizenga 2011-02-08 19:03:10 PST
I'm using a hacked driver 15.0.9.0 dating in Feb 2010 meant for HP laptops, using it on my thinkpad (to enable middleclick when both trackpad buttons are pressed. i hate synaptics drivers debacle). 

No Scroll in FF4b11, works fine in Chrome and FF3.6. Trackpad does not scroll at all in horizontal or vertical, and the continuous circle-scrolling doesnt work either.

Works fine with external mouse.

I notice that I have the goofy synaptics "SCROLLING IS HAPPENING!!" mouse cursors, and this method of scrolling is buggy with certain other software (like Steam, for instance) too.

A lot of people may be unable to update their drivers for their trackpads, as manufacturers have a tendency to leave old machines in the dust. I'm aware synaptics has generic drivers available, but the generic drivers are ancient and lack many features.
Comment 33 Stefan Katschewitz 2011-03-11 14:35:23 PST
Well, just upgraded from 3.6 to 4 RC and i'm not able to Scroll with my
Trackpoint (SL300, Alps 7.2.1623.307) in any direction. Any other program works fine.

Windows 7 32Bit
Comment 34 raid8882003 2011-03-17 04:00:51 PDT
I also have this problem while I am using Lenovo X200. OS is Window Vista 32bit.
Comment 35 thorbjoern.skjetne 2011-03-18 09:20:48 PDT
Really weird, scrolling seems to be working while FF loads, but breaks after all tabs are loaded.

Latest synaptics driver, Firefox RC1
Comment 36 David Jameson 2011-03-23 14:03:58 PDT
Here is a workaround that works for me (Thinkpad T42 running XP):

- edit C:\Program Files\Synaptics\SynTP\tp4table.dat and add the following lines:

; Firefox 4
*,*,firefox.exe,*,*,*,WheelStd,1,9

Then reboot. This is the workaround mentioned by Stefan in bug 605357.
Comment 37 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-03-24 02:34:50 PDT
*** Bug 644377 has been marked as a duplicate of this bug. ***
Comment 38 Jason Keplinger 2011-03-24 04:23:35 PDT
I just saw a couple of guys having scrolling working while tabs load then stop. 
I guess I over looked those comments before.
I tried it myself. And can confirm that it is working until the tabs finish loading.

Windows 7 64bit Ultimate Edition
HP DV6-1238NR; AMD Turion X2
Comment 39 Matthias Versen [:Matti] 2011-03-25 16:19:09 PDT
*** Bug 645135 has been marked as a duplicate of this bug. ***
Comment 40 Jason Keplinger 2011-03-26 07:32:43 PDT
From bug 645135, Matthias Versen, the newest driver from Synaptics 15.2.7.0 (12/22/2010 obtained a couple of days back) does not allow scrolling to work, except for when you have a sufficiently large number of tabs open at start up of the browser, then it stops working once they are all loaded. Further, it doesn't seem to always offer some brief scrolling, probably due to amount of content to get. Which means, it's either enough tabs or enough content to allow brief scrolling.

I hope this gets fixed soon.

Also, for the Windows API, there is no scrolling as you mentioned, but there is the mouse messages for scrolling available from what I recall. It has been a long time since I've last written anything in strict Win32 API.
Comment 41 Uli Stärk 2011-03-26 09:03:27 PDT
I could fix it for my IBM X40 using Windows XP. See bug 605357. You have to alter your tp4table.dat (trackpoint driver config) as Stefan Katschewitz described.
Comment 42 Ivan Ičin 2011-03-26 09:53:09 PDT
This bug is for Windows 7, as described above. I don't think that there is a work around in that case.
Comment 43 Brad Huizenga 2011-03-28 09:53:27 PDT
Sad to see this was not fixed in time for release.
Comment 44 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-04-01 14:04:58 PDT
*** Bug 645135 has been marked as a duplicate of this bug. ***
Comment 45 Ivan Ičin 2011-04-14 10:59:47 PDT
Well, probably expected, but I have just updated to Windows 7 SP1, and nothing has changed. Had some hopes though ;)
Comment 46 YANO Takashi 2011-04-22 13:19:37 PDT
(In reply to comment #18)
> I have same problems in the Minefield(4.0b10pre buildID:20110111030357).
> Using Windows XP(SP3) and Lenovo's ThinkPad USB Keyboard with
> TrackPoint(http://www-307.ibm.com/pc/support/site.wss/MIGR-73183.html),
The problem is solved at the new driver 1.0.7 release on Apr 20 2011.
Comment 47 u354703 2011-06-10 01:23:52 PDT
same problem 4.0b1 acer 4740G netbook windows 7
Synaptics PS/2 Device driver 15.2.20.0

i noticed that scrolling works fine inside the PDF extension even when its not working on web pages.
Comment 48 u354703 2011-06-10 03:29:18 PDT
i just realized when i have a tab with the adobe extension and when i switch tabs and scroll, even though my tab doesnt scroll the pdf file in the other tab has scrolled down. its like the pdf didnt return the pointer focus back to firefox
Comment 49 Stefan Katschewitz 2011-06-10 03:31:43 PDT
I got this thing too, but it is not limited to my Laptops-Trackpoint but appears with my Mouse too and even on my Desktop-PC.
Comment 50 Ludovic Hirlimann [:Usul] 2011-07-11 01:57:36 PDT
*** Bug 670301 has been marked as a duplicate of this bug. ***
Comment 51 Carlos Mora 2011-07-24 13:08:20 PDT
I'm having this problem in a fresh install of FF 5.0.1/Win7 32bits, and the latest drivers from synaptics on a Acer Travelmate 7320.
Synaptics TouchPad Driver Version 15.2.20 31Mar11 
HW as reported by Synaptic driver (spanish):

Módulo: TouchPad Series 2.0 - Profile Sensor 

TP FW: V6.3 

Interfaz: PS2 

Versión de Windows: 6.1
Comment 52 Petr Tomes 2011-10-07 12:55:52 PDT
I can confirm this bug.

Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111006 Firefox/9.0a2
Comment 53 Petr Tomes 2011-10-07 13:08:52 PDT
EEE PC Seashell 1215N
Synaptics PS/2 Port TouchPad 19.11.2009 14.0.16.0
Comment 54 Ivan Ičin 2011-10-07 13:15:10 PDT
One amazing and potentially useful information:

Thunderbird 6 had this same behavior - trackpoint didn't work, but Thunderbird 7 has no problems. Have no idea how it is possible as even Aurora 9.0a2 (2011-10-07) still has problems.
Comment 55 YANO Takashi 2011-10-07 17:02:34 PDT
I am using ThinkPad X301. ThunderBird 7 has the problem.
Comment 56 YANO Takashi 2011-10-07 18:11:41 PDT
I add

*,*,thunderbird.exe,*,*,MozillaWindowClass,WheelVkey,0,9

to tp4table.dat and the problem is solved.
Comment 57 Petr Tomes 2011-10-08 01:21:51 PDT
I've downloaded the current Synaptics driver 15.2.20 from http://www.synaptics.com/resources/drivers and the bug still occurs in any Firefox release I've tried (4, 5, 6, 7, 8 beta, 9 aurora, 10 nightly). :(
Comment 58 Petr Tomes 2011-10-08 12:08:27 PDT
I believe this bug should be confirmed and switch to the new status and seriously considered for tracking or blocking Firefox Nightly (10) at least since there is no workaround to solve this annoyance.
Comment 59 dave kochman 2011-11-12 10:09:18 PST
I've also been experiencing this issue since somewhere around FF5 when a tab using Acrobat is active with various versions of the Synaptics drivers. Scrolling focus in other tabs is rstored following closure of any Acrobat tabs.

As a workaround if you need to keep pdfs available for fast viewing in your tab session until this is resolved, consider turning on the 'Don't load tabs until selected' option and restart FF.
Comment 60 Timothy Nikkel (:tnikkel) 2011-11-12 20:36:25 PST
There is a separate bug for the Acrobat specific issue. (Can't find it right now.)
Comment 61 Ivan Ičin 2011-11-13 03:26:08 PST
(In reply to Timothy Nikkel (:tn) from comment #60)
> There is a separate bug for the Acrobat specific issue. (Can't find it right
> now.)

I think this is right, as I reported this bug, I can confirm that scrolling works only in Adobe Reader plugin.

So it is... opposite bug ;)
Comment 62 David Tenser [:djst] 2012-02-01 06:28:13 PST
How is this bug different from bug 626813? They seem to both mention the PDF plugin issue.
Comment 63 Ivan Ičin 2012-02-01 11:00:37 PST
(In reply to David Tenser [:djst] from comment #62)
> How is this bug different from bug 626813? They seem to both mention the PDF
> plugin issue.

As far as I understand bug 626813, it is that when you open pdf scrolling doesn't work on Windows 7. Should be on every computer, that is marked major.

This bug is that scrolling doesn't work at all on some Windows 7 computers (mostly Lenovo). It does work in pdf but that is not part of reproducing bug.
Comment 64 Marvin Enders 2012-02-06 11:12:49 PST
The PDF references are taking this topic in the wrong direction.

The TrackPoint bug is still not working with Thunderbird 10.0, Lenovo x200 with a PS/2 TrackPoint (driver provided by Lenovo dated 12 Nov 09 ver 4.71.0.0) and Visa Business.
Comment 65 Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2012-02-10 17:27:21 PST
Yes, the scrolling not working when a plugin is on the page is probably a different issue.  There's bug 626813 and bug 725475 for that.  I am interested in knowing if the proposed fix for bug 725475 does help with this bug, though (since it does some more messing with hidden scrollbar windows to trick the trackpad driver into giving us the scrolling message).  Please try this build:

  https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/cmccormack@mozilla.com-e6fe32a87603/try-win32/firefox-13.0a1.en-US.win32.zip
Comment 66 Ivan Ičin 2012-02-11 01:49:32 PST

(In reply to Cameron McCormack (:heycam) from comment #65)
> try this build:
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/
> cmccormack@mozilla.com-e6fe32a87603/try-win32/firefox-13.0a1.en-US.win32.zip

No changes. With all three trackpoint hack values.
Comment 67 Emanuele Bellini 2012-02-18 03:28:43 PST
I can add Acer to the manufacturers using a Synaptics touchpad. I've got this issue in Thunderbird, too.
Comment 68 Ronald Hunter 2012-03-19 08:22:09 PDT
HP/Compaq also uses Synaptics touchpads on some models.  I have found scrolling to be distinctly flaky but NOT just with Firefox, although this is the most frequent program with a problem.  A recent update to the Synaptics driver seems NOT to have helped, but I do find that when it refuses to scroll as normal, when using the scroll bar, I can make it scroll with two-finger scrolling.  Annoying, to be sure, but not fatal.  I am using my wireless mouse MUCH more often now.
Comment 69 Emanuele Bellini 2012-03-19 16:25:17 PDT
Mine works now with Firefox 11, with Thunderbird 11 too. Works for me.
Comment 70 jaitsu@ymail.com 2012-04-14 01:39:46 PDT
Confirmed having this problem on 12.0b5. Scrollbar does not work with either the edge scroll or two finger scroll features of the touchpad on an Asus G72GX-RBBX05 Synaptics touchpad. Drivers are not the most recent available (as the most recent ones cause other bugs irrelevant to Firefox) but are the most recent OEM-recommended drivers for the touchpad. ui.trackpoint_hack.enabled value doesn't make any difference.
Comment 71 jaitsu@ymail.com 2012-04-15 05:20:48 PDT
(In reply to jaitsu@ymail.com from comment #70)
> Confirmed having this problem on 12.0b5. Scrollbar does not work with either
> the edge scroll or two finger scroll features of the touchpad on an Asus
> G72GX-RBBX05 Synaptics touchpad. Drivers are not the most recent available
> (as the most recent ones cause other bugs irrelevant to Firefox) but are the
> most recent OEM-recommended drivers for the touchpad.
> ui.trackpoint_hack.enabled value doesn't make any difference.

Disregard my previous comment, or at least part of it. Seems the trackpoint hack setting didn't stick the first time. Just set it again (to 1) and scrolling seems to work properly now. Still having trouble with it off, however.
Comment 72 j.carpenter 2012-04-20 14:25:57 PDT
After upgrading to Firefox ESR v10.0.3 on my Thinkpad R400, WinXP system, the vertical scroll no longer works.  It works fine in other applications and worked in the previous version of Firefox the 3.x version.

Please help get this fixed and change the status to "confirmed".  Looks to me like several people are having scrolling problems.
Comment 73 ashvin.gandhi 2012-04-20 14:36:18 PDT
I am still having issues with thunderbird
Comment 74 Aleksey 2012-04-20 14:41:01 PDT
I'm not sure my problem is related to exactly this bug, but I have problems with vertical scrolling too on my tabletpc Acer Iconia Tab W500 on Windows7 (FF9-10-11)
Comment 75 Ivan Ičin 2012-04-20 14:45:17 PDT
Maybe public trashing like this: http://www.zdnet.com/blog/networking/firefox-11-review-firefox-has-jumped-the-shark/2162?tag=mantle_skin%3Bcontent (it contains link to disk bug, btw) make this confirmed. You know, like if it is on TV it is truth ;).
Comment 76 nihar2 2012-04-24 10:57:32 PDT
I'm using a Dell Studio 1558 with Windows 7 x64. Scrolling works occasionally, mostly not on my Firefox 11. It is extremely annoying to have to use the keyboard or scrollbar to move vertically.
Comment 77 Emanuele Bellini 2012-04-24 12:56:20 PDT
Works for me (almost). Multi-touch is supported for zooming but not for back/forward gestures. But this is secondary...!
Comment 78 john ruskin 2012-05-07 21:08:22 PDT
Vertical scrolling falls in and out of functionality.   I am suspicious of pages with flash inserts, as these pages seem to be active when I notice that the scroll becomes dysfunctional.   I also notice that the scroll will sometimes return to functionality, without a restart of Fox.  I can not isolate why the touch pad returns to functionality

When vertical scrolling fails on Fox, it still works in T-Bird

I have segregated this problem from the one where tapping becomes dysfunctional on the touchpad, and restored by resetting the device using the touchpad device settings.  This problem does -not- seem to be associated with loss of vertical scrolling.  When the tapping function becomes dysfunctional, it behaves as such on all running software.

I am using Fox v 12.0 [up to date], and an HP pavillion g7 laptop, TouchPad V7.5, with this version of the synaptic driver set, which is reported by Win7 as up to date: 15.3.29 of 13Oct11
Comment 79 mihajlov1982jw 2012-05-10 06:36:14 PDT
Спасибо, очень интересно! С огромным ( http://kalibrplus.ru/ ) уважением ( http://protostob.ru/ ) Вадим ( http://aurajob.ru/ ) Петрович ( http://aurorium.ru/ ) Трофимов ( http://palladium-master.ru/ )
Comment 80 Simon Sheehan 2012-05-16 10:30:01 PDT
Mine is temperamental also. Sometimes it works fine, other times I go for hours without it working. I am using a Lenovo Y570. 

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 81 Chris Cowan 2012-05-30 02:54:00 PDT
Just installed Firefox 12 on a Dell XPS 17 and scrolling and zooming don't work with the trackpad at all in Windows 7. Scrolling works perfectly fine with other programs I've tested including Internet Explorer. Scrolling with a USB mouse works in Firefox.

Firefox works perfectly fine with the trackpad in Ubuntu.
Comment 82 chicagolovr 2012-06-06 12:40:14 PDT
FWIW, I thought I would add... that I have this scrolling problem with an "Elan" Smartpad on a Win7x64 laptop, using SM 2.8.   Since it comes and goes, I had been blaming it on the websites, as I hadn't paid much attention to where I was when it happens the most. [I've had too many other problems with Win7 to inquire about this yet.]   :)
Comment 83 chicagolovr 2012-06-06 17:21:05 PDT
Forgot to say in my comment that I'm using a Gateway NV57H laptop.   Sorry.....
Comment 84 eag5 2012-06-23 14:12:01 PDT
So this has been going on since 2006 and it still hasn't been fixed? Amazing.
Comment 85 eag5 2012-06-23 14:13:54 PDT
This tends to happen when clicking on any youtube video, it also appears to have a problem with adobe flash...is this issue ever going to be looked at?
Comment 86 Ivan Ičin 2012-09-28 06:39:34 PDT
Aurora 17.0a2 (2012-09-27) tried on new profile and it is scrolling like it should now (it still doesn't on old profile). As I have reported this bug, I mark this WFM.
Comment 87 Ivan Ičin 2012-09-30 05:34:23 PDT
Here is some more info for people that still have trouble:

You should check if ui.window_class_override is set to MozillaUIWindowClass and reset that setting and restart Firefox.
Comment 88 ashvin.gandhi 2012-09-30 11:15:58 PDT
Just tried your suggestion, but it still doesn't work for me on Thunderbird. :-(
Comment 89 Ivan Ičin 2012-09-30 14:15:59 PDT
(In reply to ashvin.gandhi from comment #88)
> Just tried your suggestion, but it still doesn't work for me on Thunderbird.
> :-(

Check if you have the latest version. Try with clean profile (start thunderbird -p and choose Create profile). If it doesn't work still submit new bug.

Note You need to log in before you can comment on or make changes to this bug.