Last Comment Bug 626813 - laptop touchpad scrolling doesn't work on other pages/tabs while PDF file is open through browser plugin in any tab in the same window
: laptop touchpad scrolling doesn't work on other pages/tabs while PDF file is ...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: All Windows 7
: -- major with 21 votes (vote)
: mozilla13
Assigned To: Cameron McCormack (:heycam)
:
Mentors:
: 632889 638671 (view as bug list)
Depends on:
Blocks: 709996 130078
  Show dependency treegraph
 
Reported: 2011-01-18 14:16 PST by Raaj
Modified: 2012-02-19 04:54 PST (History)
46 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Hide plugins in background tabs to avoid trackpad drivers wanting to scroll them (1.34 KB, patch)
2012-02-07 15:52 PST, Cameron McCormack (:heycam)
no flags Details | Diff | Splinter Review
Hide plugins in background tabs to avoid trackpad drivers wanting to scroll them. (v1.1) (1.41 KB, patch)
2012-02-07 16:33 PST, Cameron McCormack (:heycam)
jmathies: review+
Details | Diff | Splinter Review

Description Raaj 2011-01-18 14:16:34 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When a PDF is open via browser plugin and when using a laptop touchpad for scrolling, scrolling only works on the PDF and not other tabs. Scroll bar scrolling works though.

Reproducible: Always

Steps to Reproduce:
1.Open a PDF file
2.Open another website on another tab
3.Scroll using laptop touchpad
Actual Results:  
The scrolling does not work on the other tab.

Expected Results:  
The page on the other tab should scroll while using a laptop touchpad.

Bug occurs with default theme.
Comment 1 Mark Z 2011-01-25 20:11:30 PST
Same happens for me with 4b9 and 4b10. Scrolling with the scrollbar on the touchpad is affected. Scrolling with Touchpoint and its middle button works
Comment 2 igor2002 2011-03-30 02:56:39 PDT
Want to Subscribe this Bug! It is pretty much annoying, cause it makes my working harder.
Comment 3 tezchcegrac 2011-05-05 11:28:48 PDT
Also same happens with my touchpad. Im using FF 4.0.1, adobe acrobat 10.0.1, windows 7 64bit. When document in pdf is opened in one tab i cannot scrolling in another tab.
Comment 4 kylehanson 2011-05-13 04:49:39 PDT
I also get this bug, FF 4.0.1, and I agree that it is _super annoying_.

WORKAROUND: Open PDFs in a different _window_ and it won't happen, at least for me (Dell laptop, Windows 7, FF 4.0.1).
Comment 5 Dão Gottwald [:dao] 2011-05-16 14:24:30 PDT
*** Bug 632889 has been marked as a duplicate of this bug. ***
Comment 6 Dão Gottwald [:dao] 2011-05-16 14:25:04 PDT
*** Bug 641299 has been marked as a duplicate of this bug. ***
Comment 7 eyal gruss (eyaler) 2011-05-16 23:37:21 PDT

*** This bug has been marked as a duplicate of bug 273456 ***
Comment 8 meberbs 2011-05-18 09:53:05 PDT
I can confirm that this bug was introduced between beta 4 and beta 5 for Firefox 4. 

Some additional information: mouse wheel scrolling works properly in all tabs even when pdfs are open. Touchpad scrolling works properly in pdf tabs even with multiple open (it may take an extra click to focus on the pdf first). When attempting to scroll in a web tab using the touchpad, the pdf file that was opened most recently scrolls instead. It does not matter which pdf tab last had focus.

Example:

1. open web tab 1
2. open pdf tab 1
3. open pdf tab 2
4. open web tab 2

Results:
The touchpad correctly scrolls the current pdf when either pdf is open.
Pdf tab 2 will scroll whenever the touchpad is used to attempt to scroll one of the web tabs. order of receiving focus does not change this.
If pdf tab 2 is closed, scrolling on a web tab will scroll pdf tab 1.
Comment 9 Ibrahim Jadoon 2011-05-23 23:32:47 PDT
Whoever can mark duplicates:

Bugs 594500 (this one), 626813, and 543027 are ALL THE SAME.

Information:

A reinstall of the Synaptics Touchpad driver (occurs on 15.2.20 and 15.0.24.0; I assume all) did not help.

We know it worked in FF4 beta 4 and broke in FF4 beta 5. Do we need a regression window deeper than that, such as a nightly build? I can try and find one, if no one else has. 

I'm reposting this to both other bugs, in case someone checks those first.
Comment 10 :aceman 2011-05-24 06:44:52 PDT
Thanks, I duped the other ones (albeit to bug 273456).
However, this bug was deduped from bug 273456. Dao, could you explain the difference here?
Comment 11 Dão Gottwald [:dao] 2011-05-24 06:58:40 PDT

*** This bug has been marked as a duplicate of bug 594500 ***
Comment 12 meberbs 2011-05-26 14:31:22 PDT
I do not believe that this is a duplicate of bug 594500. This bug refers to touchpad scrolling, and that one refers to the mouse wheel. The circumstances also appear different, because it seems that the symptoms of the mouse wheel can be resolved at least partially without closing all pdf tabs in the window. The touchpad will not work outside of pdfs until all pdfs are closed.

For more details on the different pdf related bugs see the comments on Bug 594500.
Comment 13 Ibrahim Jadoon 2011-07-25 16:47:01 PDT
You guys wanted a regression window? You got one...found using mozregression tool.

Last good nightly: 2010-08-27
First bad nightly: 2010-08-28

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1d55bbd1d1d&tochange=6e3f6d18c124
Comment 14 Ibrahim Jadoon 2011-07-26 10:52:51 PDT
This problem occurs in the normal Adobe PDF plugin and also the Nitro PDF plugin.  

The PDF also must be in the same window. If you open two Firefox windows (Window A and Window B), only the window with a PDF tab will have the broken scrolling.

Window A: Google tab, PDF tab, CNN tab
Window B: Microsoft tab, Apple Tab, Dell tab

(tab names are examples)

Any scroll event in Window A activated via the touchpad (two-finger scroll, scrolling at the edge of the touchpad) will be INTERCEPTED by the PDF tab, even if the PDF tab is not active.

Any scroll event activated via the touchpad inside Window B will respond normally: scroll events will respond to the active tab only.
Comment 15 Ibrahim Jadoon 2011-07-26 10:55:51 PDT
Also, as per comment 12, may we revert the duplication? This is a separate bug. 

We have a regression window, per comment 13...how can we make this official, as one of the keywords still states "regressionwindow-wanted"? This should accelerate the debug time when a developer looks at, right? So, how do we get a developer to look at this?
Comment 16 Shaunak Dey 2011-07-26 11:00:07 PDT
(In reply to comment #14)
> This problem occurs in the normal Adobe PDF plugin and also the Nitro PDF
> plugin.  
> 
> The PDF also must be in the same window. If you open two Firefox windows
> (Window A and Window B), only the window with a PDF tab will have the broken
> scrolling.
> 
> Window A: Google tab, PDF tab, CNN tab
> Window B: Microsoft tab, Apple Tab, Dell tab
> 
> (tab names are examples)
> 
> Any scroll event in Window A activated via the touchpad (two-finger scroll,
> scrolling at the edge of the touchpad) will be INTERCEPTED by the PDF tab,
> even if the PDF tab is not active.
> 
> Any scroll event activated via the touchpad inside Window B will respond
> normally: scroll events will respond to the active tab only.

I have been facing the same issue(Bug 644226)
Comment 17 Ibrahim Jadoon 2011-07-26 11:36:53 PDT
Also, as per comment 12, may we revert the duplication? This is a separate bug. 

We have a regression window, per comment 13...how can we make this official, as one of the keywords still states "regressionwindow-wanted"? 

Through my rudimentary technical skills, it seems bug 575440 (one bug fixed from 0827) may have something to do with it: https://bugzilla.mozilla.org/show_bug.cgi?id=575440.
Comment 18 Ibrahim Jadoon 2011-07-28 14:13:17 PDT
Maybe so we can narrow this bug down a bit further, we can post our specifications. OS and touchpad should be enough, I think.

Windows 7 64-bit
Synaptics Touchpad v7.2 on driver 15.0.24.0
Comment 19 :aceman 2011-07-29 05:28:53 PDT
I am able to deduplicate, however we must find the differing facts.
So this bug basically says the touchpad scrolling does not work in web tabs while any other pdf tab is open in the FF window? No amount of clicking on other tabs and changing focus fixes this? Only closing all the pdf tabs fixes the scrolling agains? Is that correct?
Comment 20 kylehanson 2011-07-29 05:30:27 PDT
Aceman -- yes
Comment 21 :aceman 2011-07-29 05:55:29 PDT
I could test that but touchpad on my Thinkpad R500 (called UltraNav) does not do any scrolling in FF. It works fine in other programs. Any idea why that is?
Comment 22 :aceman 2011-07-29 06:20:48 PDT
The analysis in comment 13 and comment 17 seems logical. CCing the author of the change in bug 575440.
While I could not reproduce on my machine yet (touchpad seems to not work in FF web tabs, it works only in pdf tabs), I will try on other laptops later in the day. Until then, can anybody confirm this is still seen in FF 7 or 8?
Comment 23 Ibrahim Jadoon 2011-07-29 14:34:03 PDT
Thank you, Aceman! :) Yes, if you would like further detail to why bug 626813 and bug 594500 are different, see bug 594500 comment 33. Further evidence that these are two different bugs can be found at bug 626813 comment 12 and bug 594500 comment 28.

@ comment 19

Yes, you can click over 9000 times, you cannot "reset" the focus to the active tab. It is permanently focused on the PDF tab as long as the PDF tab is open (in the same window, of course, as stated in comment 14). I agree with Kyle.

@ comment 21

Hmm...weird. Is the UltraNav with Synaptics or the UltraNav with Alps? If Synaptics, check out this fix (slightly technical): 

http://forums.laptopvideo2go.com/topic/7103-scrolling-with-synaptics-touchpad/

If it's Alps, are the drivers updated? Have you tried generic/non-Toshiba Alps drivers? I think, like the Synaptics touchapds and most hardware products, you can use non-branded-OEM drivers just fine. Also, did you experience this issue in Firefox 3.6.xx? 

@ comment 22

Firefox 8? Are we on 8, yet? I only see links for Aurora (FF 7) and Beta (FF 6). I'm D/L'ing the latest Aurora build and checking it out; brb.
Comment 24 :aceman 2011-07-29 14:43:29 PDT
Can't comment on the UltraNav questions, I am not allowed to change the drivers, but I think they are about 2 years old, I can check that later. I don't know about FF 3.6 I only opened the lid on the laptop now and used the touchpad to test this bug in FF 5 :) I do not use it normally, have external mouse and keyboard.

However, I have found other older Thinkpad where the scrolling works in web tabs and it also works in pdf tabs. There I do not see this bug 626813.

Yes, Nightly FF is on 8 now.

So let's try to dedupe this bug.
Comment 25 :aceman 2011-07-29 14:50:50 PDT
Ah, forgot the main question :) I have only Win XP available. Has anybody seen this bug on anything outside of Win 7 64bit? That is what the platform field is set to.
Comment 26 Ibrahim Jadoon 2011-07-29 16:35:12 PDT
Oh, haha, gotcha. Sounds good. :D

Ah, OK. I guess there is a difference from Aurora and the Nightly's, then? Aurora Firefox 7 (from 7-29-2011) still exhibits this bug. 

Let me go find Firefox 8! :D

Sorry for the delay; I still haven't gotten used to having two Firefox's installed on my computer (one for regular, one for testing) and I accidentally deleted my regular profile! :o All better now, but, whew...different profile folders this time, lol. :D
Comment 27 Ibrahim Jadoon 2011-07-29 16:51:04 PDT
All right, typing this from Firefox 8.0a1 (2011-07-29). Bug still present in this latest nightly. :(
Comment 28 :aceman 2011-07-29 18:10:05 PDT
Yes, Nightly and Aurora are offset by 6 weeks and 1 version in the same way as Aurora and Beta are. Nightlies are where the real new work happens and bug are fixed :)

Do you have any non-Win 7 machines to test this?
Comment 29 Ibrahim Jadoon 2011-07-30 15:37:07 PDT
Thank you for the reply again; sorry for the delay. Unfortunately, I have no laptops with Windows XP. :( I have 3 other laptops running Windows 7. 

HP Envy 14 (Windows 7, 64-bit, Synaptics): problem exists.
Gateway ZH7 (Windows 7, 64-bit, Synaptics): problem exists.
Toshiba Satellite C665 (Windows 7, 64-bit, Synaptics): problem exists.

I'm surprised more people haven't seen this problem, but no one in my house knows how to use a multitouch touchpad, haha. :)
Comment 30 Ibrahim Jadoon 2011-07-30 15:55:19 PDT
Also, a bit of Google searching shows a few duplicated bugs. However, those duplicated bugs (bug 638671 and bug 632889) show it as a problem on Windows 7 x86!

Seems to be a Synaptics + Windows 7 issue.
Comment 31 :aceman 2011-07-30 16:01:04 PDT
*** Bug 638671 has been marked as a duplicate of this bug. ***
Comment 32 robb 2011-07-31 03:46:29 PDT
Synaptics + Windows Vista 32-bit SP2 and I have the problem as well, currently with FF6.0 beta
Comment 33 robb 2011-07-31 03:55:05 PDT
Additional info:

With a PDF open, touchpad scrolling doesn't work.

If I disable the Adobe plugin the scrolling works.  The tab the PDF was in still exists but is blank.

Enable Adobe scrolling still works.

Open a pdf and scrolling quits.
Comment 34 Ibrahim Jadoon 2011-07-31 09:52:47 PDT
Thanks, robb. :)

Yup, that's exactly it. Well, you're another Windows 7 x86 user, so I think we're safe to change this bug from only x64 to Windows 7 x86 AND x64.
Comment 35 :aceman 2011-07-31 10:59:34 PDT
Comment 32 seems to imply also Windows Vista.
Comment 36 Ibrahim Jadoon 2011-08-06 12:01:01 PDT
That's true. Vista and 7, then?

Oh, an update: Foxit PDF's plugin is able to scroll correctly (!). I don't know why or how, but it does. :)
Comment 37 Cameron McCormack (:heycam) 2011-08-10 16:40:49 PDT
Windowed vs non-windowed plugins?
Comment 38 Ibrahim Jadoon 2011-08-13 15:28:22 PDT
(In reply to Cameron McCormack (:heycam) from comment #37)
> Windowed vs non-windowed plugins?

Possibly? I mean, the plugin is still within the tab?
Comment 39 Cameron McCormack (:heycam) 2011-08-13 15:58:50 PDT
Sorry, by windowed and non-windowed (windowless) I meant the mode of operation of the NPAPI plugin: https://developer.mozilla.org/en/Gecko_Plugin_API_Reference/Plug-in_Basics#Windowed%20and%20Windowless%20Plug-ins

Trackpad drivers are known to inspect the window hierarchy to determine where to send scrolling events.  With windowless plugins, there is no change to the window hierarchy.  My guess would be that the Foxit plugin is windowless while the Adobe reader one is windowed, and that that is why scrolling works with the former but not with the latter.
Comment 40 Ibrahim Jadoon 2011-08-17 19:16:39 PDT
Ohhh, I see. That could very well be true. I'm emailing Foxit to see if they know anything about their plugin behavior.
Comment 41 mike 2011-08-18 10:15:39 PDT
I've had this problem for over 2 yrs with FF3 up to FF5 (no beta).  When pdf open in a tab (hidden), other visible tabs don't scroll with touchpad. Just discovered that hidden pdf scrolls, though; after reading this thread. cntl-t cntl-w works properly. 

Synaptics PS/2 Port Pointing Device, driver 9.1.18.6 (up to date).
Vista 32 SP2, latest updates, antivirus deactivated.
Comment 42 Igor 2011-08-18 10:36:59 PDT
I can remember this bug only since FF4 and up to FF6...

G73jw; Synaptics Touchpad v7.4;
Synaptics Pointing Device - v15.2.20 31 Mar 2011

Windows 7 x64
Comment 43 Igor 2011-08-18 11:04:03 PDT
Bug also exists on HP8710p (Synaptics Touchpad v6.2) Win7 x64 ....
Comment 44 Dmitry 2011-08-18 11:29:33 PDT
There is no such bug on my PC. My sysreqs are:

ASUS N73JF : ELAN PS/2 Port Smart-Pad  
Firefox v5.0.1
Win 7 x64
Comment 45 Ibrahim Jadoon 2011-08-21 08:28:39 PDT
(In reply to Cameron McCormack (:heycam) from comment #39)
> Sorry, by windowed and non-windowed (windowless) I meant the mode of
> operation of the NPAPI plugin:
> https://developer.mozilla.org/en/Gecko_Plugin_API_Reference/Plug-
> in_Basics#Windowed%20and%20Windowless%20Plug-ins
> 
> Trackpad drivers are known to inspect the window hierarchy to determine
> where to send scrolling events.  With windowless plugins, there is no change
> to the window hierarchy.  My guess would be that the Foxit plugin is
> windowless while the Adobe reader one is windowed, and that that is why
> scrolling works with the former but not with the latter.

Well, Foxit's support team sent me a reply:

"Ours is a windowed' s OCX plugin."

Humph. :(

Thank you Igor, mike, and Dmitry for those details. It seems, so far, that this only occurs on Synaptics Touchpads, but we'll need a bit more data to make this concrete. 

I'm with Igor on the timing; I've only ever had this problem since FF4, but it's curious mike that you've had it even on FF3! The plot thickens...
Comment 46 sizzles 2011-09-24 05:39:52 PDT
Experiencing this bug as well.

HP 8530p notebook
Firefox v6.0.2
Win 7 x64 SP1
Synaptics PS/2 Port TouchPad 15.0.24.0
Adobe Acrobat 10.1.1.3 plugin
Comment 47 :aceman 2011-09-24 05:57:48 PDT
Now, a very similar bug 273456 has been fixed in Firefox 9, and also bug 594500 is marked fixed, can anybody of you try if the problem reported here isn't fixed too?
Comment 48 sizzles 2011-09-24 06:04:32 PDT
Uninstalled adobe and installed Foxit and srolling works everywhere.
Comment 49 sizzles 2011-09-24 07:26:59 PDT
(In reply to aceman from comment #47)
> Now, a very similar bug 273456 has been fixed in Firefox 9, and also bug
> 594500 is marked fixed, can anybody of you try if the problem reported here
> isn't fixed too?

Where can I download Firefox 9?

Eventhough scrolling works with Foxit Ctrl+Pg up and Ctrl+pg dn do not work once on the pdf tab. I downloaded Aurora but the same issue still exists.
Comment 50 :aceman 2011-09-24 07:37:42 PDT
Aurora is only at version 8. Try the nightly here: http://nightly.mozilla.org/ .
Comment 51 sizzles 2011-09-24 10:16:51 PDT
(In reply to aceman from comment #50)
> Aurora is only at version 8. Try the nightly here:
> http://nightly.mozilla.org/ .

Thanks! I installed the nightly. However it opens the pdf externally in adobe. Under Options Applications for Adobe Acrobat Document there is no option of 'Preview in Nightly' or 'Use Adobe Reader (in Firefox)'.
Comment 52 :aceman 2011-09-24 10:26:28 PDT
Check in Tools-> Addons->plugins if the Adobe PDF plugin is correctly enabled.
Comment 53 sizzles 2011-09-24 11:10:57 PDT
(In reply to aceman from comment #52)
> Check in Tools-> Addons->plugins if the Adobe PDF plugin is correctly
> enabled.

I don't see anything in plugins. It's empty. I installed adobe reader x after installing nightly. What should I do to get the plugin installed correctly? Thanks.
Comment 54 :aceman 2011-09-24 11:56:26 PDT
Don't know, it should kinda install automatically. Do you now have several firefox versions installed in parallel?
Comment 55 sizzles 2011-09-24 13:59:13 PDT
(In reply to aceman from comment #54)
> Don't know, it should kinda install automatically. Do you now have several
> firefox versions installed in parallel?

Removed everything except for Nightly. Neither Adobe nor Foxit recognize Nightly.
Comment 56 :aceman 2011-09-24 14:05:44 PDT
Maybe they are looking into the registry and searching for "Firefox" name, which you now don't have so they do not install the plugin. But if it worked on Aurora I don't know why it would fail on Nightly. What about installing Firefox, then Adobe reader, then Nightly?
Comment 57 Viktor 2011-09-24 14:19:58 PDT
(In reply to aceman from comment #47)
> Now, a very similar bug 273456 has been fixed in Firefox 9, and also bug
> 594500 is marked fixed, can anybody of you try if the problem reported here
> isn't fixed too?

Tried the nightly on win7 with acrobatX and it does the same as before. So the problem is not fixed.
Comment 58 Petr Tomes 2011-10-07 13:06:54 PDT
I can confirm this bug on Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111006 Firefox/9.0a2. 

EEE PC Seashell 1215N
Synaptics PS/2 Port TouchPad 19.11.2009 14.0.16.0
Comment 59 :aceman 2011-10-07 13:37:40 PDT
Has anybody seen this with Adobe acrobat pdf plugin older than version X.0.0 (10)?
Comment 60 Petr Tomes 2011-10-08 01:22:16 PDT
I've downloaded the current Synaptics driver 15.2.20 from http://www.synaptics.com/resources/drivers and the bug still occurs in any Firefox release I've tried (4, 5, 6, 7, 8 beta, 9 aurora, 10 nightly). :(
Comment 61 napkinsonthehouse 2011-10-10 05:44:53 PDT
Same problem. Using Windows 7 SP1, Firefox 7, Adobe Reader X, and an HP ProBook 4530s with a Synaptics touchpad.  All are up-to-date.
Comment 62 Petr Tomes 2011-10-10 09:24:35 PDT
I believe this bug should be confirmed and switch to the new status and seriously considered for tracking or blocking Firefox Nightly (10) at least since there is no workaround to solve this annoyance.
Comment 63 Igor 2011-10-10 09:45:58 PDT
There's no workaround... except for installing foxit, may be ;)
Comment 64 :aceman 2011-10-10 12:13:04 PDT
The bug is confirmed (REOPENED almost equals NEW).
Any answers to my question in comment 59?
I don't think you should use the tracking flag in this way...
Comment 65 Igor 2011-10-10 12:22:28 PDT
I'm not sure, which versions are you talking about, but I've got Adobe Acrobat 10.1.1.33 plugin on FF7.0.1 and the bug is still there.
Comment 66 :aceman 2011-10-10 12:29:14 PDT
I am asking about Acrobat reader 9.x or lower.
Comment 67 Benjamin Smedberg [:bsmedberg] 2011-10-10 12:40:33 PDT
This is a regression from bug 130078, related to bug 273456, and is not something that we'd track for a particular release because it is not a recent regression. It may also be a bug in the trackpad driver, not in the Mozilla code, because they were making assumptions about our window hierarchy that were changed in bug 130078. Tn/roc, wasn't there another bug already filed on the synaptic trackpad issue?
Comment 68 Petr Tomes 2011-10-10 14:14:16 PDT
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #67)
> hierarchy that were changed in bug 130078. Tn/roc, wasn't there another bug
> already filed on the synaptic trackpad issue?

https://bugzilla.mozilla.org/show_bug.cgi?id=622410
?

Why Chrome is working fine here?
Comment 69 :aceman 2011-10-10 14:33:14 PDT
Because it hasn't redesigned the window hierarchy recently?
Comment 70 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-10-10 15:07:14 PDT
heycam, would you be able to try reproducing this?
Comment 71 napkinsonthehouse 2011-10-11 04:27:20 PDT
Here's a similar issue that may help for troubleshooting: 
Scrolling also doesn't work in the same manner for the "Manage Search Engines" box, with or without a pdf tab open.  Not sure if there's a separate bug report for that, but functionally it's the same problem to me.
Comment 72 Cameron McCormack (:heycam) 2011-10-11 23:01:36 PDT
On this Thinkpad T60 with Windows 7 x64, a 32 bit Nightly, Adobe plugin 10.1.1.33 and UltraNav driver 15.2.14.0, I don't have any trouble using the trackpad to scroll in one tab if another background tab has a PDF in an <object>.  I'm using http://people.mozilla.org/~cmccormack/misc/pdf.html as the background tab's page.  I will try some earlier trackpad drivers.
Comment 73 Timothy Nikkel (:tnikkel) 2011-10-11 23:05:37 PDT
Make sure you try giving the PDF plugin focus before making a background tab, that might be important.
Comment 74 Cameron McCormack (:heycam) 2011-10-12 00:11:17 PDT
Good idea.  Same result, though.  (I selected the non-PDF with the mouse after clicking in one of the text boxes in the PDF plugin's toolbar.)  The same configuration above but with driver 15.0.18.0 did not show the scrolling problem either.

I am wondering now whether this is a problem that only manifests on newer Synaptics hardware than the one in this T60 (which is not multi-touch).
Comment 75 Richard 2011-10-12 01:20:45 PDT
I have the exact same problem. The problem also seems to happen if you have a PDF open in another tab group.

Synaptics PS/2 Port Touchpad (Driver 15.0.17.4)
Windows 7 Professional x64
Running Firefox 7.0.1 but bug has been occurring for a while now.

My friend has an Alps Pointing Device (Driver 7.106.2015.1201 (29/10/2010)) and the problem does not occur for him. He has the same version of Firefox and Windows as me.
Comment 76 jb 2011-10-15 14:13:30 PDT
Same problem, even when PDF is not open in another tab. Both scrolling by two fingers, and scrolling by touching the right side edge do not work on ff7, even when as it works on chrome, ie 9, and all other programs. It is maddening.

My configuration is Synaptics PS/2 Port Touchpad (driver 15.3.22.0) on Windows 7 Enterprise
Comment 77 bobbamme 2011-11-09 13:02:20 PST
I have this problem on both my Windows XP 32-bit and Windows 7 64-bit machines with the latest Firefox, Adobe plugin, and Synaptics touchpad driver installed.  I cannot read pdf documents in Firefox while being about to scroll with the touchpad in other tabs.  Is there any hope of this being fixed?  I remember not having this problem on my Windows XP machine before I updated the Adobe plugin from version 9 to version 10.
Comment 78 oscar.a.quintero 2011-12-09 16:52:16 PST
Operating System: Windows 7 Home Premium Service Pack 1
Firefox Version: 8.0
Adobe Acrobat Plugin version: 10.1.1.33
Device: Synaptics TouchPad V7.4 Driver 15.2.6
Comment 79 Luke Pacholski 2011-12-21 15:35:32 PST
I can confirm on both Windows 7 and XP here with Firefox 9.0:

XP Media Center Edition 2002 SP 3
Synaptics v10.1.8 06Dec07 (Synaptics TouchPad V5.9)
Adobe Acrobat 9.4.5.236

Windows 7 Home Premium SP 1 (64-bit)
Synaptics v15.2.11.1 03Feb11 (Synaptics TouchPad V7.2)
Adobe Acrobat 10.1.1.33
Comment 80 :aceman 2011-12-21 23:54:20 PST
Please also specify Firefox version (or build date) in your posts.

Firefox 9 (www.getfirefox.com, autoupdate does not yet offer it) supposedly fixed bug 273456 (scrolling with PDF with other scrolling devices (mouse, keyboard)). So it may help some of you.
We need clear reports from touchpad configurations that are still broken even in Firefox 9.
Comment 81 robb 2011-12-22 05:50:03 PST
Firefox 9.0 beta channel
Windows Vista Home Premium Service Pack 2 32-bit
Synaptics 15.2.20.0  3/31/2011
Adobe Acrobat 10.1.1.33

pdf scrolls in browser tab but other tabs do not
Comment 82 Luke Pacholski 2011-12-22 06:22:33 PST
(In reply to :aceman from comment #80)
> Please also specify Firefox version (or build date) in your posts.

I'm not sure if this was directed at me or not, but to be clear I was using Firefox 9.0 on both machines in post 79.
Comment 83 Richard 2011-12-22 06:32:29 PST
Exactly the same as last time. The pdf scrolls but normal webpages do not and the pdf scrolls in the background while trying to scroll on a webpage.

Synaptics PS/2 Port Touchpad (Driver 15.0.17.4)
Windows 7 Professional x64
Firefox 9.0.1
Comment 84 Ibrahim Jadoon 2011-12-30 21:51:26 PST
Just going to hop in here to consolidate some information:

I also still have this bug in FF 9.0.1 and 10.0a2. 

Synaptics v7.2 touchpad (driver version: 15.0.24.0)
Windows 7 Ultimate x64
Firefox 9.0.1 and Firefox 10.0a2
Adobe PDF Reader 10.1.1.xx (unsure exactly which version; already uninstalled) and NitroPDF 2.1.1.3
Comment 85 Ibrahim Jadoon 2011-12-31 11:26:01 PST
And it's not limited to scrolling, actually. With Nitro PDF installed, pinch zoom and three finger flick do not work with a PDF open. 

So, all multitouch gestures do not work in the active tab if a nonactive tab is a PDF.
Comment 86 Ibrahim Jadoon 2012-01-08 01:08:32 PST
Just want to check in here...any new info or news on this? Still makes browsing a pain...
Comment 87 David Tenser [:djst] 2012-01-12 03:12:16 PST
Happens all the time here, on all of my versions of Firefox (stable 8.0.x-9.0.x Aurora, Nightly). Sony Vaio Z, Windows 7, latest version of the Adobe Reader X software and plugin.
Comment 88 David Tenser [:djst] 2012-01-12 03:25:38 PST
(In reply to Cameron McCormack (:heycam) from comment #74)
> I am wondering now whether this is a problem that only manifests on newer
> Synaptics hardware than the one in this T60 (which is not multi-touch).

I can confirm that my Sony Vaio has multi-touch, so this hypothesis might be true.
Comment 89 Cameron McCormack (:heycam) 2012-01-30 16:03:16 PST
I just installed Adobe Reader X on this Lenovo SL500 I have, and am able to reproduce the problem.  When trying to vertically scroll by using the right edge of the trackpad, the mouse cursor changes (to something that I assume means "scrolling", though it is different from other Synaptics scrolling cursors I've seen) but no scrolling occurs.  If I am on the tab with the PDF loaded, then the document does scroll.  Using the trackpoint to scroll works regardless.
Comment 90 David Tenser [:djst] 2012-02-01 06:33:26 PST
Is QA help wanted in this bug? It's been in bugzilla for over a year and the steps to reproduce are clear. Just trying to figure out what we're stuck at and what the next step is in this bug. It seems like it's affecting lots of users.
Comment 91 Ibrahim Jadoon 2012-02-04 12:24:36 PST
I have the same comment as Mr. Tenser. For me, this bug has been present since *Firefox 4*. Yes, six versions ago! What do we need to do to move towards a resolution? And, again, ostensibly many users *are* affected.

And, the bug has a tracking flag of "tracking-firefox10." For those who do not know, bugs marked tracking-firefox# "are bugs that must be resolved one way or another before a particular release ships." I do not know how stringent this is because this was obviously not looked at before Firefox 10 was released. :( And "...bugs marked tracking-firefox# should have actionable next steps. Often, the next thing to do is to gather more information (from automated systems like crash-stats or the bug reporters themselves). If a bug has tracking-firefox# set it means release drivers will help shepherd those next steps until it becomes clear the bug will not impact a release (either via a fix or new information). At that point, release drivers will no longer track the bug."

All of this is copied from this Mozilla blog post (http://blog.mozilla.com/channels/2011/06/01/more-details-about-how-to-use-the-tracking-firefox-bugzilla-flag/). 

So apparently, at one time for one person (at least), this bug was worth fixing or else that flag would not have been approved. Again, a regression window has been provided in comment 13, which I will repeat here:

Last good nightly: 2010-08-27
First bad nightly: 2010-08-28

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1d55bbd1d1d&tochange=6e3f6d18c124

And yes, these are nightlies for Firefox 4 (!).
Comment 92 Tim Abraldes [:TimAbraldes] [:tabraldes] 2012-02-04 18:16:47 PST
I'd love to take this on but I'm not able to reproduce this bug on my system:
  Lenovo W520
  Windows 7 64-bit
  "Thinkpad UltraNav Pointing Device" 15.0.18.0
  Acrobat 10.1.2.245
Comment 93 Danilo Roascio 2012-02-04 19:04:00 PST
So, can I propose something?

First of all, I know nothing about the ff code structure and I never had part in the development. But quickly going through the pushlog posted by Ibrahim, I think I can identify some changes that may be involved in the regression.

What about "undoing" them in the code and posting some test executable somewhere so that we can check if it's solved? (I know that this is easier said than done, and I know this may lead nowhere, but unless someone else comes up with a better idea to solve the bug...)

Starting from the most guilty change to the least guilty one:
https://bugzilla.mozilla.org/show_bug.cgi?id=575440 <- 60% probability
https://bugzilla.mozilla.org/show_bug.cgi?id=587944
https://bugzilla.mozilla.org/show_bug.cgi?id=577579
https://bugzilla.mozilla.org/show_bug.cgi?id=549799

Cheers.
Danilo
Comment 94 John May 2012-02-04 22:34:20 PST
I have the same bug using:

Compaq CQ60
Windows 7 32-bit
Synaptics Pointing Device - v11.0.7 27Mar08
Acrobat 10.1.2.45

Before I found this work-around, I had to change to Chrome, but I'm back now, but it needs fixing!
Comment 95 John May 2012-02-04 22:36:43 PST
Forgot to say, this is with FF10.0
Comment 96 Cameron McCormack (:heycam) 2012-02-04 23:23:48 PST
Since I am able to reproduce now, I will look into it.
Comment 97 Cameron McCormack (:heycam) 2012-02-07 15:52:07 PST
Created attachment 595231 [details] [diff] [review]
Hide plugins in background tabs to avoid trackpad drivers wanting to scroll them

As a first step, let's try hiding plugins when they are not visible.  That will get scrolling working if the plugin is on a background tab.  I'll need to look further into solving the problem more generally to handle plugins visible on the foreground tab.
Comment 98 Cameron McCormack (:heycam) 2012-02-07 15:55:29 PST
The patch does this hiding regardless of whether we've got a Synaptics trackpad.  If you think it's a good idea to do this only if we do, I can do that.  (Although it will need to be a different condition from IsObsoleteSynapticsDriver(), since someone is reporting this problem with v15.3.x.y of the driver, whereas IsObsoleteSynapticsDriver() checks for <= 15.0.x.y.)
Comment 99 Mozilla RelEng Bot 2012-02-07 16:26:42 PST
Autoland Patchset:
	Patches: 595231
	Branch: mozilla-central => try
Error applying patch 595231 to mozilla-central.
unable to find 'widget/src/windows/nsWindow.cpp' for patching
1 out of 1 hunks FAILED -- saving rejects to file widget/src/windows/nsWindow.cpp.rej
abort: patch failed to apply

Could not apply and push patchset:
Comment 100 Cameron McCormack (:heycam) 2012-02-07 16:33:45 PST
Created attachment 595249 [details] [diff] [review]
Hide plugins in background tabs to avoid trackpad drivers wanting to scroll them. (v1.1)

rebase over recent widget/ directory changes
Comment 101 Mozilla RelEng Bot 2012-02-07 16:38:20 PST
Autoland Patchset:
	Patches: 595249
	Branch: mozilla-central => try
	Destination: http://hg.mozilla.org/try/rev/c098b7df0f00
Try run started, revision c098b7df0f00. To cancel or monitor the job, see: https://tbpl.mozilla.org/?tree=Try&rev=c098b7df0f00
Comment 102 Jim Mathies [:jimm] 2012-02-07 18:10:37 PST
Comment on attachment 595249 [details] [diff] [review]
Hide plugins in background tabs to avoid trackpad drivers wanting to scroll them. (v1.1)

Review of attachment 595249 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/windows/nsWindow.cpp
@@ +7305,4 @@
>        ::EnableWindow(mWnd, FALSE);
>      } else {
>        ::EnableWindow(mWnd, TRUE);
> +      ::ShowWindow(mWnd, WS_SHOW);

Should this be SW_SHOWNOACTIVATE? Activation implies taking focus. 

Also, any anomalies with this patch with plugins? I wonder what windowing events this generates that ultimately end up as plugin event.
Comment 103 Cameron McCormack (:heycam) 2012-02-07 18:18:35 PST
I'm not finding that SW_SHOWNOACTIVATE is giving the plugin focus.  (I kind of assumed that SW_SHOWNOACTIVATE was more for top-level windows, but maybe not?)

I did some brief testing with the Adobe Reader X plugin, but nothing extensive, nor with other plugins.  If you can give me a list of top N plugins I should test with, I can do that.

Switching back and forth between the tab with the Reader plugin and another tab, I only see painting related messages being sent to the plugin's windows.
Comment 104 Jim Mathies [:jimm] 2012-02-07 19:06:57 PST
(In reply to Cameron McCormack (:heycam) from comment #103)
> I'm not finding that SW_SHOWNOACTIVATE is giving the plugin focus.  (I kind
> of assumed that SW_SHOWNOACTIVATE was more for top-level windows, but maybe
> not?)
> 

Entirely possible it doesn't do anything different on children, but it's good we checked.
Comment 105 Mozilla RelEng Bot 2012-02-07 19:45:21 PST
Try run for c098b7df0f00 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=c098b7df0f00
Results (out of 83 total builds):
    exception: 6
    success: 28
    failure: 49
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/autolanduser@mozilla.com-c098b7df0f00
Comment 106 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-02-07 19:53:50 PST
Excellent! The patch v1.1 fixed this bug on my environment (Synaptics TouchPad V7.4).

Note that the consts are SW_*, not WS_*.
Comment 107 Cameron McCormack (:heycam) 2012-02-07 20:00:56 PST
Great!  Thanks for testing, Masayuki.  When you have a page like http://people.mozilla.org/~cmccormack/misc/pdf.html in the foreground tab, with the plugin visible, and you try to scroll, it will scroll the plugin regardless of what has focus, right?

Got a new try build with the correct const names up now.
Comment 108 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-02-07 22:09:35 PST
(In reply to Cameron McCormack (:heycam) from comment #107)
> When you have a page like
> http://people.mozilla.org/~cmccormack/misc/pdf.html in the foreground tab,
> with the plugin visible, and you try to scroll, it will scroll the plugin
> regardless of what has focus, right?

Unfortunately, yes. So, I cannot scroll tab bar too.

If we're hooking all messages of all windows on plugins, we can make the wheel messages pass our window procedure first. I'm not sure whether we're doing it.
Comment 109 Cameron McCormack (:heycam) 2012-02-07 22:22:39 PST
I don't think we are hooking the messages for plugin windows at the moment.  Seems kind of drastic. :)  I'll see if I can trick the trackpad driver into sending our top-level window the scroll messages instead of the plugin window, first.
Comment 110 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-02-07 22:39:40 PST
Okay, when you change nsWindow's mouse wheel handling code or pointing device driver related code, please cc me to the bug. I'm working on mouse wheel handling code refactoring in bug 672175. On my local tree, I almost finished the work excepting making testing framework.
Comment 111 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-02-07 23:13:21 PST
(In reply to Cameron McCormack (:heycam) from comment #109)
> I don't think we are hooking the messages for plugin windows at the moment. 
> Seems kind of drastic. :)

We are. We're subclassing the plugin window actually. See PluginInstanceChild::PluginWindowProcInternal.
Comment 112 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-02-07 23:13:56 PST
Let's land patch v1.1 soon anyway.
Comment 113 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-02-08 00:00:16 PST
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #112)
> Let's land patch v1.1 soon anyway.

Yeah, new bug should be filed for the remaining issue.
Comment 114 Mozilla RelEng Bot 2012-02-08 03:15:22 PST
Try run for 43132a6c8985 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=43132a6c8985
Results (out of 47 total builds):
    success: 46
    warnings: 1
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/cmccormack@mozilla.com-43132a6c8985
 Timed out after 06 hours without completing.
Comment 115 Cameron McCormack (:heycam) 2012-02-08 14:15:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/606a6ab0d0a6
Comment 116 Cameron McCormack (:heycam) 2012-02-08 14:19:57 PST
I filed bug 725475 for working on a more complete fix.
Comment 117 Ed Morley [:emorley] 2012-02-09 10:26:32 PST
https://hg.mozilla.org/mozilla-central/rev/606a6ab0d0a6
Comment 118 napkinsonthehouse 2012-02-17 06:45:29 PST
Updated to 10.0.2 ... still not fixed. Synaptics touchpad still won't scroll when PDF open in another tab. To clarify: the PDF tabs will scroll fine, but not any other tab when Reader active in browser. Peripheral non-synaptics mouse unaffected by this bug when using same computer. NOT FIXED.
Comment 119 Andrew McCreight [:mccr8] 2012-02-17 06:47:09 PST
If you look above, you'll see that it says that the target milestone for this is Firefox 13.  In order to get this fix, you'll have to wait another few release cycles, or switch to a more experimental version.
Comment 120 napkinsonthehouse 2012-02-17 06:55:03 PST
A link would be nice ... cause you see, I can't scroll up ;)
Comment 121 David Tenser [:djst] 2012-02-17 08:47:26 PST
Since there are a number of people cc'ed to this bug, I thought it might be helpful with a few pointers on how to get more involved with beta testing Firefox.

If you want to test the fix of this bug today, you can do that in the latest nightly build: http://nightly.mozilla.org/

If you want to wait until this lands in a slightly more stable (yet still beta testing) branch, you can download Firefox Aurora, where the fix should appear on March 13: http://aurora.mozilla.org/

For an overview of the release schedule, see https://wiki.mozilla.org/Releases

Note You need to log in before you can comment on or make changes to this bug.