Messed display when long descriptions in Detail View

VERIFIED FIXED in mozilla2.0b10

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: Paenglab, Assigned: Unfocused)

Tracking

(Depends on: 1 bug)

Trunk
mozilla2.0b10
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
After landing of Bug 602059 when a Add-on has a long description, the #detail-contributions and #detail-grid are painted over #detail-desc in Detail View. When I remove on #detail-screenshot the max-height: 300px all is correct.
(Reporter)

Comment 1

7 years ago
Created attachment 502278 [details]
Screenshot showing the problem

Screenshot showing the problem with the description from LavaFox theme
(Reporter)

Updated

7 years ago
Blocks: 602059
Happens on all platforms. Asking for blocking, because it's a highly visible regression.
blocking2.0: --- → ?
OS: Windows 7 → All
Hardware: x86 → All
blocking2.0: ? → final+
Think this is caused by bug 394738 - I've hit that before. Thankfully, there's a pretty simple workaround. Patch coming up.
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Depends on: 394738
Created attachment 502694 [details] [diff] [review]
Patch v1
Attachment #502694 - Flags: review?(dtownsend)
Whiteboard: [has patch][needs review Mossop]
Whiteboard: [has patch][needs review Mossop] → [has patch][needs review Mossop][soft blocker]
Comment on attachment 502694 [details] [diff] [review]
Patch v1

Nice find
Attachment #502694 - Flags: review?(dtownsend) → review+
Whiteboard: [has patch][needs review Mossop][soft blocker] → [has patch][soft blocker]
Landed: https://hg.mozilla.org/mozilla-central/rev/4d3f8e99c842

Litmus test would be beneficial - using the steps outlined in comment 0 and comment 1.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite-
Flags: in-litmus?
Resolution: --- → FIXED
Whiteboard: [has patch][soft blocker] → [soft blocker]
Target Milestone: --- → mozilla2.0b10
Whiteboard: [soft blocker] → [softblocker]
Duplicate of this bug: 625023
Duplicate of this bug: 625064
Duplicate of this bug: 626125
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110116 Firefox/4.0b10pre
Status: RESOLVED → VERIFIED

Updated

6 years ago
Duplicate of this bug: 627645
Duplicate of this bug: 628396
Duplicate of this bug: 628798
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.