Newly uploaded add-on version of a public add-on has the wrong review queue status

VERIFIED FIXED in 5.12.7

Status

addons.mozilla.org Graveyard
Developer Pages
P3
normal
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Details

(Whiteboard: [Versions page], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
steps to reproduce:
1. Pick a public add-on
2. Upload  a new version
3. Notice the file status in versions page

observed behavior:
File status says that the newly uploaded version is in the prelim queue. However, the version is in the right review queue(checked from Editor tools)

screenshot: http://screencast.com/t/me3QKLr4
(Reporter)

Updated

8 years ago
Summary: Newly uploaded add-on version of a public add-on is in the wrong review queue → Newly uploaded add-on version of a public add-on has the wrong review queue status
This is a candidate for 5.12.6.1 as it sounds like a serious problem.
(Assignee)

Comment 2

8 years ago
This is just a problem with the words. All fresh files get marked as unreviewed, which is interpreted as "awaiting prelim review". The editor tools know what to do.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 626272
(Assignee)

Updated

8 years ago
Assignee: nobody → jbalogh
(Assignee)

Updated

8 years ago
Priority: -- → P3
(Assignee)

Comment 4

8 years ago
http://github.com/jbalogh/zamboni/commit/2babd25
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
Created attachment 505599 [details]
status in manage versions page

The status is not fixed in Manage Versions page. See https://addons.allizom.org/en-US/developers/addon/sleepless-in-seattle/versions/126459
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> Created attachment 505599 [details]
> status in manage versions page
> 
> The status is not fixed in Manage Versions page. See
> https://addons.allizom.org/en-US/developers/addon/sleepless-in-seattle/versions/126459

Filed as bug 627565
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.