Flash menu and games rendered with black background

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: raul.malea, Assigned: cjones)

Tracking

({regression, reproducible})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [hardblocker][4b10] flash [to be fixed by bug 626602], )

Attachments

(5 attachments, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110115030345

This is a spin-off from bug 611698 comment 103 per roc.  On some machines
(namely, my own), it appears that the patch for bug 611698
(https://hg.mozilla.org/mozilla-central/rev/fbf144260d6c) does not fix the
problem (Flash text rendered with black surface behind, should be transparent).


Reproducible: Always

Steps to Reproduce:
1.Open http://oscar-raul.superpokepets.com/ (if it is necessary please sign in)
2.Play this game (click on menu, on pet etc.)
3.Observe flash menu and game rendered with a black, non-transparent or normal background
Actual Results:  
Black background in games (see screenshots)

Expected Results:  
Flash rendered normally (see screenshot for Chrome)

I'm running Windows 7 x86 Professional, with OOPP enabled (and if I disable
OOPP, the original bug goes away).
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110115 Firefox/4.0b10pre ID:20110115030345

Grafică(Graphics) 
              
Descrierea adaptorului NVIDIA GeForce 8600 GT 
ID furnizor 10de 
ID dispozitiv 0402 
RAM pentru adaptor 512
Drivere pentru adaptor nvd3dum nvwgf2um,nvwgf2um
Versiune driver 8.17.12.6099
Dată driver 10-16-2010
Direct2D activat true
DirectWrite activat true (6.1.7600.20830)
WebGL Renderer TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 15 2011 03:39:46)
Accelerare GPU Windows 1/1 Direct3D 10


about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/3d4620449437
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests
Depends on: 625933, 611698
See Also: → 626202
Whiteboard: [hardblocker][4b10] flash
blocking2.0: --- → ?
See Also: → 615119
Posted image flash loading is black (obsolete) —
Posted image screenshot black background (obsolete) —
My Flash plugins:

Shockwave Flash

    Fișier: NPSWF32.dll
    Versiune: 10.2.161.23
    Shockwave Flash 10.2 d161

Tip MIME 	Descriere 	Sufixe
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
Shockwave for Director

    Fișier: np32dsw.dll
    Versiune: 11.5.9.615
    Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615

Tip MIME 	Descriere 	Sufixe
application/x-director 	Shockwave Movie 	dir,dxr,dcr
Confirmed here on XP 32bit + 8600GT 256MB (266.44) with:
-latest Flash 10.2.152.14 Release Candidate
-latest nightly of Firefox 4.0b10pre

Adapter Description - NVIDIA GeForce 8600 GT
Vendor ID - 10de
Device ID - 0402
Adapter RAMU - nknown
Adapter Driversn - v4_disp
Driver Version - 6.14.12.6644
Driver Date - 12-27-2010
Direct2D Enabled - false
DirectWrite Enabled - false (0.0.0.0)
WebGL Renderer - TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Jan 15 2011 07:29:57)
GPU Accelerated Windows - 3/3 Direct3D 9
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hmmm, perhaps this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=626177  , influence my bug? (TEXT flash rendered is incorrect).
Also, please marked this bug for blocked Firefox 4 final.
Whiteboard: [hardblocker][4b10] flash
Whiteboard: [hardblocker][4b10] flash
WFM with Flash 10.2 and the fix for bug 626177. Please recheck with the next nightly.
Oh wait, in some cases it doesn't. Investigating.
Flash 10.2 has basically the same rendering loop as 10.1 although it's a bit better optimized. Now it doesn't read the entire plugin area back to its private DIB, instead it just reads back the dirty area.

But for some reason 10.2 is giving some areas opaque backgrounds that shouldn't have them. Note for the Superpoke site the "header" Flash object has a black background just where the SuperPoke log is. I can't tell what triggers it.

Note that SIFRs like http://www.foreignaffairs.com/issues/2010/89/6 are working fine with 10.2.

Michelle, can you help? I think we have our async rendering for windowless Flash working with 10.1 now, it's only 10.2 that's causing problems :-(
Correction, the problem at superpokepets.com does occur with Flash 10.1.
smadayag, msintov: let me explain what we're trying to do ... we've been trying to capture Flash output in an RGBA bitmap that we can then render in our GPU-accelerated rendering pipeline. We noticed that if we fill a 32-bit Windows DIB with zeroed alpha values and ask Flash to draw into it, Flash usually fills in the correct alpha values --- at least if we turn off subpixel antialiasing (see bug 611698). But there are some cases where that doesn't work and Flash fills in pixels with alpha 0xFF which should be transparent. This bug identifies Flash objects on superpokepets.com as triggering that, but presumably there are others.

We'd like to know what triggers these bad cases. If we could identify them, we could use a slower path just for them (e.g. "alpha recovery" --- painting twice, once onto a black background and once onto a white background, and computing alpha values). Or if you could fix those case in Flash 10.2, that'd be great too :-).
Posted image nba.com flash glitch
Happens after hovering the 'vote now' button. The background is not entirely black, is it the same bug?

Screenshot taken with the latest hourly which includes a fix for bug 626177
Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre BuildID=20110117212224
This needs an owner, assigning to roc who's looked at this the most. Roc, feel free to reassign if necessary here...
Assignee: nobody → roc
Isn't it a dupe of bug 626202?
Is flash issue on http://www.msi.com/ related to this bug?
http://img190.imageshack.us/img190/2527/msij.jpg
It's fine when OOPP is disabled.
Blocks: 629679
Depends on: 626602, 615025
Bug 626602 fixes the glitches on http://www.nba.com and http://www.msi.com/.  I couldn't figure out what to do with http://oscar-raul.superpokepets.com/, guess I'm too old.
(In reply to comment #21)
> Bug 626602 fixes the glitches on http://www.nba.com and http://www.msi.com/.  I
> couldn't figure out what to do with http://oscar-raul.superpokepets.com/, guess
> I'm too old.

In website superpokepets.com black background renderer is still present in flash menu. 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110129 Firefox/4.0b11pre ID:20110129030338
Version: unspecified → Trunk
still a problem even in flash 10.2 final?
Yes.
blocking2.0: final+ → betaN+
Bug 626602 fixed this for me.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
For me this bug is NOT fixed completely. Screenshot attached.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12pre) Gecko/20110209 Firefox/4.0b12pre ID:20110209030359


Flash

Shockwave Flash

    Fișier: NPSWF32.dll
    Versiune: 10.2.152.26
    Shockwave Flash 10.2 r152

Tip MIME 	Descriere 	Sufixe
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
Shockwave for Director

    Fișier: np32dsw.dll
    Versiune: 11.5.9.620
    Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620

Tip MIME 	Descriere 	Sufixe
application/x-director 	Shockwave Movie 	dir,dxr,dcr

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/fd0817e454fe
Build platform
target
i686-pc-mingw32
Build tools
Compiler 	Version 	Compiler flags
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
d;D:\mozilla-build\msys\mozilla-build\python25\python2.5.exe -O e;D:\mozilla-build\msys\builds\moz2_slave\cen-w32-ntly\build\build\cl.py cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -wd4800 -DNDEBUG -DTRIMMED -Zi -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
Configure arguments

--enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-jemalloc --enable-tests

Graphic
Grafică

        
Descrierea adaptorului NVIDIA GeForce 8600 GT 
ID furnizor 10de
ID dispozitiv 0402
RAM pentru adaptor 512
Drivere pentru adaptor nvd3dum nvwgf2um,nvwgf2um
Versiune driver 8.17.12.6099
Dată driver 10-16-2010
Direct2D activat true
DirectWrite activat true (6.1.7600.20830, font cache n/a)
Motor de afișare WebGL Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
Accelerare GPU Windows 1/1 Direct3D 10
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #504239 - Attachment is obsolete: true
Attachment #504240 - Attachment is obsolete: true
Will be fixed by 626602.
Assignee: roc → jones.chris.g
Whiteboard: [hardblocker][4b10] flash → [hardblocker][4b10] flash [to be fixed by bug 626602]
Duplicate of this bug: 634192
Can we resolve this now that bug 626602 is fixed?
Yep.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Disappearing menu is probably a symptom of bug 631388, which should also land soon.  Either way, that sounds like a separate bug.
Depends on: 631388
Verified. Black rendered disappeared. But menu not stay fixed, disappearing etc.
You need to log in before you can comment on or make changes to this bug.