Last Comment Bug 626448 - Ctrl-E doesn't focus web search input
: Ctrl-E doesn't focus web search input
Status: VERIFIED FIXED
[testday-20110930]
: regression
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: Trunk
: All Windows 7
: -- normal with 6 votes (vote)
: Firefox 8
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
: 635497 647121 647426 (view as bug list)
Depends on: 624588
Blocks: 629367
  Show dependency treegraph
 
Reported: 2011-01-17 10:03 PST by gadjo
Modified: 2011-09-30 08:41 PDT (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for bug 626448 (4.25 KB, patch)
2011-07-28 22:22 PDT, Jared Wein [:jaws] (please needinfo? me)
gavin.sharp: review+
l10n: feedback+
Details | Diff | Splinter Review
Patch for bug 626448 v2 (3.40 KB, patch)
2011-08-04 14:59 PDT, Jared Wein [:jaws] (please needinfo? me)
l10n: feedback+
Details | Diff | Splinter Review

Description gadjo 2011-01-17 10:03:27 PST
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

After changing panorama shortcut from Ctrl-E to Ctrl-Shift-E, Ctrl-E should focus the search input as it was done before panorama

Reproducible: Always
Comment 1 Ian Gilman [:iangilman] 2011-01-19 11:05:12 PST
I believe we're passed the time where this can happen for Fx4.
Comment 2 gadjo 2011-01-19 13:45:52 PST
That would be bad, I think, lot of users switching from 3.6 to 4.0 will be dissapointed that this shortcut is no longer available. IMHO it will be a big usability regression

I suppose that after releasing 4.0 you'll spend more time on marking similar bugs as a duplicate than you would spend time just on fixing it

BTW - I just found the valuable post on this subject, maybe you don't know it:
https://support.mozilla.com/pl/questions/773020
Comment 3 Alex Faaborg [:faaborg] (Firefox UX) 2011-01-26 16:38:45 PST
I think we'll want to move panorama to accel-e once it gets a primary UI control in Firefox 5, so given that it might be kind of useful to have a release out for a few months where it doesn't do anything during the transition.  Setting it back to search for the time being is fine as well.

Also, it would be really great if we built a UI for users to customize their shortcuts, since ultimately that's the only way for us to introduce new ones without making people upset (it turns out they are pretty much all taken).
Comment 4 [not reading bugmail] 2011-02-05 10:17:17 PST
Ctrl+F makes the most sense for search on windows.
Comment 5 [not reading bugmail] 2011-02-05 10:19:57 PST
(In reply to comment #4)
> Ctrl+F makes the most sense for search on windows.

Better yet, we should just stop some things Find and other things Search, they are the same function, and doesn't make logical sense to have two shortcuts to Find things in different UIs in the same program.
Comment 6 John 2011-02-05 13:00:29 PST
You can't be serious about ctrl+f for web search. It's a well established shortcut for finding text in the most popular applications (Adobe PDF, Microsoft Office, old Firefox, Chrome). 

I can see there is a menu item under Tools if one reenables the menu bar on Firefox 4 Beta 10 called web search with the shortcut listed as ctrl+k, maybe it would be better if while this bug is fixed, Mozilla could change the listed shortcut to ctrl+e, at least on Windows, for compatibility with IE.
Comment 7 [not reading bugmail] 2011-02-05 16:41:42 PST
John, this bug is about Panorama's search box AFAICT in comment 0.  I wasn't referring to Web Search (I know that is different), I meant Panaroma's Search to Find tabs in Panorama.
Comment 8 gadjo 2011-02-06 12:42:48 PST
Dennis - no, this bug is about Web Search. Before Panorama has landed Ctrl-E shortcut focused the google/bing/whatever search input, then it's behaviour was changed to open Panorama and then the Panorama shortcut was changed to Ctrl-Shift-E so that Ctrl-E is now unused and I think that it should be binded again to Web Search. Sorry if my description was not clear enough
Comment 9 [not reading bugmail] 2011-02-06 20:13:20 PST
Ok, thanks.  I don't understand how it can be a regression though.  I see you filed this bug using a windows build, and Ctrl-K is the hotkey even on FF3.5.  I don't see how its a regression on the Web Search, is this bug for another Platform?
Comment 10 gadjo 2011-02-07 00:23:03 PST
I'm talking about Ctrl-E, not Ctrl-K. In 3.6 Ctrl-E was focusing web search input, in 4.0 it does nothing - that's why I marked it as a regression
Comment 11 broccauley 2011-03-07 14:02:32 PST
The amount of negative feedback on this says it all:
http://input.mozilla.com/en-US/beta/search?product=firefox&version=--&q=ctrl+e+search

This is the standard search shortcut in all other Windows browsers, in major email programs such as Outlook, and in Windows Explorer. It's absolutely ridiculous that such a standard and frequently used keyboard shortcut has been removed for Windows users, yet Mac and Linux users get to keep their standard shortcuts.

Panorama needs its own shortcut, not to steal other standard shortcuts.

If in Firefox 5 a group = window then it makes things much simpler. I would propose the following:

- Ctrl+` (key above tab) currently toggles tab groups, but this can be changed to open the Panorama interface.

- Toggling groups/windows can already be performed on Mac using F10 (Exposé to show all windows from the current applicaton). On Windows, Microsoft has yet to implement a Application specific version of Alt-Tab, but we can hint at them to do so by using Win+` (key above tab) to switch between Firefox windows.

On Windows there is also a standard "Display the Multiple Document Interface (MDI) child window's System menu" Windows shortcut key which is Alt+- (Alt + hyphen). This would be very appropriate for Panorama (even for Firefox 4) considering Panorama is essentially a MDI menu.
Comment 12 broccauley 2011-03-07 15:26:35 PST
(In reply to comment #11)

> On Windows there is also a standard "Display the Multiple Document Interface
> (MDI) child window's System menu" Windows shortcut key which is Alt+- (Alt +
> hyphen). This would be very appropriate for Panorama (even for Firefox 4)
> considering Panorama is essentially a MDI menu.

On second thoughts, Alt+- should probably bring up the right-click menu for the current tab.

Ctrl+` for Panorama
Win+` to toggle between Firefox windows.
Comment 13 M8R-o0dtb4 2011-03-17 08:08:22 PDT
Ctrl+E is standard keyboard shortcut for search in almost all windows applications(not only browsers) with a search-box in the top right corner. Same in all other browsers.
Firefox 4 should have it too as the previous versions had.
Comment 14 Giovanni 2011-03-24 04:09:19 PDT
Just wanted to append add another thread from the Firefox Help forum, which adds even more to the disappointment about the removal of this shortcut:
http://support.mozilla.com/en-US/questions/764069#answer-139444

My personal best is:
> "This is a problem. Firstly, because Firefox 3 (in Windows), IE and Opera only use the Ctrl-E shortcut. Why train the users to change what they do for Firefox 4 only?
> Secondly, Ctrl-E can be typed with just your left hand while your right hand is on the mouse, without changing the position of your hand. This saves quite a lot of time and reduces fatigue.
>Before creating disbelief, let me explain a common example. Consider the need to google a single word from your clipboard (from any document/application). Until now you had to (1) Open a new tab - Ctrl-T, (2) Focus on the web search - Ctrl-E, (3) Paste the word - Ctrl-V and (4) Press Enter using the side enter button. This required your left hand on the keyboard and no move of your right hand.
>To do this in Firefox 4 you have to: 1) Open a new tab - Ctrl-T, (2) Move your right hand on the keyboard and focus on the web search - Ctrl-K, (3) Paste the word - Ctrl-V, (4) Press Enter using the main Enter button and finally (5) Return your hand on the mouse to continue browsing. This requires moving your right hand twice. "

And something last, not so major - keyboard shortcuts are all about matching commands (words) with keys. And it all started with taking the 1st letter of the word: Ctrl+S - Save, Ctrl+F - Find, Ctrl+P - Print, Ctrl+O - Open, Ctrl+N - New window et al. Then we ran out of first letters and started matching inside the word: Ctrl+T - new Tab, etc. (I'm leaving the Ctrl+Z,X,C,V aside, they are separate class of "ergonomic" shortcuts)
I guess you get it where I'm taking it - E is the most intuitive shortcut for sEarch, given that Ctrl+S is already taken (I hope nobody changes that too!!!). There's no K in "Search the Web", neither there's an E in "Panorama". Why don't we reassign Ctrl+P for Panorama? :)
Comment 15 John 2011-03-28 13:17:09 PDT
CTRL+E was unmapped from panorma because it irritated a lot of people. Doesn't that imply that a lot of people used CTRL+E for search? Really annoying that a final version is being different just because.
Comment 16 Frank Yan (:fryn) 2011-03-29 14:40:35 PDT
Let's get this back in before string freeze for Firefox 5.
Comment 17 [not reading bugmail] 2011-03-29 15:59:30 PDT
 (In reply to comment #10)
> I'm talking about Ctrl-E, not Ctrl-K. In 3.6 Ctrl-E was focusing web search
> input, in 4.0 it does nothing - that's why I marked it as a regression

I understand now.  I think we should just restore functionality here, see bug 629367 comment 30 and let Panorama be more clever then trying to take over standard key functionality.
Comment 18 Srinivas 2011-04-01 01:52:36 PDT
*** Bug 635497 has been marked as a duplicate of this bug. ***
Comment 19 Srinivas 2011-04-01 01:59:49 PDT
*** Bug 647121 has been marked as a duplicate of this bug. ***
Comment 20 Alice0775 White 2011-04-02 04:38:07 PDT
*** Bug 647426 has been marked as a duplicate of this bug. ***
Comment 21 Jared Wein [:jaws] (please needinfo? me) 2011-07-28 22:22:06 PDT
Created attachment 549304 [details] [diff] [review]
Patch for bug 626448
Comment 22 Axel 2011-07-29 10:35:40 PDT
OK, I see, the new default keyboard combination is CTRL+K.

In the comments for the patch it reads "and advertised"... As a user I don't know where I can learn the current keyboard shortcuts available for my FF version.

Does FF provide a menu item, listing all available keyboard shortcuts?
Comment 23 Axel 2011-07-29 10:36:40 PDT
BTW: Why "K"? The word "search", even the word "find", don't contain any "K"...
Comment 24 Peter 2011-07-29 11:06:02 PDT
All other letters are in use already. Except for "E".
Comment 25 Gian-Carlo Pascutto [:gcp] 2011-07-31 12:32:51 PDT
Can we raise the importance of this? The fix should be low-risk, so it's preferably something that can go Aurora or Beta ASAP. The missing Ctrl-E association is a major source of confusion, just look at the support forums:

https://support.mozilla.com/pl/questions/773020
http://support.mozilla.com/en-US/questions/796096
http://support.mozilla.com/en-US/questions/791339
http://support.mozilla.com/en-US/questions/764069
http://support.mozilla.com/en-US/questions/803906
Comment 26 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-08-02 15:59:30 PDT
Comment on attachment 549304 [details] [diff] [review]
Patch for bug 626448

I worry a little about adding it back now that it's been gone for a while (multiple releases). This could be an opportunity to reclaim a rare Accel+<Letter> shortcut for some other purpose... though as we discovered with Panorama, it's awfully easy to hit this accidentally, so whatever we'd use it for would have to be minimally disruptive, and so that's probably not a great idea. Perhaps you should find a UX person to advise.

We can't make this change as-is on Aurora or Beta, because it's a string change. It's unfortunate that we missed this before Firefox 5, that would have been the ideal time to re-introduce it.

If we want to land this on the branches, we could just hard-code the value and not use a string. It looks like very few locales change these strings anyways (looks like only sr changed it, and I don't know whether their change even works - it might just be breaking the shortcut).

We could just revert to using the old string name exactly (searchFocus.commandkey2), since it looks like a bunch of localizers never removed it.

http://mxr.mozilla.org/l10n-central/search?string=searchFocus.commandkey&find=browser%2F
Comment 27 Jared Wein [:jaws] (please needinfo? me) 2011-08-02 16:10:24 PDT
Limi: Can you please approve this change. Even though it will not exist until Fx8, it will be better sooner than later.

I don't feel strongly about the string name. If searchFocus.commandkey2 will work and the localizers would like that instead then I can make the change.
Comment 28 Axel 2011-08-02 16:15:22 PDT
How about dropping fixed acceleration keys in the next release and creating a acceleration key map file that could be edited by the user (like in Visual Studio or Adobe products).

Which brings me back to my original question from post #22: Does FF provide a menu item displaying a list of all acceleration keys and commands?
Comment 29 Axel 2011-08-02 16:17:54 PDT
... replace "creating" with "using" ... Sorry for that.
Comment 30 [not reading bugmail] 2011-08-02 20:14:40 PDT
(In reply to comment #28)
> How about dropping fixed acceleration keys in the next release and creating
> a acceleration key map file that could be edited by the user (like in Visual
> Studio or Adobe products).

That doesn't belong in this bug. Create a new bug if you would like.

> Which brings me back to my original question from post #22: Does FF provide
> a menu item displaying a list of all acceleration keys and commands?

Please refer to the firefox support website for using the browser, for instance:
http://support.mozilla.com/en-US/kb/Keyboard%20shortcuts?s=keyboard&as=s
Comment 31 Axel Hecht [pto-Aug-30][:Pike] 2011-08-03 03:46:30 PDT
Comment on attachment 549304 [details] [diff] [review]
Patch for bug 626448

This looks good for central.

For string frozen branches, we'd probably need to 
a) hard-code the key
b) verify with mozmill tests or so that it doesn't break localizations, which is two tests:
-- before the change, test that crtl-e is not bound
-- after the change, test that crtl-e triggers search.
Comment 32 Jared Wein [:jaws] (please needinfo? me) 2011-08-04 14:59:35 PDT
Created attachment 550841 [details] [diff] [review]
Patch for bug 626448 v2

Pike, I have switched to using searchFocus.commandKey2 as I hope to make it easier for localizers who haven't already removed support for this key. Can you OK this change?

Further, I think we should just land this on central, as it seems a little late to try to add to Aurora/Beta.
Comment 33 Axel Hecht [pto-Aug-30][:Pike] 2011-08-08 04:03:48 PDT
Comment on attachment 550841 [details] [diff] [review]
Patch for bug 626448 v2

Sounds good to me, looking at http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=searchFocus.commandkey2&find=browser.dtd$
Comment 34 Jared Wein [:jaws] (please needinfo? me) 2011-08-08 11:47:48 PDT
This has been fixed in the Fx team repo:
https://hg.mozilla.org/integration/fx-team/rev/45be6bf39c3b
Comment 35 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2011-08-09 09:08:46 PDT
http://hg.mozilla.org/mozilla-central/rev/7532423401ea
Comment 36 Daniel Desira 2011-09-30 08:00:31 PDT
verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 37 [:Aleksej] 2011-09-30 08:41:22 PDT
Marking VERIFIED per comment 36. Comment 11 seems to say that it isn’t supposed to work on GNU/Linux (where Ctrl+K does).

Note You need to log in before you can comment on or make changes to this bug.