Change panorama shortcut back to CTRL+E

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
--
critical
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: No Real Name, Thanks, Unassigned)

Tracking

unspecified
Future

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b10pre) Gecko/20110125 Firefox/4.0b10pre

As many people commented about the new "CTRL+SHIFT+E" combination, hereby I'm opening a new ticket as Mike Bletzner suggested.

"If we want to re-enable Ctrl/Cmd+E, file another bug for that, and we can
evaluate the late-l10n cost."

I'm on Windows so I can't comment on MAC.
If you use CTRL+E shortcut, it's all simple. If you hit the wrong key, you close a tab, open a new tab. If you close a single tab, you can reopen it by using the History.

BUT. If you use the new CTRL+SHIFT+E combination and hit the W instead of E , ALL of your tabs gets closed, and you can't reopen them and you don't even get a warning dialog (no, don't think putting a dialog there.. that would be only a stupid/dirty workaround).


It is an option that we could have a about:config line which changes this back and forth (ctrl+shift / ctrl) or a configuration editor. The latter wouldn't make it for FF4.


Previous report about this (where you can read the conversation, rage, ideas):
https://bugzilla.mozilla.org/show_bug.cgi?id=624588

Reproducible: Always

Steps to Reproduce:
1. Try to open panorama
2. Lose all your work since you pressed W instead of E.
Actual Results:  
You lose all your work, your current session.

Comment 1

7 years ago
What is the case against using a Function key? By my test F1, F2, F4, F8, F9, F10 and F12 are unused.
(Reporter)

Comment 2

7 years ago
It is far, not comfy. Check your left hand when you use your computer/browse unconsciously.

If you want people to use Panorama as a standard function.. every day, every time, then its have to be close enough to use.
Repeating my comment here then!

at https://bugzilla.mozilla.org/show_bug.cgi?id=624588#c71 limi suggests an audit will be done post Fx4 to see what shortcut keys can be freed up, and possibly give Panorama a better option. I replied thusly:

If you're going to rethink the shortcuts *after* Firefox 4, then it seems that
maybe this shouldn't have a shortcut for now at all.

As you can see from the very angry poster, users learn if you let them! If you
make a shortcut now, only to find a better one later then you'll be going
through this all over again, and in the end people will be asking for a pref to
map back to whatever you choose now, or they'll have to use an extension.

An extension or a pref in the first place seems to be the sane course right
now, then people *already* have it installed if they want to override whatever
is chosen in the future.

Comment 4

7 years ago
For the time being, one of the Panorama team members whipped up a handy extension that lets you set the command key to whatever you want:

https://addons.mozilla.org/en-US/firefox/addon/change-panorama-shortcut/

Marking as future.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Target Milestone: --- → Future
(Reporter)

Comment 5

7 years ago
Thank you very much for the link. That's a really neat idea! :)
(And thanks for the dev who made it!)

Comment 6

7 years ago
I'd rather bind Ctrl-E to focusing search bar

https://support.mozilla.com/pl/questions/773020
(Reporter)

Comment 7

7 years ago
@Gadjo: That's the basic idea behind the shortcut editor, which ..said by the devs, wouldn't make it for version 4.

We ...well... the so called "annoyed people" just want a sane shortcut.
(Or no shortcut? But that's just stupid. Let's leave that addon working then and remove shortcut ...but... most of the people won't know about Panorama's hidden potential.)

Panorama is.. kinda like Compiz from Linux. I'm not an Ubuntard, but curiosity made me try it. Anyway, it really feels like it.. and actually Panorama is something usable not just pure eyecandy. (yaaaay the cube is rotating yaaay! :))

Comment 8

7 years ago
I have had the same problem, and decided I couldn't wait for the Firefox head cheeses to do something that they don't want to do. So I created this simple add-on:

https://addons.mozilla.org/en-US/firefox/addon/change-search-shortcut/

Along with the previous (simple) add-on, which I used as a basis for mine, you should have a complete solution.

Enjoy! Cheers!
(Reporter)

Comment 9

7 years ago
@Skagon: Thanks for your hard work, and I appreciate it.
But .. this is just a dirty workaround and I don't think the developers should use something like this.

We talk about simple users in this case. Who are STILL in the danger of losing ALL of their work once they start using the hotkey.

I don't know about this CTRL+SHIFT+W stuff, but I started to use CTRL+E again. Beats me how, but I never managed to press CTRL+W. Maybe just because I'm used to CTRL+W, T. (It just feels so much different.. so easier to mistype with CTRL+SHIFT.)

Comment 10

7 years ago
@Zsolt Peter:
I know it's a... let's call it "inelegant" solution (I wouldn't exactly call it 'dirty'). However, when people change things that other people have been using for years, and not caring...
Anyhow, from the looks of it, the "official" stance of Mozilla is "we care about Mac OS X, we *deeply* care about Linux, and we couldn't give a toss about Windows". Want proof of that?
Let's check out the source of the Firefox 4b10, /browser/base/content/browser-sets.inc and see what we see:

>#
># Search Command Key Logic works like this:
># 
># Unix: Ctrl+K (cross platform binding)
>#       Ctrl+J (in case of emacs Ctrl-K conflict)
># Mac:  Cmd+K (cross platform binding)
>#       Cmd+Opt+F (platform convention)
># Win:  Ctrl+K (cross platform binding)
>#
># We support Ctrl+K on all platforms now and advertise it in the menu since it is
># our standard - it is a "safe" choice since it is near no harmful keys like "W" as
># "E" is. People mourning the loss of Ctrl+K for emacs compat can switch their GTK
># system setting to use emacs emulation, and we should respect it. Focus-Search-Box
># is a fundamental keybinding and we are maintaining a XP binding so that it is easy
># for people to switch to Linux.
>#

So... you can see, Unix gets TWO shortcuts for access to 'search', Macs get TWO shortcuts for access to 'search', and Windows... heh... well, Windows USED to have two, now have ONE, and the other isn't even there as a non-used option (key_search2) !!!
Moreover, the comments are even more revealing: 
- "we support Ctrl+K on all platforms blah blah" : yeah, whatever
- "people mourning the loss of Ctrl+K [...] and we should respect it" : nice
- "we are maintaining an XP binding so that it's easy for people to switch to Linux" : !!!!!!!!!

From that, you can understand that:
a. Mozilla will go to all lengths to accommodate the needs of Linux or OS X users, but won't waste a second thought on inconveniencing Windows users.
b. Mozilla will even REMOVE options, so that Windows users don't have a second option.
c. Mozilla will try to "encourage" Windows users to switch to Linux, any way they can.

...and all that, even though Windows users are the VAST majority of Firefox users (>85% in my estimates).

Nice going, Mozilla...
(Reporter)

Comment 11

7 years ago
Thanks for the long explanation, source paste. Guess I like Chrome even more, though I've always been a Firefox user.
Mozilla knows very well that Windows is the vast majority of their user base. Your argument isn't very strong and doesn't belong in a bug. If we're looking at number of shorcuts to demonstrate how much Mozilla cares, why don't you try looking for other functions that have multiple shortcuts?

What should be discussed is how many people actually use the ctrl+e shortcut for search. I'm not sure if the test pilot data can be so specific. You could do a search on Input to see how many people have complained to prove whether Mozilla *should* care about this. http://input.mozilla.com/en-US/beta/  

You can also search bugs for the whiteboard status [input] and see how many bugs are being worked on based on direct feedback from users to prove whether or not Mozilla *cares.*

Comment 13

7 years ago
(In reply to comment #12)
> Mozilla knows very well that Windows is the vast majority of their user base.
> Your argument isn't very strong and doesn't belong in a bug.
> [...]
> What should be discussed is how many people actually use the ctrl+e shortcut
> for search.

That is exactly what I am discussing, along with my opinion about its possibility to get resolved in a proper manner.

> I'm not sure if the test pilot data can be so specific. You could
> do a search on Input to see how many people have complained to prove whether
> Mozilla *should* care about this. http://input.mozilla.com/en-US/beta/  

Actually, I already have.
Mozilla interprets that feedback in the way they want. Example:
bug report: "a lot of people get panorama by accident"
actual cause: "a lot of people use CTRL+E for search"
Mozilla reply: "let's change the shortcut of panorama, but leave CTRL+E unused"
 
> You can also search bugs for the whiteboard status [input] and see how many
> bugs are being worked on based on direct feedback from users to prove whether
> or not Mozilla *cares.*

I don't care if Mozilla *cares* about bugs in general. I am really worried about their well-demonstrated behaviour in *this* particular issue.
The problem is that the *majority* of users that *have* this specific problem, either don't know how to express their concern (i.e. file a bug in here), or the "feedback" button, or just won't do it, thinking that "surely someone else must have reported this by now".
I personally know of some 7 people who are using the CTRL+E shortcut for search, who just thought that Panorama popping up was a bug that would eventually get nailed. Even more, I had 2 of these people that, seeing that CTRL+E does nothing in 4b10, thought "they're working on solving the bug; they nailed the Panorama popping up now, in the next beta they'll fix the problem and put search back on".
None of these people bothered submitting feedback or a bug report.

Comment 14

7 years ago
There's an unofficial survey on Mozillazine http://forums.mozillazine.org/viewtopic.php?f=23&t=2032769&start=135 which I figure is nerdier than the population in general, and even most of the posters there don't care for pano.

https://testpilot.mozillalabs.com/testcases/tab-open-close/results.html
Mozilla's own results shows most people have 5 or less tabs open at a time, well below the "problem" pano was intending to fix.

Comment 15

7 years ago
FIRST: I think many people will use this feature in the future (panorama), therefore an EASY shortcut (not 3 fingers!!) is important!!!

SECOND: Just because a survey shows, that people have 5 or less tabs open at a time doesn't mean panorama is unuseful. It's a new thing, and many people will change there tab-behavior, becauso OF this new thing. Like me, I never had to much tabs open, but since panorama it's a completely different thing to me. I work with it, and it's great. 

SO PLEASE MAKE A SHORTCUT WHICH IS ACCEPTABLE (means just two keys to be pressed)!!!!

Comment 16

7 years ago
For Windows users the Ctrl-E shortcut is used for:
1. Search in Windows Explorer and Outlook
2. Search web for IE, Chrome, Opera
3. Search web for Firefox until version 4

Panorama can be very useful, but it should not take the shortcut out of something that the Windows users have access to everywhere else. Or a percentage will seek a different browser or change the shortcut and thus not use Panorama.

My proposals in order of preference are: (1) Ctrl-Right mouse click (2) Ctrl-Q and (3) Ctrl-Tab.

Comment 17

7 years ago
I think that there's another issue that has to be taken into consideration. Ctrl+Shift+E is also a shortcut in the Yahoo Mail, so any user that wants to access panorama while (s)he is reading the emails ends up creating a new folder.

I can understand that FF cannot think in advance about all the possible shortcuts that are used on all the websites, but in this case, Yahoo Mail is widely used and we should take this into account.

Comment 18

7 years ago
Ctrl+Shift+E is also a command in Google Docs, overriding the browser.

Comment 19

7 years ago
This is a daft suggestion. As already mentioned by others I find it particularly infuriating that something used as often as web search has had its standard cross-browser keyboard short-cut removed on the overwhelmingly majority platform.

To add something constructive,  how about making Alt+` to access Panorama. Or alternatively how about changing switch Panormama group to Alt+` and change Ctrl+` to access Panorama? Will this cause issues with IME?

Comment 20

7 years ago
Nice idea, but something like {Alt,Ctrl}+` has a main disadvantage, for ` is a special character and placed all around the keyboard in international keyboard layouts. so in the german keyboard layout for example you had to press Alt+Shift+` where the ` is far away from Alt.

I suggest using a two-key shortcut which consists of Ctrl or Alt and a letter. Ctrl+E would be a good one.
Or Ctrl+Space, like it was in the beginning, I liked that very much, it's very easy to use.

Comment 21

7 years ago
Instead of Alt+` it could be Alt+the-key-above-tab, that would work for any keyboard layout (assumed that the key is not already used).

Comment 22

7 years ago
I very much like the idea of Alt+[something] and Alt+` or whatever is above the tab key seems very appropriate, since that is the key used to switch between tab groups. I don't much care whether ALT or CTRL is used to switch between tab groups or open panorama because I'm sure I'll get used to whatever is chosen. However, personally I think I'll be switching between tab groups a lot more than opening panorama. I would just open it to organize my tab groups.

As far as I can tell, in the realm of left hand accessible CTRL keys, the closet unused one is CTRL+G. It would seem that we're either stuck with CTRL+G, CTRL+B or an ALT+[something] combination, and I really like the ALT route.

Comment 23

7 years ago
Woops, I just threw CTRL+B in there without thinking, since it was about as close as CTRL+G, but it's clearly taken as well. So, scratch that!

Comment 24

7 years ago
To re-post a suggestion at Bug 626448 where there is a lot of opposition to this suggestion.

"Panorama needs its own shortcut, not to steal other standard shortcuts.

If in Firefox 5 a group = window then it makes things much simpler. I would
propose the following:

- Ctrl+` (key above tab) currently toggles tab groups, but this can be changed
to open the Panorama interface.

- Toggling groups/windows can already be performed on Mac using F10 (Exposé to
show all windows from the current applicaton). On Windows, Microsoft has yet to
implement a Application-specific version of Alt-Tab, but we can hint at them to
do so by using Win+` (key above tab) to switch between Firefox windows.

On Windows there is also a standard "Display the Multiple Document Interface
(MDI) child window's System menu" Windows shortcut key which is Alt+- (Alt +
hyphen). This would be very appropriate for Panorama (even for Firefox 4)
considering Panorama is essentially a MDI menu."

Comment 25

7 years ago
I find it a little unfortunate that a valid complaint about an ergonomics problem with the current hotkey (Ctrl+Shift+E) presumes to suggest, right in its title, the what the correct replacement hotkey should be.  It would have been perhaps preferrable to document the issue with the current hotkey separately from its suggested replacement -- and let the choice of replacement hotkey come out of discussion.  Anyway.

A brief overview of recent Ctrl+E/Panorama/Ctrl+Shift+E activity from my point of view:

1) Ctrl+E has been mapped in Firefox to focus the search box for a quite a while (at least all through FF3 and FF3.5)  Ctrl+E is also a standard mapping to "search" for many different applications on Windows, including Windows itself, and for all major web browsers on Windows (Chrome, Safari, Opera, IE.)

2) During Firefox 4 development, Ctrl+E was repurposed to open Panorama. This lasted through most of the FF4 beta as well.

3) Late in the beta, an argument was made (and accepted) that Ctrl+E was not a very ergonomic hotkey for Panorama ("Change Panorama key to something besides CTRL+E" https://bugzilla.mozilla.org/show_bug.cgi?id=612486 ).  Bug 612486 also had support from people who felt Ctrl+E should be restored to its original purpose (focus search bar), since unmapping it from Panorama was half the battle.  At this point Ctrl+E is now unmapped, and Panorama is mapped to Ctrl+Shift+E.

4) We are now seeing an increase in requests to restore the mapping of Ctrl+E to the search box: http://input.mozilla.com/en-US/beta/search?q=ctrl+e+search&product=firefox&version=-- https://support.mozilla.com/pl/questions/773020 https://addons.mozilla.org/en-US/firefox/addon/change-search-shortcut/ https://bugzilla.mozilla.org/show_bug.cgi?id=635497 https://bugzilla.mozilla.org/show_bug.cgi?id=626448 

I agree with this issue's assessment that Ctrl+Shift+E has an ergonomics issue.  I do not agree with this issue's request to restore the Panorama mapping to Ctrl+E.  In my humble opinion, Ctrl+E should be restored to focus the search box -- at least -- or especially -- on Windows.

Comment 26

7 years ago
(In reply to comment #25)

Some great discussion on this thread, glad to see people passionate about both sides of the argument.

> 3) Late in the beta, an argument was made (and accepted) that Ctrl+E was not a
> very ergonomic hotkey for Panorama ("Change Panorama key to something besides
> CTRL+E" https://bugzilla.mozilla.org/show_bug.cgi?id=612486 ).  

Point of fact, we changed the hotkey because we determined that Panorama wasn't baked enough yet for prime-time and that it was too easy to accidentally enter it (trying to hit ctrl+w, etc) and incur perceived data loss. This has been almost entirely mitigated at this stage.

> 4) We are now seeing an increase in requests to restore the mapping of Ctrl+E
> to the search box:

We are also seeing a number of requests for ctrl+e to be mapped backed to Panorama, usually in the form of "why doesn't the panorama key work any more :("
Here is something we haven't considered, change Ctrl+E back to search to fix the regression for Web Search, and Change Ctrl+K from Web Search to Panorama since people are not expecting Ctrl+K to related to Search anyway, even though its been in the menu just as long.
(In reply to comment #27)
> Here is something we haven't considered, change Ctrl+E back to search to fix
> the regression for Web Search, and Change Ctrl+K from Web Search to Panorama
> since people are not expecting Ctrl+K to related to Search anyway, even though
> its been in the menu just as long.

I use ctrl+k for search, as I'm sure many many people do. Especially people who only learned shortcuts in Firefox. Personally I'd be happy to retrain if that's what was best, but don't think people won't be expecting it.

Comment 29

7 years ago
Well, I've been thinking about this off and on for a month.  Here's what I think: For Windows users Ctrl+E has meant "Search" since Firefox 2.  That's about 5 years of soak time.  Search is important; I don't even have to point out all the reasons and evidence for why search is a big part of the web. 

Now if Ctrl+E were just a Firefox thing, I'd say: sure, go ahead, let's be like Apple and kick out the old and make way for the new.  But Ctrl+E is not just a Firefox thing, it's a Windows thing: the Windows shell uses it, and every major browser on Windows uses it.  And for all these things, it means one thing: Search.

On the historical weight of Ctrl+E in Firefox, and the current weight of the shortcut in the Windows environment, I think it's a good idea to just go ahead and map it back to search.

What should we map Panorama to?  Clearly this is an area where Firefox is trying to innovate, and we want to give the feature a premium spot to let it succeed.  But turning to Ctrl+K isn't a good choice.  If Ctrl+E is important to Windows users, then Ctrl+K is equally important to Linux users: it has the weight historical precedence, and some additional reason (like avoiding conflicts with some other hotkeys.)

Search is one of the most important aspects of any modern device.  Search made the short list of the required 4 dedicated keys on Android.  Search is important.  Let's leave search hotkeys alone and in place.  Ctrl+E should search.  Ctrl+K should search.  I understand the desire to promote innovative features, but please, let's not tread on core features to do it.

Updated

7 years ago
Depends on: 626448
Here is what the code current says about this topic of more than 1 key for Web Search:
a/browser/base/content/browser-sets.inc

Search Command Key Logic works like this:
Unix: Ctrl+K (cross platform binding)
      Ctrl+J (in case of emacs Ctrl-K conflict)
Mac:  Cmd+K  (cross platform binding)
      Cmd+Opt+F (platform convention)
Win:  Ctrl+K (cross platform binding)
      Ctrl+E (IE compat)

We support Ctrl+K on all platforms now and advertise it in the menu since it is
our standard - it is a "safe" choice since it is near no harmful keys like "W" as "E" is. People mourning the loss of Ctrl+K for emacs compat can switch their GTK system setting to use emacs emulation, and we should respect it. Focus-Search-Box is a fundamental keybinding and we are maintaining a XP binding so that it is easy for people to switch to Linux.
We're not going to change the shortcut again. It has been around for quite some time and people have become accustomed. Finding a good shortcut that's not already already taken is non-trivial task and if people really want to change it there are add-ons like this: https://addons.mozilla.org/en-US/firefox/addon/customizable-shortcuts/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.