bookmarks button with drop-down missing from nav toolbar and cannot be added back

RESOLVED DUPLICATE of bug 581238

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED DUPLICATE of bug 581238
7 years ago
5 years ago

People

(Reporter: asa, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: firefox 5 fodder)

(Reporter)

Description

7 years ago
In 2011-02-02 nightly build on XP I do not have a bookmarks button in the navigation toolbar. When I customize it shows as being there but closing customize window and it's gone again. Moving it does not help, it always disappears when I close the customize window. 

Tested new profiles and old. If others can reproduce, this is a blocker.
(Reporter)

Comment 1

7 years ago
Additional info, if you hide the menubar (show the Firefox button) then the bookmarks menu re-appears. So, this is a problem in the default configuration only.
(Reporter)

Comment 2

7 years ago
Marcia or Tony, can one of you test this or find someone to test this?
(Reporter)

Comment 3

7 years ago
Just occurred to me that this could be intentional. With the menubar showing, you have a Bookmarks menu item so maybe the bookmarks button is supposed to be hidden? Seems odd though, that a button disappears like that and cannot be added even when you try.
Asa: I think this is by design, but I would have to search through the UI bugs to see the bug where they made this change.
I should clarify that the following happens to me with a clean profile using Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

1. New profile, with Firefox button -> Bookmarks button shows
2. New profile, without Firefox button -> Bookmarks button does not show

In scenario #2 if I try to go to customize and re-add it, I am unable to as as states in Comment 0.
http://support.mozilla.com/en-US/questions/730664 is a thread in the SUMO forum that discusses this issue.
(Reporter)

Comment 7

7 years ago
Disabling the customization is a bug, even if the "only show when menubar hidden" is intentional.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581238

Updated

7 years ago
blocking2.0: ? → ---
(Reporter)

Comment 9

7 years ago
I'm un-duping this and asking that it be an early Firefox 5 fix. 

For Firefox 5, we either need to make the button customizable (like every other toolbar button we have) or we need to remove it from the customization options.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

7 years ago
Status: REOPENED → NEW
Whiteboard: firefox 5 fodder
I don't understand why you want it unduped, it's exactly the same bug.
(Reporter)

Comment 11

7 years ago
Because that bug was marked wontfix and this one is not.  There is a bug here. Won'tfix is for issues which are fully intentional or where the fix would be worse than the flaw. Neither of those is the case here.
(Reporter)

Comment 12

7 years ago
The bug is either the lack of functioning customizability or the misleading appearance of customizability. But either way, it's a bug. And if someone came with a perfect fix for this, we'd take it, right? The only reason to mark it won'tfix is if we really would not accept a proper fix.
that bug wontfix only for Firefox 4.0, not for any future versions
(Reporter)

Comment 15

7 years ago
OK. Then this is the bug for future versions.

Updated

6 years ago
OS: Windows XP → All
Summary: bookmarks button missing from nav toolbar and cannot be added back → bookmarks button with drop-down missing from nav toolbar and cannot be added back when the menu bar is on / Firefox button off

Updated

6 years ago
Duplicate of this bug: 703894

Comment 17

6 years ago
Bug 581238, of which this one may be a duplicate, is still open.
Summary: bookmarks button with drop-down missing from nav toolbar and cannot be added back when the menu bar is on / Firefox button off → bookmarks button with drop-down missing from nav toolbar and cannot be added back

Updated

6 years ago
Duplicate of this bug: 751417

Updated

6 years ago
Duplicate of this bug: 754942
just duping, the future plan is bug 748894
Status: NEW → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581238
You need to log in before you can comment on or make changes to this bug.