The default bug view has changed. See this FAQ.

Prevent Sync Now from blocking the menu (port bug 597788 and bug 631918)

RESOLVED FIXED in seamonkey2.1b3

Status

SeaMonkey
Sync UI
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.1b3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 510170 [details] [diff] [review]
patch [Checkin: comment 2]

The Tools menu is blocked when using Sync Now, for two reasons:
1. Sync login. See bug 631918.
2. Syncing. See bug 597788 (comment 3 also applies to us).
Attachment #510170 - Flags: review?(neil)

Comment 1

6 years ago
Comment on attachment 510170 [details] [diff] [review]
patch [Checkin: comment 2]

So, the problem is that Weave.Service.sync() needs to be async... ;-)

[I noticed that Sync conflicts with Search the Web :-( ]
Attachment #510170 - Flags: review?(neil) → review+
(Assignee)

Comment 2

6 years ago
Comment on attachment 510170 [details] [diff] [review]
patch [Checkin: comment 2]

http://hg.mozilla.org/comm-central/rev/c7d38399359a
Attachment #510170 - Attachment description: patch → patch [Checkin: comment 2]
(Assignee)

Updated

6 years ago
No longer blocks: 615950
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1b3
Depends on: 632433
Blocks: 632433
No longer depends on: 632433
(Assignee)

Updated

6 years ago
Component: UI Design → Sync UI
QA Contact: ui-design → sync-ui
(Assignee)

Updated

6 years ago
No longer blocks: 632433
You need to log in before you can comment on or make changes to this bug.