The default bug view has changed. See this FAQ.

[SeaMonkey] mochitest-chrome: permanent "test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - ..." and others, caused by bug 611653

VERIFIED FIXED in mozilla11

Status

()

Core
Layout
--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {regression})

Trunk
mozilla11
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perma-orange])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Linux, which was not affected (as far as the log goes):
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297155052.1297158726.13175.gz
Linux comm-central-trunk debug test mochitest-other on 2011/02/08 00:50:52
{
8200 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/modules/plugin/test/test_crash_submit.xul | Test timed out.
8847 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/modules/plugin/test/test_npruntime.xul | Test timed out.
9500 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/modules/plugin/test/test_privatemode.xul | Test timed out.
10297 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/modules/plugin/test/test_wmode.xul | Test timed out.
10298 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | 4 test timeouts, giving up.
10299 ERROR TEST-UNEXPECTED-FAIL | (SimpleTest/TestRunner.js) | Skipping 172 remaining tests.
}

OSX 10.5 and 10.6 and Windows, which used to have +/- the same failures as Linux, now report:
{
12603 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/tests/chrome/test_idcheck.xul | Test timed out.
12678 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - autocomplete.controller is undefined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete.xul:50
12692 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - autocomplete.controller is undefined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete2.xul:171
12709 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - autocomplete.controller is undefined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul:171
12736 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete4.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - $("autocomplete").controller is undefined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete4.xul:152
}

I can't say whether this is an improvement or a regression :-|
(Assignee)

Comment 1

6 years ago
NB:
*I think test_idcheck.xul was already there: it should probably be ignored here.
*I can reproduce with test_autocomplete2.xul alone (for example) on my local Windows 2000 with an opt build.
(Assignee)

Comment 2

6 years ago
Ah,
bug 631942 revealed these failures, [I don't know about Linux SeaMonkey...]
which are caused by bug 611652. [I don't know what Firefox has different.]
Blocks: 611652
No longer blocks: 631942
blocking-seamonkey2.1: ? → ---
status2.0: --- → ?
Component: UI Design → Layout
Depends on: 631942
Product: SeaMonkey → Core
QA Contact: ui-design → layout
Summary: mochitest-chrome: permanent "test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - ..." and others, since bug 631942 landing → [SeaMonkey] mochitest-chrome: permanent "test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - ..." and others, revealed after bug 631942 landing
FF bug 631918 has not landed yet, it doesn't even have a review as of now. I ported it nevertheless. That's the difference.
(Assignee)

Comment 4

6 years ago
(In reply to comment #1)
> *I think test_idcheck.xul was already there: it should probably be ignored
> here.

I would guess this could just need bug 631286.

***

(In reply to comment #3)

> FF bug 631918 has not landed yet, it doesn't even have a review as of now.

(Not landed, but has r+, afaics.)

> I ported it nevertheless. That's the difference.

So Firefox possibly doesn't fail yet?
We'll see when that lands...
Depends on: 631918
(Assignee)

Comment 5

6 years ago
(In reply to comment #3)
> FF bug 631918 has not landed yet, it doesn't even have a review as of now. I
> ported it nevertheless. That's the difference.

Bug 631918 has now landed: Firefox passes, SeaMonkey still fails :-|
Would this bug depend on some other port(s) not-yet-done?
(In reply to comment #2)
> bug 631942 revealed these failures, [I don't know about Linux SeaMonkey...]
> which are caused by bug 611652. [I don't know what Firefox has different.]

So, too bad I didn't ask this in the first place: Why do you actually think that either of these two is relevant here?

* I can reproduce the problem (test_autocomplete2.xul) with or without the changes from bug 631942
* bug 631942 just changed something related to doSync (in addition to removing two unused methods), a method which should never be called in a fresh profile (like used for tests) since no Sync account has been set up there yet
* bug 611652 seems to be about something completely different
* the issue at hand is that autocomplete.controller is undefined, so wouldn't it rather make sense that some change related to autocompletion would be the cause? And AFAIK we have different autocomplete implementations (XPFE vs. Toolkit), no?
* unfortunately I don't understand the test details, but to me the key question is where autocomplete.controller is supposed to be set or removed, and whether it's ever set in cases where the test fails. Without knowing what I'm actually talking about I'd guess it would be added through registerFactory, correct?
* the line reported in the error message seems to be off by one
* not sure why FF would behave differently than SM there if it's not different autocomplete implementations. Do we have a different test setup, maybe concerning JS (engine) defaults or something?
(Assignee)

Comment 7

6 years ago
This bug got worse (though probably more explicit):

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297731728.1297735269.11901.gz
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/14 17:02:08
{
7749 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7750 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7751 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7752 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7753 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7754 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7755 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7756 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7825 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - autocomplete.controller is undefined at chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete2.xul:171
7833 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7834 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7835 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7836 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_autocomplete3.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7848 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_bug263683.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7849 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_bug263683.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
7850 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_bug263683.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1371
7851 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/content/tests/chrome/test_bug263683.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run compile-and-go script on a cleared scope at chrome://global/content/autocomplete.xml:1380
}

"Change" timeframe:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c46f36d6b1fe&tochange=4c2962ad0a9d
Bug 630072!
Depends on: 630072
(In reply to comment #7)
> This bug got worse (though probably more explicit):
> 
> http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1297731728.1297735269.11901.gz
> WINNT 5.2 comm-central-trunk debug test mochitest-other on 2011/02/14 17:02:08
> {
> 7749 ERROR TEST-UNEXPECTED-FAIL |
> chrome://mochitests/content/chrome/suite/common/places/tests/test_bug549192.xul
> | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - attempt to run
> compile-and-go script on a cleared scope at
> chrome://global/content/autocomplete.xml:1371

I fixed some errors like this the first time around by canceling the autocomplete request before finishing the test. See

https://bugzilla.mozilla.org/attachment.cgi?id=508580&action=diff
(Assignee)

Comment 9

6 years ago
(In reply to comment #2)
> caused by bug 611652.

Bug 611652 comment 15:
{
Johnny Stenback (:jst, jst@mozilla.com)      2011-02-12 22:09:37 PST

(A fix for bug 611653 was landed as
http://hg.mozilla.org/tracemonkey/rev/6882211c4a80, mistakenly referring to
this bug)
}


(In reply to comment #8)
> I fixed some errors like this the first time around by canceling the
> autocomplete request before finishing the test.

Yeah, that very fix is what is causing comment 0 errors ;-<
This bug is to investigate and fix the current situation...
Blocks: 611653
No longer blocks: 611652
(Assignee)

Comment 10

6 years ago
(In reply to comment #6)

> So, too bad I didn't ask this in the first place: Why do you actually think
> that either of these two is relevant here?
> 
> * I can reproduce the problem (test_autocomplete2.xul) with or without the
> changes from bug 631942
> * bug 631942 just changed something related to doSync (in addition to removing
> two unused methods), a method which should never be called in a fresh profile
> (like used for tests) since no Sync account has been set up there yet

Iirc, I was assuming fixing bug 631942 let more tests run on tinderboxes, so I filed this bug about the newly reported errors.

> * bug 611652 seems to be about something completely different
> * the issue at hand is that autocomplete.controller is undefined, so wouldn't
> it rather make sense that some change related to autocompletion would be the
> cause? And AFAIK we have different autocomplete implementations (XPFE vs.
> Toolkit), no?

xactly, see (comment 8 and) comment 9.

> * unfortunately I don't understand the test details, but to me the key question
> is where autocomplete.controller is supposed to be set or removed, and whether
> it's ever set in cases where the test fails. Without knowing what I'm actually
> talking about I'd guess it would be added through registerFactory, correct?
> * the line reported in the error message seems to be off by one
> * not sure why FF would behave differently than SM there if it's not different
> autocomplete implementations. Do we have a different test setup, maybe
> concerning JS (engine) defaults or something?

Firefox uses
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/autocomplete.xml
{
129       <property name="controller" onget="return this.mController;" readonly="true"/>
...
889         controller.stopSearch();
}
Ftr, "controller" was added in
http://bonsai.mozilla.org/cvslog.cgi?file=mozilla/toolkit/content/widgets/autocomplete.xml&rev=HEAD&mark=1.10#1.11

But SeaMonkey (still) uses
http://mxr.mozilla.org/mozilla-central/source/xpfe/components/autocomplete/resources/content/autocomplete.xml
{
640       <method name="stopLookup">
}

Per
http://mxr.mozilla.org/mozilla-central/source/toolkit/content/xul.css#743
{
748 %ifdef MOZ_THUNDERBIRD
749 %define AUTOCOMPLETE_OLD_STYLE
750 %elifdef MOZ_STANDALONE_COMPOSER
751 %define AUTOCOMPLETE_OLD_STYLE
752 %elifdef MOZ_SUITE
753 %define AUTOCOMPLETE_OLD_STYLE
754 %endif
...
}

So these Toolkit tests were fixed with Firefox specific code :-/
(In reply to comment #10)
> Iirc, I was assuming fixing bug 631942 let more tests run on tinderboxes, so I
> filed this bug about the newly reported errors.

OK, since they are not related I'll remove the dependency.

> Firefox uses
> http://mxr.mozilla.org/mozilla-central/source/toolkit/content/widgets/autocomplete.xml
> {
> 129       <property name="controller" onget="return this.mController;"
> readonly="true"/>
> (...)

Ah, that explains it. I have to admit I was too lazy to dig deeper.

That said, it should be easy to check for the availability of controller but I'm not so sure about the new alternative code path (haven't checked). Maybe ask Neil?

> So these Toolkit tests were fixed with Firefox specific code :-/

To be fair, the "Firefox specific code" is actually Toolkit code, which just happens to not be used by SM and TB right now.
No longer depends on: 631942
Created attachment 514162 [details] [diff] [review]
(Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope"
[Checked in: Comment 16]

If I then comment out the calls to stopSearch, the tests pass!
Attachment #514162 - Flags: review?(iann_bugzilla)
(In reply to comment #12)
> If I then comment out the calls to stopSearch, the tests pass!
(We don't need to call stopSearch because we use setTimeout which gets automatically cancelled when the test is unloaded.)

Updated

6 years ago
Attachment #514162 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 514162 [details] [diff] [review]
(Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope"
[Checked in: Comment 16]

Lives in m-c but not even part of the Firefox build system.
Attachment #514162 - Flags: approval2.0?
(Assignee)

Updated

6 years ago
No longer depends on: 631918
Keywords: regression
Comment on attachment 514162 [details] [diff] [review]
(Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope"
[Checked in: Comment 16]

a=beltzner, NPTOB
Attachment #514162 - Flags: approval2.0? → approval2.0+
Comment on attachment 514162 [details] [diff] [review]
(Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope"
[Checked in: Comment 16]

Pushed changeset 7e47bbbebc28 to mozilla-central.
I asked dmandelin on IRC and he said that he put those calls to stopSearch because the OSX64debug builds failed. Certainly I can't reproduce the failures on Windows. We have a number of options:
1. Push a test backout to try to see if any debug builds still fail
   (feel free to do release builds too, but I don't expect them to fail).
2. As 1, but increase the timeout of the cleanup block to 100s.
3. Condition the calls on existence or wrap them in try/catch.
4. Add some ugly code to autocomplete.xml to simulate a controller.
(In reply to comment #17)
> I asked dmandelin on IRC and he said that he put those calls to stopSearch
> because the OSX64debug builds failed. Certainly I can't reproduce the failures
> on Windows. We have a number of options:
> 1. Push a test backout to try to see if any debug builds still fail
>    (feel free to do release builds too, but I don't expect them to fail).
> 2. As 1, but increase the timeout of the cleanup block to 100s.
> 3. Condition the calls on existence or wrap them in try/catch.
> 4. Add some ugly code to autocomplete.xml to simulate a controller.

#1 seems the best to me, and failing that, #3. But I know little about this code so don't accord my opinion much weight.
(Assignee)

Comment 19

6 years ago
Comment on attachment 514162 [details] [diff] [review]
(Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope"
[Checked in: Comment 16]

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1298589076.1298592099.10983.gz
Linux comm-central-trunk debug test mochitest-other on 2011/02/24 15:11:16

Comment 7 additional failures are V.Fixed :-)

Ftr, they were counted as +/- 50 failures whereas logs listed +/- 10 errors only... (wrt bug 451287)
Attachment #514162 - Attachment description: Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope" → Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope" [Checked in: Comment 16]
(Assignee)

Updated

6 years ago
Depends on: 451287
(Assignee)

Comment 20

6 years ago
(In reply to comment #17)
> 1. Push a test backout to try to see if any debug builds still fail
>    (feel free to do release builds too, but I don't expect them to fail).
> 2. As 1, but increase the timeout of the cleanup block to 100s.

Submitted:
http://tbpl.mozilla.org/?tree=MozillaTry&rev=3903bb34d218
http://tbpl.mozilla.org/?tree=MozillaTry&rev=e3c50a937d2d
(Assignee)

Updated

6 years ago
Summary: [SeaMonkey] mochitest-chrome: permanent "test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - ..." and others, revealed after bug 631942 landing → [SeaMonkey] mochitest-chrome: permanent "test_autocomplete2.xul | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - ..." and others, caused by bug 611653
If 1. doesn't work, then maybe the correct fix is for toolkit autocomplete to stop the search when it is destroyed.
(Assignee)

Comment 22

6 years ago
Created attachment 515266 [details] [diff] [review]
(Bv1) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_cocoa.xul

This option 1 fix succeeded as
http://tbpl.mozilla.org/?tree=MozillaTry&rev=3b35034b050f

Ftr, option 2 fix succeeded too as
http://tbpl.mozilla.org/?tree=MozillaTry&rev=e4836345d9ea

Rename test_autocomplete.xul to make it more explicit why it runs on mac only.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #515266 - Flags: review?(enndeakin)
Whiteboard: [perma-orange] → [perma-orange][approved-patches-landed]

Updated

6 years ago
Whiteboard: [perma-orange][approved-patches-landed] → [perma-orange][approved-patches-landed][not-ready]

Comment 23

6 years ago
Comment on attachment 515266 [details] [diff] [review]
(Bv1) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_cocoa.xul

Better would be to be more specific with the filename since the test is checking caret position in autocomplete widgets:

test_autocomplete_mac_caret.xul

I'm ok with removing the calls to stopSearch but what has changed between when they were added? The autocomplete tests have always had some intermittent problems that cause later tests to fail inexplicably.
(Assignee)

Comment 24

6 years ago
(In reply to comment #23)

> test_autocomplete_mac_caret.xul

I'll rename it before checking it in.

> I'm ok with removing the calls to stopSearch but what has changed between when

No idea. And no details about the initial issue. (See comment 17.)

> they were added? The autocomplete tests have always had some intermittent
> problems that cause later tests to fail inexplicably.

Hum, that should be an separate/explicit bug...
(Assignee)

Comment 25

6 years ago
Comment on attachment 515266 [details] [diff] [review]
(Bv1) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_cocoa.xul

Ping for review.
(Assignee)

Comment 26

5 years ago
Comment on attachment 515266 [details] [diff] [review]
(Bv1) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_cocoa.xul

Ping for review.
Attachment #515266 - Flags: review?(neil)
Maybe he's expecting a new patch?
(Assignee)

Comment 28

5 years ago
Created attachment 576327 [details] [diff] [review]
(Bv1a) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul
[Checked in: Comment 31]

Bv1, with comment 23 suggestion(s).
Attachment #515266 - Attachment is obsolete: true
Attachment #576327 - Flags: review?(neil)
Attachment #576327 - Flags: review?(enndeakin)
Attachment #515266 - Flags: review?(neil)
Attachment #515266 - Flags: review?(enndeakin)

Comment 29

5 years ago
Comment on attachment 576327 [details] [diff] [review]
(Bv1a) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul
[Checked in: Comment 31]

OK, but let's watch to look for this failing again.
Attachment #576327 - Flags: review?(enndeakin) → review+
(Assignee)

Updated

5 years ago
Attachment #576327 - Flags: review?(neil)
(Assignee)

Updated

5 years ago
Attachment #576327 - Attachment description: Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul. → (Bv1a) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul.
(Assignee)

Updated

5 years ago
Attachment #514162 - Attachment description: Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope" [Checked in: Comment 16] → (Av1) Fix for "An error occurred - attempt to run compile-and-go script on a cleared scope" [Checked in: Comment 16]
(Assignee)

Updated

5 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [perma-orange][approved-patches-landed][not-ready] → [c-n: Bv1a to m-c] [perma-orange]
Target Milestone: --- → mozilla11
http://hg.mozilla.org/integration/mozilla-inbound/rev/8e47f9fbd5f2
Keywords: checkin-needed
Whiteboard: [c-n: Bv1a to m-c] [perma-orange] → [perma-orange]
https://hg.mozilla.org/mozilla-central/rev/8e47f9fbd5f2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Attachment #576327 - Attachment description: (Bv1a) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul. → (Bv1a) Remove calls to Firefox stopSearch(), Rename test_autocomplete.xul to test_autocomplete_mac_caret.xul [Checked in: Comment 31]
(Assignee)

Comment 32

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1322504054.1322507762.12447.gz
OS X 10.6 comm-central-trunk debug test mochitest-other on 2011/11/28 10:14:14

V.Fixed :-)
(And Firefox is still passing.)

To summarize:
patch Av1 fixed bug 630072 regression in Gecko 2.0 cycle :-)
patch Bv1a fixed bug 611652 regression (at last) in Gecko 11 cycle: these tests had been failing for SeaMonkey in the meantime.
Status: RESOLVED → VERIFIED
status2.0: ? → ---
(Assignee)

Comment 33

5 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #32)
> patch Bv1a fixed bug 611652 regression (at last) in Gecko 11 cycle

Arf, bug 611653!
You need to log in before you can comment on or make changes to this bug.