Last Comment Bug 631973 - configuring to open firefox in private browsing mode thru quicklaunch shortcut icons, opens 2 windows: one in normal mode and another in private browsing mode
: configuring to open firefox in private browsing mode thru quicklaunch shortcu...
Status: VERIFIED FIXED
: regression, relnote
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 5
Assigned To: :Ehsan Akhgari
:
Mentors:
: 653360 (view as bug list)
Depends on: 786897
Blocks: 603272
  Show dependency treegraph
 
Reported: 2011-02-07 01:09 PST by Srinath N [:srinath]
Modified: 2012-08-30 04:31 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
The target which was tweaked (36.72 KB, image/jpeg)
2011-02-07 01:27 PST, Srinath N [:srinath]
no flags Details
issues (38.76 KB, image/jpeg)
2011-02-07 03:54 PST, Srinivas
no flags Details
Patch (v1) (1.08 KB, patch)
2011-02-07 15:40 PST, :Ehsan Akhgari
gavin.sharp: review+
Details | Diff | Splinter Review

Description Srinath N [:srinath] 2011-02-07 01:09:40 PST
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

Configuring to open firefox in private browsing mode thru quicklaunch shortcut icon, opens 2 windows: one in normal mode and another in private browsing mode

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla firefox 4.0B10
2. Add a shortcut to the quick launch area for firefox (can be done while installing itself)
3. Right click on the Firefox quick launch icon
4. Click "Properties"
5. Edit 'Target' to make it accept the -private switch
    eg: "C:\Program Files\Mozilla Firefox 4.0 Beta 8\firefox.exe"  -private
6. Apply the changes and Ok the changes
7. Now launch firefox through the firefox quick launch icon
8. Observe the number of firefox windows that open.
Actual Results:  
2 windows open,
one with the private browsing mode ON and another in the normal browsing mode.

Expected Results:  
only 1 window should open and it should open in private browsing mode.
Comment 1 Srinath N [:srinath] 2011-02-07 01:27:05 PST
Created attachment 510236 [details]
The target which was tweaked
Comment 2 Srinivas 2011-02-07 03:53:42 PST
Both the windows will starting in private browsing mode

Noticed few issues

Check the attachment

1 [review].The first image(private browsing window) shows that the window is in private browsing so the Menu button should be in violet color but here the Menu button is in orange color

2.The second window(Normal Window) also enters into private browsing mode as the we can see the option "Stop Private Browsing" which can be observed by going to Menu button

3.Unable to come out of private browsing mode by clicking "Stop Private Browsing" as it is grayed out and the shortcut Ctrl+Shift+P is also not working

Noticed issues 2,3 with 3.6.13 also
Comment 3 Srinivas 2011-02-07 03:54:19 PST
Created attachment 510246 [details]
issues
Comment 4 Alice0775 White 2011-02-07 04:14:04 PST
Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/114966e5b168
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre ID:20101126034710
Fails(2 browser is opened):
http://hg.mozilla.org/mozilla-central/rev/98184990f3ba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101124 Firefox/4.0b8pre ID:20101126090802
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=114966e5b168&tochange=98184990f3ba
Comment 5 Alice0775 White 2011-02-07 04:19:38 PST
It happens on Linux build too and it is same regression range.
Mozilla/5.0 (X11; Linux i686; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre ID:20110207030345
Comment 6 :Ehsan Akhgari 2011-02-07 15:40:54 PST
Created attachment 510427 [details] [diff] [review]
Patch (v1)

The fact that the private browsing command is disabled is by design.  This patch fixes the double-window creation problem.
Comment 7 :Ehsan Akhgari 2011-03-23 13:43:14 PDT
Gavin: ping?
Comment 9 Vlad [QA] 2011-04-04 05:46:36 PDT
I can still reproduce this issue on 
Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110403 Firefox/4.2a1pre 

Adding " -private switch" at the end of the "Target" line is causing the opening of two separate windows, one in normal mode and one in private mode.
Comment 10 George Carstoiu 2011-04-05 07:43:53 PDT
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110404 Firefox/4.2a1pre

By adding "-private" only one window is opened that is in Private browsing. 

"Stop private browsing" option is grayed out and the shortcut does not function - this may be a problem.

By adding "-private switch", Firefox opens 2 windows that are both in Private browsing. One of the windows contains a link to the website: http://www.ansaldo-sts.com/AnsaldoSTS/EN/index.sdo
Comment 11 AndreiD[QA] 2011-04-07 08:06:36 PDT
Works for Me on:
 Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre
AND ON
 Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre

Marking it as Verified
Comment 12 Srinath N [:srinath] 2011-04-08 17:52:23 PDT
Apologies for the delay in getting to this.
I tried the reported scenario with Firefox 4.2a1pre (Nightly build Built on 08-Apr-2011 downloaded from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-4.2a1pre.en-US.win32.installer.exe) on Windows 7 OS. 

Following are my observations:
1. Only one window opens --> Correct behaviour
2. Stop Private Browsing is disabled --> By Design as per ehsan's comments
3. The Firefox Menu option is in orange colour NOT purple --> This might still be an issue since in Private Browsing mode, the colour of Firefox menu option is PURPLE.

Hence reopening the defect. Kindly consider the same.
Comment 13 :Ehsan Akhgari 2011-04-12 21:23:17 PDT
(In reply to comment #12)
> 3. The Firefox Menu option is in orange colour NOT purple --> This might still
> be an issue since in Private Browsing mode, the colour of Firefox menu option
> is PURPLE.

Yeah, I need to investigate that.  But would you mind filing a new bug, please?  This is a different issue than the one this bug was originally filed for, and fixing them in separate bugs makes things less confusing for us in the future.  Thanks!
Comment 14 Srinath N [:srinath] 2011-04-13 18:07:13 PDT
Sure. Raised 649878 for the menu button issue. Retested this with Nightly built on 13-4-2011. Only one window opens up in private browsing mode.
Marking this defect as Resolved - Fixed
Comment 15 AndreiD[QA] 2011-04-22 05:49:33 PDT
Verified on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110421 Firefox/6.0a1
Comment 16 :Ehsan Akhgari 2011-05-03 15:27:39 PDT
*** Bug 653360 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.