Closed Bug 633337 Opened 9 years ago Closed 9 years ago

pattern viewBoxes still not treated correctly

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla5

People

(Reporter: longsonr, Assigned: longsonr)

References

Details

Attachments

(1 file, 3 obsolete files)

No description provided.
Attached patch patch (obsolete) — Splinter Review
Assignee: nobody → longsonr
Attachment #511527 - Flags: review?(jwatt)
Comment on attachment 511527 [details] [diff] [review]
patch

pservers-pattern-02 seems to be failing on how viewBoxes are interpreted too so I'll see if I can fix that too.
Attachment #511527 - Flags: review?(jwatt)
Attached patch diff -w patch (obsolete) — Splinter Review
Only fixes pservers-pattern-04, looks like pservers-pattern-02 is some other issue
Attachment #511527 - Attachment is obsolete: true
Attachment #512022 - Flags: review?(jwatt)
Attached patch standard patch (obsolete) — Splinter Review
The patch does fix bug 589651 though.
Blocks: 589651
Do you understand the use of MaxExpansion, Robert?
bug 384208. If a pattern is rotated then the bounding box can be bigger. Probably should try to convert one of the testcases from that bug into a reftest.
The MaxExpansion call is in the |else|, so it's used for patternContentUnits=userSpaceOnUse, not =objectBoundingBox.

I have to prepare for the SVG WG F2F tomorrow (taking place all next week), and since we're going to have to wait until after ff4 to land this anyways, I'll come back to this after the F2F.
Why are you worried about the MaxExpansion call? I haven't changed that.
Attachment #512023 - Flags: review+
Because I needed to understand the surrounding code and how the function works and is used as a whole to understand the change.
Attachment #512022 - Flags: review?(jwatt)
Attachment #512022 - Attachment is obsolete: true
Attachment #512023 - Attachment is obsolete: true
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/4ff3dfaadd48
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.2
Duplicate of this bug: 661863
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.