bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

cpu spinning freeze when opening the add-on manager for the first time in a new profile

VERIFIED FIXED in 6.0.0

Status

addons.mozilla.org Graveyard
Discovery Pane
P2
critical
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: al_9x, Assigned: potch)

Tracking

unspecified
6.0.0
x86
Windows XP

Details

(Whiteboard: [post-freeze+])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

1. open the add-on manager
2. it starts in the "get add-ons" pane
3. at first there is some loading progress
4. cpu spikes fairly quickly
5. unresponsive script warning: https://static.addons.mozilla.net/media/js/zamboni/discovery-pane-min.js?build=ea72fbb:16
6. "Continue" leaves Fx permanently frozen with a pegged cpu/core (main thread)

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Duplicate of this bug: 637037
Also, as per bug 637037, clicking on "Stop Script" on the warning, hangs the process, kill the process is the only way to get any control back.
Works fine on today's nightly.  CCing QA to try to reproduce.  If anyone can reproduce can you let us know if you're logged in or not and what all you see on the page?

Also CCing mossop on the off chance this is some weird interaction with the chrome.
I have never seen this issue and also can't reproduce on any of our machines.
I'm using Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b13pre) Gecko/20110226 Firefox/4.0b13pre and it's still not working.  And the B12 is still hosed for me as well.

I've tried the nightly in safe mode and it still happens.
Reported affected platforms so far are all windows.  QA: can you try that? thanks

Comment 7

8 years ago
I haven't been able to reproduce this behavior so far.

Comment 8

8 years ago
Works for Me on:
Mozilla/5.0 (Windows NT 6.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Duplicate of this bug: 637085

Comment 10

8 years ago
Since 637085 was marked "resolved" instead of this one, I'll re-post this comment, in case it doesn't get looked at in the other thread:

"Using the most recent nightly, I still have the same problem. CPU is dual-core
3.2GHz, and I have 8GB RAM. Only one CPU core gets 80-90% usage, the rest of
the system doesn't get stuck, only Minefield does.

Interestingly, it seems it freezes while loading data from the AMO site (url
shows up in bottom-left corner). It seems like the other add-on pages are
working, because for the first couple of seconds I can navigate to them and see
their content, but they then freeze. If I leave the Get Add-Ons tab selected,
it freezes, usually before displaying any content. It feels like the AMO web
content is freezing on the Get Add-Ons tab and taking down the rest of the
browser with it, as opposed to one of the other add-on tabs being the source of
the problem, but I can't be certain."

Also, this occurs on an existing profile, not just on a new profile - so the description of this bug is inaccurate, and perhaps #637085 should have been left active and this one resolved as a duplicate. In either case, this issue still happens for me using B12 and today's B13pre nightly on Win7 x64, with an existing profile, even in safe mode.

Comment 11

8 years ago
Further information: I have more reason to believe that this is due to the Get Add-Ons tab. I re-tested again with B12, and the tab that came up by default was the tab showing the currently installed add-ons. I was able to navigate around this tab without error. However, when I switched to the Get Add-ons tab, the spinner came up, momentarily followed by the unresponsive script dialog. Now that FF remembers the active tab as the Get Add-ons tab, it opens that tab by default when going to the Tools / Add-ons menu, and thus freezes every time. Even if I immediately switch to the Manage Add-ons tab, the Get Add-ons content is still loading in the background, and will freeze the Manage Add-ons tab. If I can find the about:config setting to reset the default tab to the Manage Add-ons tab instead of Get Add-ons, I can probably better confirm this.
If you are using nightlies (not b12) and you can reproduce this then does it go away when you disable extensions.getAddons.cache.enabled in about:config?
Created attachment 515707 [details]
Contents received from 63.245.209.158

Received code that FF claims is taking too long.
Since some people are seeing no issues, and others are, and I'm assuming using the same executable, can we verify some things?

Like that static.addons.mozilla.net points to static-addons.amo-zlb.sj.mozilla.com and has the IP of 63.245.209.158.

Also that the contents of the received file are identical down to the byte from a system that isn't working, like mine, of which I have uploaded a copy as an attachment.

Comment 15

8 years ago
Dave, interesting result: At first it seemed that disabling the cache had no effect, the page still came up with the unresponsive script error (does anyone else find it ironic that a script with the word "zamboni" in it is "freezing" the browser?). However, when I click "Stop", the add-ons page does appear, and seems functional. Clicking "Continue" still freezes it on a blank page. Re-enabling the cache reverts to the original behavior, where it freezes either way (clicking "Stop" doesn't even dismiss the script dialog, it's frozen in place).

So, we can at least affect the effect with this setting - that's gotta count for something.
(In reply to comment #12)
> If you are using nightlies (not b12) and you can reproduce this then does it go
> away when you disable extensions.getAddons.cache.enabled in about:config?

Well, that was interesting.

The change didn't affect that the script timed out (which I think is something it shouldn't do) BUT! at least when I clicked on the Cancel button, FF remained responsive, and I can't tell what the issue was since it looks the same to me before I was having the trouble.

I am retrying and using the Continue button now (which did go away...)

Well, it should have timed out, and is now just being unresponsive.  Yeah, a minute later, I'm just spinning my wheels right now.

So a little bit of an improvement with that change.

Comment 17

8 years ago
Bryan, I can confirm I see the same IP for that host. The copy of "https://static.addons.mozilla.net/media/js/zamboni/discovery-pane-min.js?build=ea72fbb:16" that I receive seems to be byte-for-byte an exact copy of the attachment you posted.
Do you still see the unresponsive script message when loading this url normally in the browser: https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT
Bryan and Adam, do you also see this unresponsive script warning with b11 nowadays? If it doesn't happen it would be really helpful to check for a regression range.
Thanks Adam.  I just wanted that nailed down. Been bit by that before! :/

Dave, I still get an unresponsive browser.  It still just hangs if I click Continue.  And if I click Stop, the browser is responsive again.  And that's with the cache disabled.
(Reporter)

Comment 21

8 years ago
(In reply to comment #18)
> Do you still see the unresponsive script message when loading this url normally
> in the browser:
> https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT

Yes, and the subsequent hang.  Beta8, the oldest I tried, has the problem, 3.6.13 loads it fine.
(In reply to comment #21)
> Yes, and the subsequent hang.  Beta8, the oldest I tried, has the problem,
> 3.6.13 loads it fine.

Could you please even check older betas? Given that 3.6 works gives me the impression that we really have a regression here.
I did a quick downgrade to B11, same thing happens.
I'm guessing this is related to Personalized Recommendations, which was turned on Thursday. I don't think it's a Firefox regression.
B1 works!
B2 doesn't!

Also, if you continue the page (I'm talking about https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT), it will time out again, and again, and doesn't just hang the browser.  It still pegs the core/CPU while doing so.  B1 did just fire up, there didn't seem to be even a hint that there was something running in the background.

Comment 27

8 years ago
(In reply to comment #18)
> Do you still see the unresponsive script message when loading this url normally
> in the browser:
> https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT

I also do get the unresponsive script warning at that URL.

Justin - that this is related to the new Personalized Recommendations just turned on the other day does make sense, as older versions now experience this problem, which they didn't before. I'm fairly sure that I've gone to the Add-Ons page since B11pre, and had this been a browser problem the whole time, surely it would have been reported before now. That said, it may be a browser bug related to the new feature, but the new feature is a very likely suspect for being the place to look.
What add-ons do you all have installed when you hit the page?
(Reporter)

Comment 29

8 years ago
(In reply to comment #25)
> B1 works!

Not for me.  In fact, 3.6.13 doesn't work either.  It worked for me initially because it was not a new profile and had dom storage turned off (dom.storage.enabled).  With dom storage enabled it fails same as 4.0.  With dom storage disabled the page loads even in 4.0 albeit with js error:

Error: localStorage is null
Source File: https://static.addons.mozilla.net/media/js/zamboni/discovery-pane-min.js?build=ea72fbb
Line: 16

Comment 30

8 years ago
(In reply to comment #28)
> What add-ons do you all have installed when you hit the page?

This happens for me even with all add-ons disabled (safe mode) - including the script error loading that URL directly in the browser.
(In reply to comment #28)
> What add-ons do you all have installed when you hit the page?

Loading the URL normally or with the cache disabled as in comment 12 means that we don't pass add-on data to the page so it is happening irrespective to that.

Looks like we may have two issues here, one a long running script on AMO and the other some JS engine issue that hangs us when trying to stop the script.
(Reporter)

Comment 32

8 years ago
> Looks like we may have two issues here, one a long running script on AMO and
> the other some JS engine issue that hangs us when trying to stop the script.

Another issue is the use of localStorage by discovery-pane-min.js without checking if it's enabled.

I never had a problem stopping the script, no hang after stop.
(Reporter)

Comment 33

8 years ago
(In reply to comment #32)
> Another issue is the use of localStorage by discovery-pane-min.js without
> checking if it's enabled.

Bug 637475
Based on comment 27 loading the page in a regular browser causes the same issue so it can't be an add-ons manager problem, more likely something specific with AMO's code so over to there for now. Still might be a JS engine bug or something here though but not sure how to narrow this down further though.
Component: Add-ons Manager → Discovery Pane
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → discoverypane
Version: Trunk → unspecified

Comment 35

8 years ago
Good this is being looked at. Has been nagging me for days now.
CCing some JS people
Assignee: nobody → cwiemeersch
Priority: -- → P2
Target Milestone: --- → 6.0.1
Does localStorage access happen on the main thread? 

This is the main app code: https://github.com/jbalogh/zamboni/blob/master/media/js/zamboni/discovery.js
While the culprit may indeed eventually turn up to be a bad js script, I find it rather bad that by default, even clicking the stop button hangs the program (although I actually think by the time it displays the alert and wants to accept events, it's already hung itself.)

For sheets and grindles, I decided to try https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT with Chrome and IE9.  Chrome kept timing out (although it's updating right now, and I'll give it a try when it's done) and IE9 just sits there, but at least stops when I hit the Escape key.

OK, the updated chrome doesn't even time out, it just sits there, but at least I can stop it or kill the tab.

It may not be an issue under other OS, but under Windows, it sure is.

Although I'm wondering since that other Windows installations aren't having the issue, it might actually be something to do with a Windows component.
Can someone who is having issues go to http://people.mozilla.com/~jbalogh/storage.html and tell me if it gets to step 5 or hangs before that?
(Reporter)

Comment 40

8 years ago
(In reply to comment #39)
> Can someone who is having issues go to
> http://people.mozilla.com/~jbalogh/storage.html and tell me if it gets to step
> 5 or hangs before that?

b12 gets to 5.
5. Cleared localStorage. All done.
(In reply to comment #39)
> Can someone who is having issues go to
> http://people.mozilla.com/~jbalogh/storage.html and tell me if it gets to step
> 5 or hangs before that?

Pretty much completes in a flash on B12 and yesterday's daily (Yep, I just started it!)
I wonder if it is somehow related to issue we have like bug 637639.
(Reporter)

Comment 43

8 years ago
(In reply to comment #42)
> I wonder if it is somehow related to issue we have like bug 637639.

This bug manifests in a new profile, profile upgrades and modified prefs are not a factor.

Comment 44

8 years ago
(In reply to comment #43)
> (In reply to comment #42)
> > I wonder if it is somehow related to issue we have like bug 637639.
> 
> This bug manifests in a new profile, profile upgrades and modified prefs are
> not a factor.

I'm not sure if you meant that bug 637639 only manifests in a new profile, or if you meant that this bug does, but to disambiguate, this bug (#636884) - despite the title - does indeed manifest in existing profiles, not just new ones.
(Reporter)

Comment 45

8 years ago
> this bug (#636884) -
> despite the title - does indeed manifest in existing profiles, not just new
> ones.

That's irrelevant to the question posed by Henrik Skupin.  If it manifests in a new profile, then profile upgrades and modified prefs are not a factor.
Since it's happening cross-browser, we should also look at plugins. What plugins (including versions) do you have installed system-wide? (you can find this in about:plugins)
(Reporter)

Comment 47

8 years ago
Still happens with all plugins disabled.

about:plugins shows: No enabled plugins found
Here's my about:plugins, but doesn't safe-mode already kill them anyway, and this bug happens even in safe mode?

Enabled plugins
Find more information about browser plugins at mozilla.org.
Find updates for installed plugins at mozilla.com/plugincheck.
Help for installing plugins is available from plugindoc.mozdev.org.
Google Talk Plugin Video Accelerator

    File: npgtpo3dautoplugin.dll
    Version: 0.1.43.5
    Google Talk Plugin Video Accelerator version:0.1.43.5

MIME Type 	Description 	Suffixes
application/vnd.gtpo3d.auto 		
Google Talk Plugin

    File: npgoogletalk.dll
    Version: 1.9.2.0
    Version 1.9.2.0

MIME Type 	Description 	Suffixes
application/googletalk 	Google voice and video chat 	googletalk
Google Update

    File: npGoogleOneClick8.dll
    Version: 1.2.183.39
    Google Update

MIME Type 	Description 	Suffixes
application/x-vnd.google.oneclickctrl.8 		
Unity Player

    File: npUnity3D32.dll
    Version: 2.6.1.31223
    Unity Player 2.6.1f3

MIME Type 	Description 	Suffixes
application/vnd.unity 	Unity Player datafile 	unity3d
Shockwave Flash

    File: NPSWF32.dll
    Version: 10.2.152.26
    Shockwave Flash 10.2 r152

MIME Type 	Description 	Suffixes
application/x-shockwave-flash 	Adobe Flash movie 	swf
application/futuresplash 	FutureSplash movie 	spl
Java(TM) Platform SE 6 U23

    File: npjp2.dll
    Version: 6.0.230.5
    Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers

MIME Type 	Description 	Suffixes
application/x-java-applet 	Java Applet 	
application/x-java-bean 	JavaBeans 	
application/x-java-vm 		
application/x-java-applet;version=1.1.1 		
application/x-java-bean;version=1.1.1 		
application/x-java-applet;version=1.1 		
application/x-java-bean;version=1.1 		
application/x-java-applet;version=1.2 		
application/x-java-bean;version=1.2 		
application/x-java-applet;version=1.1.3 		
application/x-java-bean;version=1.1.3 		
application/x-java-applet;version=1.1.2 		
application/x-java-bean;version=1.1.2 		
application/x-java-applet;version=1.3 		
application/x-java-bean;version=1.3 		
application/x-java-applet;version=1.2.2 		
application/x-java-bean;version=1.2.2 		
application/x-java-applet;version=1.2.1 		
application/x-java-bean;version=1.2.1 		
application/x-java-applet;version=1.3.1 		
application/x-java-bean;version=1.3.1 		
application/x-java-applet;version=1.4 		
application/x-java-bean;version=1.4 		
application/x-java-applet;version=1.4.1 		
application/x-java-bean;version=1.4.1 		
application/x-java-applet;version=1.4.2 		
application/x-java-bean;version=1.4.2 		
application/x-java-applet;version=1.5 		
application/x-java-bean;version=1.5 		
application/x-java-applet;version=1.6 		
application/x-java-bean;version=1.6 		
application/x-java-applet;jpi-version=1.6.0_23 		
application/x-java-bean;jpi-version=1.6.0_23 		
Java Deployment Toolkit 6.0.230.5

    File: npdeployJava1.dll
    Version: 6.0.230.5
    NPRuntime Script Plug-in Library for Java(TM) Deploy

MIME Type 	Description 	Suffixes
application/java-deployment-toolkit 		
Silverlight Plug-In

    File: npctrl.dll
    Version: 4.0.60129.0
    4.0.60129.0

MIME Type 	Description 	Suffixes
application/x-silverlight 	npctrl 	scr
application/x-silverlight-2 		
Microsoft Office 2010

    File: NPAUTHZ.DLL
    Version: 14.0.4730.1010
    Office Authorization plug-in for NPAPI browsers

MIME Type 	Description 	Suffixes
application/x-msoffice14 	14.0.4730.1010 	*
Microsoft Office 2010

    File: NPSPWRAP.DLL
    Version: 14.0.4761.1000
    The plug-in allows you to open and edit files using Microsoft Office applications

MIME Type 	Description 	Suffixes
application/x-sharepoint 	SharePoint Plug-in for Firefox 	
Microsoft Office Live Plug-in for Firefox

    File: npOLW.dll
    Version: 2.0.3009.0
    Office Live Update v1.4

MIME Type 	Description 	Suffixes
application/OfficeLive 	Office Live Update v1.4 	
Windows Live™ Photo Gallery

    File: NPWLPG.dll
    Version: 15.4.3508.1109
    NPWLPG

MIME Type 	Description 	Suffixes
application/x-wlpg3-detect 	Windows Live™ Photo Gallery 	wlpg
application/x-wlpg-detect 	Windows Live™ Photo Gallery 	wlpg
NVIDIA 3D Vision

    File: npnv3dv.dll
    Version: 7.17.12.5896
    NVIDIA 3D Vision plugin for Mozilla browsers

MIME Type 	Description 	Suffixes
image/jps 	JPEG-based stereo image 	jps
image/pns 	PNG-based stereo image 	pns
image/mpo 	Multi-Picture Format image 	mpo
NVIDIA 3D VISION

    File: npnv3dvstreaming.dll
    Version: 7.17.12.5896
    NVIDIA 3D Vision Streaming plugin for Mozilla browsers

MIME Type 	Description 	Suffixes
application/mozilla-3DV-streaming-plugin 	npnv3dvstreaming 	rts
PalmSource Package Installer

    File: NPInstal.dll
    Version: 1.5.0.4
    Package Installer & Install Conduit

MIME Type 	Description 	Suffixes
application/vnd.palm.psi 	PalmSource Package 	psi
QuickTime Plug-in 7.6.8

    File: npqtplugin4.dll
    Version: 7.6.8.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
video/mpeg 	MPEG media 	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa
audio/mpeg 	MPEG audio 	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a
audio/x-mpeg 	MPEG audio 	mpeg,mpg,m1s,m1a,mp2,mpm,mpa,m2a
video/3gpp 	3GPP media 	3gp,3gpp
QuickTime Plug-in 7.6.9

    File: npqtplugin.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
application/sdp 	SDP stream descriptor 	sdp
application/x-sdp 	SDP stream descriptor 	sdp
application/x-rtsp 	RTSP stream descriptor 	rtsp,rts
video/quicktime 	QuickTime Movie 	mov,qt,mqv
video/flc 	AutoDesk Animator (FLC) 	flc,fli,cel
audio/x-wav 	WAVE audio 	wav,bwf
audio/wav 	WAVE audio 	wav,bwf
QuickTime Plug-in 7.6.9

    File: npqtplugin2.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
audio/aiff 	AIFF audio 	aiff,aif,aifc,cdda
audio/x-aiff 	AIFF audio 	aiff,aif,aifc,cdda
audio/basic 	uLaw/AU audio 	au,snd,ulw
audio/mid 	MIDI 	mid,midi,smf,kar
audio/x-midi 	MIDI 	mid,midi,smf,kar
audio/midi 	MIDI 	mid,midi,smf,kar
audio/vnd.qcelp 	QUALCOMM PureVoice audio 	qcp
QuickTime Plug-in 7.6.9

    File: npqtplugin3.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
audio/x-gsm 	GSM audio 	gsm
audio/AMR 	AMR audio 	AMR
audio/aac 	AAC audio 	aac,adts
audio/x-aac 	AAC audio 	aac,adts
audio/x-caf 	CAF audio 	caf
audio/ac3 	AC3 audio 	ac3
audio/x-ac3 	AC3 audio 	ac3
video/x-mpeg 	MPEG media 	mpeg,mpg,m1s,m1v,m1a,m75,m15,mp2,mpm,mpv,mpa
QuickTime Plug-in 7.6.9

    File: npqtplugin5.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
audio/3gpp 	3GPP media 	3gp,3gpp
video/3gpp2 	3GPP2 media 	3g2,3gp2
audio/3gpp2 	3GPP2 media 	3g2,3gp2
video/sd-video 	SD video 	sdv
application/x-mpeg 	AMC media 	amc
video/mp4 	MPEG-4 media 	mp4
audio/mp4 	MPEG-4 media 	mp4
audio/x-m4a 	AAC audio 	m4a
audio/x-m4p 	AAC audio (protected) 	m4p
audio/x-m4b 	AAC audio book 	m4b
QuickTime Plug-in 7.6.9

    File: npqtplugin6.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
video/x-m4v 	Video (protected) 	m4v
image/x-macpaint 	MacPaint image 	pntg,pnt,mac
image/pict 	PICT image 	pict,pic,pct
image/x-pict 	PICT image 	pict,pic,pct
image/png 	PNG image 	png
image/x-png 	PNG image 	png
image/x-quicktime 	QuickTime image 	qtif,qti
image/x-sgi 	SGI image 	sgi,rgb
image/x-targa 	TGA image 	targa,tga
QuickTime Plug-in 7.6.9

    File: npqtplugin7.dll
    Version: 7.6.9.0
    The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

MIME Type 	Description 	Suffixes
image/jp2 	JPEG2000 image 	jp2
image/jpeg2000 	JPEG2000 image 	jp2
image/jpeg2000-image 	JPEG2000 image 	jp2
image/x-jpeg2000-image 	JPEG2000 image 	jp2

Comment 49

8 years ago
I am affected as well, with Firefox 4 beta 12 under x64 Linux (Ubuntu 10.10). Maybe I should open a new bug ?

Browsing to the « Catalogue » (I am using the French localization) or to https://services.addons.mozilla.org/en-US/firefox/discovery/pane/4.0b12/WINNT causes what has already been described.

Comment 50

8 years ago
In case it's helpful, I have confirmed that this issue happens with both the x86 and x64 builds on Windows 7 x64.
Adam, Al, and Bryan, we have a testday tomorrow for add-ons compatibility and the add-ons manager. It would be great if you could join so we could try to nail down this issue even more. Please see our QMO blog post:

http://quality.mozilla.org/events/2011/02/28/add-ons-compatibility-and-add-ons-manager-testday-march-4th/

Thanks!
Henrik, I should be there.
For those seeing this, what is your screen size and are you running with Firefox maximized?

Comment 54

8 years ago
(In reply to comment #53)
> For those seeing this, what is your screen size and are you running with
> Firefox maximized?

My screen is 1680x1050, I have dual screens. I run Firefox at roughly 75-80% of the screen size. The same issue happens on either screen.
(Reporter)

Comment 55

8 years ago
The the problem persists regardless of resolution (1024x768, 1152x864, 1280x1024, 1680x1050).  The maximized state also doesn't matter.
Quite a few reports on Input as well: http://input.mozilla.com/en-US/beta/search?product=firefox&q=add-ons+script
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Since none of the developers can reproduce this we're pretty much swinging in the dark.  QA:  can you hit this with every combination of browsers+platforms you've got and try to reproduce it?

Comment 58

8 years ago
My screen size is 1920x1200 and I run Firefox maximized.
I've been running the 4B12 full screen at 1920x1200.  The 64-bit nightly I've been running at about 60% of that.

FF 3.16 loads the page fine.  4B1 works.  4B2 is the point where it stops working.

IE9 just runs at 100% and never even times out, but stopping it doesn't crash it like FF4 currently does.

Chrome 9.0.597.107 tells me the script won't finish, and if I stop it, it stops, and if I continue it, it will eventually time out again and I can either again, continue it or stop it.  So it appears that it is indeed cross platform.

So something is certainly funky with the script.

If somebody wants me to try Opera, fine, but I'm not installing Safari, no Apple crud on my system!
(In reply to comment #57)
> Since none of the developers can reproduce this we're pretty much swinging in
> the dark.  QA:  can you hit this with every combination of browsers+platforms
> you've got and try to reproduce it?

If we could put up a version of AMO somewhere where discovery-pane.js wasn't minimized we'd at least be able to get better info about what part of the script was timing out.
We have css and js unminified on preview now. Please test at https://addons.allizom.org/en-US/firefox/discovery/pane/4.0b12/WINNT.
(Reporter)

Comment 62

8 years ago
(In reply to comment #61)
> We have css and js unminified on preview now. Please test at
> https://addons.allizom.org/en-US/firefox/discovery/pane/4.0b12/WINNT.

truncation.js:31

I've also substituted a jsbeautified discovery-min.js with fiddler on the real site and Fx reported the same line there (5796)
(Reporter)

Comment 63

8 years ago
I debugged it, it appears that on the very first invocation the following loop never terminates:

while (!done) {
	$el.html(txt.slice(0,cutoff).join(delim)+truncText);
	wid = (this.scrollHeight - this.offsetHeight);
	if (wid < 2 && chunk == oc) {
		 done = true;
	} else if (wid > 1) {
		 cutoff -= chunk;
	} else {
		 cutoff += chunk;
	}
	oc = chunk;
	chunk = Math.ceil(chunk/2);
}

Updated

8 years ago
Assignee: cwiemeersch → thepotch
Whiteboard: [post-freeze+]
Target Milestone: 6.0.1 → 6.0.0
(Assignee)

Comment 64

8 years ago
http://github.com/jbalogh/zamboni/commit/fa1a82d
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Thanks everyone for your help.  Can the affected people verify it's fixed using the addons.allizom.org domain?  (The rest of the URL can be the same as you were testing above).  Thanks

Comment 66

8 years ago
Perhaps the script changes haven't been posted to the site yet? I am still getting the same error at https://addons.allizom.org/en-US/firefox/discovery/pane/4.0b12/WINNT as of now.
The new JS is there when I look at https://addons-cdn.allizom.org/media/js/zamboni/truncation.js

Can you hard refresh to make sure you're using the new JS?

Comment 68

8 years ago
Hmm, the cache/expiry headers might have been wrong or something - manually clearing the cache and reloading the page seemed to work. The Add-ons manager still freezes, but I suspect that's due to the updated code not being on the live AMO site yet.

Looks good on this end...
(Reporter)

Comment 69

8 years ago
Verified
Status: RESOLVED → VERIFIED
Yep, the uncompressed JS is never supposed to be on the CDN (we turned it on for this bug) so it's going to have the cache headers on it, and no cache busting string.  You'll have to hard-refresh to get it.  Once we turn the compressed JS back on, things will go back to working by default.  That's bug 639110.
https://addons.allizom.org/en-US/firefox/discovery/pane/4.0b12/WINNT

That works for me!  Although I had to turn NoScript on for allizom.org. :-p

All praise Allizom and Potch! :)
(Reporter)

Comment 72

8 years ago
When is the fix going to be deployed?  rc1 is still failing on AMO.
There is a push tomorrow at 4pm.  See http://is.gd/cGud9
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.