Better help text in Windows Integration dialog

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WinXP+, URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
When you start Mozilla for the first time you're presented with a "Windows 
Integration" dialog.

The dialog says:
"Do you want to set up Windows so that it will use this application whenever 
you open the kinds of documents and Internet shortcuts that this application 
can view?"

Perhaps something like this could be added:
"To change these settings later select Edit -> Preferences -> Advanced -> 
Windows Integration after starting Mozilla."

Comment 1

18 years ago
nav triage team:

Yeah, would be nice, but don't think we'll get to it for beta1, marking 
nsbeta1-, reassigning to law
Assignee: vishy → law

Comment 2

18 years ago
In an ideal world we might have a button to open that preferences pane instead 
of forcing the user to remember...

Comment 3

18 years ago
no, really, marking nsbeta1-
Keywords: nsbeta1-

Comment 4

18 years ago
In an ideal world, this would be part of a `Mozilla Setup' utility which was 
launched by the installer, it would not be part of Mozilla itself.

But for now ...
------
Do you want Windows to use {browserName} to display HTML and image files? 
[large UI font]

You can change these settings later in the `Desktop Integration' category of 
Preferences. [small UI font]
------

Comment 5

18 years ago
Ideal worlds don't need installers.  I'd much prefer to be able to specify 
which associations to restore rather than carte blank.  If we need to trigger 
the prefs pane or frame that prefs pane here I don't mind.

mpt's string is at least misleading.

mozilla can capture:
browser protocols, mail protocols, web documents, web images, internal 
protocols, internal file types, and some other stuff. 

If it isn't too hard a collapse widget hiding the relevant prefs panel might be 
more appropriate.  We designed mozilla chrome to be modular, maybe we should 
use that feature.

Comment 6

18 years ago
Ok, if we're talking about protocols as well as file types, then the question 
should be:
------
Do you want {browserName} to be your default browser?
------

Comment 7

18 years ago
And mail client and instant messaging client, and graphic viewer, and web 
editor, and um what else does our suite do?

But yes it's an improvement. Keep those suggestions coming ;-)

Comment 8

18 years ago
There should be separate questions for the browser, and the mail client, and 
the IM client. The question for a component should appear the first time the 
user uses that component.

Asking a single `Do you want Mozilla to take over your life?' question for the 
whole suite is not very useful at all.

Comment 9

18 years ago
*** Bug 64630 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Marking nsbeta1- bugs as future
Target Milestone: --- → Future
(Reporter)

Comment 11

18 years ago
*** Bug 79408 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 81795 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
ugg....this is very confusing now:

http://bugzilla.mozilla.org/showattachment.cgi?attach_id=35301

After 10 minutes, I finnaly think I figured out what it was trying to ask me. 
This comes up all the time for me.

Attempting to nominate nsbeta1 (forgive me if I do this wrong)
Keywords: nsbeta1- → nsbeta1
Target Milestone: Future → ---

Comment 14

18 years ago
*** Bug 81854 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
nav triage team:

nsbeta1+, p3, and mozilla0.9.3, adding jatin@netscape.com to cc list
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla0.9.3
moving Windows Integration [formerly Desktop Integration] bugs to PaulW as qa
contact.
QA Contact: sairuh → paw

Comment 17

18 years ago
*** Bug 72453 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
The dialog should read more like the Navigator 4.7x dialog. How about this:

"Netscape is not registered to handle Internet Shortcuts. Would you like to
register Navigator as your default browswer?"

Comment 19

18 years ago
Correction for Mozilla: 

The dialog should read more like the Navigator 4.7x dialog. How about this:

"Mozilla is not registered to handle Internet Shortcuts. Would you like to
register Mozilla as your default browswer?"


Comment 20

18 years ago
bah. this is foolish.

Mozilla is not your default browser. You can change these settings in the 
Internet control panel.

[x] I like things the way they are.
<Change> <Ignore>

bug 77846 is about better windows interegration.

Comment 21

18 years ago
Duplicate of 63868

Comment 22

18 years ago
nope bug 63868 was filed by the same reporter for a slightly different purpose. 
what is missing is a dependency tree so that people could have found that bug 
...

Comment 23

18 years ago
-> me while bill's gone...
Assignee: law → blake

Updated

18 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 24

18 years ago
usability/polish, 0.9.4.
Status: NEW → ASSIGNED

Comment 25

17 years ago
This hasn't be touched since July, and is not a stop-ship IMHO. Propose we move
it out to a later milestone.

Comment 26

17 years ago
*** Bug 98424 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 27

17 years ago
Actually, this is an important part of Windows XP integration and indirectly
related to XP Start menu integration (Bug 97813, Bug 95724).  We need to make
this clearer for our next release. While I believe separate checkboxes for Nav
and Mail are the best way to go in the long run, the low cost solution we should
try to get for 0.9.5 is a single combined selection, i.e.:

"Would you like to make Netscape your default browswer and email program?

                [Yes]   [No]

 [checkbox] Ask me next time I start Netscape."

Or something like that.  Saying yes should affect the behavior described in the
bugs mentioned above, namely placing Nav and Mail in the default browser and
mail section of the WinXP start menu.

Blake, are you busy with turbo stuff?  Ccing Bill.  Adding nsbranch keyword. 
Whiteboard: nsbranch

Comment 28

17 years ago
Adding Peter Trudelle and myself to the CC list.  Peter, this was discussed in
PDT yesterday and I think it is really needed in light of the XP Start Menu
integration work we're doing.  Not sure if Blake and Law are too busy with turbo
stuff/XP start menu stuff to work on it, could you find someone to work on it if
so?  Thanks. 

Comment 29

17 years ago
->law, since he is back and Blake is now gone.  I think having a single combined
browser/mail prompt would be a disaster, since at least 75% of users would
answer "NO!" (cuz they use some other mail program), whereas presumably a large
percentage would allow the browser to take over as default. Moving nsbranch to
keywords, and plussing, p2 for 0.9.5
Assignee: blakeross → law
Status: ASSIGNED → NEW
Keywords: nsbranch+
Priority: P3 → P2
Whiteboard: nsbranch

Comment 30

17 years ago
taking from bill
Assignee: law → pchen

Comment 31

17 years ago
Sounds like in talking to Bill that the code behind this dialog only sets the
default browser, not the email app.  Since this is the case and we don't have
time in the short run to combine the two effectively, we can simply change the
wording above the buttons to "Would you like to make Netscape your default
browser?" 

Sounds like with implementation of SMAPI, mail will have a similar dialog.  I
will talk to them about that one as well.

Comment 32

17 years ago
Created attachment 50262 [details] [diff] [review]
patch to use brandShortName in windows integration dialog

Comment 33

17 years ago
Ok, so the patch above will insert brandShortName for %S in the
initialPromptText and promptText strings. I've changed initialPromptText to be
"%S is not your default browser. Would you like to make it your default
browser?" I think we should make promptText also short and sweet. Any suggestions?

Comment 34

17 years ago
My suggestion:

"Netscape is not currently set as your default browser.  Would you like to make
it your default browser?"

                [Yes]      [No]      [Cancel]

[checkbox (default selected)]  Ask me next time I start Netscape

Ccing docs (Jatin) for input.
(Assignee)

Comment 35

17 years ago
There's a subtle yet crucial distinction between initialPromptText and
promptText.  The former is asked once per installation (more or less; there
might be exceptions to that) and really asks about "make this your default browser."

The latter is displayed whenever the user's Advanced|System preferences are out
of whack with the Windows registry.  However, if the user has indicated that
they don't want to have the application handle http: protocol Internet
shortcuts, then the question is not at all related to being the system's
"default browser."  For example, it might only be related to being the system's
"default .png viewer."

So we either need to make promptText more generic, or, enhance the code so that
if "isHandlingHTTP" is true, it uses initialPromptText rather than promptText. 
I think that is doable and would be much preferred by people like, say, Todd :-).

Comment 36

17 years ago
PChen/Trudelle - Staus Pls ... we are closing down today.
Whiteboard: WinXP+

Comment 37

17 years ago
The only real issue left is the text for when your the prefs that you have set
in preferences->Advanced->System for file types and protocols have been
overridden in the system (by say IE). The dialog text we use for thatnow :

Windows is not currently set up to match your Windows Integration preferences. 
This means that Windows will not use this application when you open all the
types of documents and Internet shortcuts that you have indicated.  Do you want
to update Windows to match your Windows Integration preferences?

seems a bit long winded and cryptic to "normal" users. I currently have it so
that "this application" will now use brandShortName instead.

I'm looking for better wording that what we have now.

Comment 38

17 years ago
How about this:
Windows is not set up use Netscape to open all the types of documents and
Internet shortcuts you have enabled in Netscape's Windows Integration
preferences.  Do you want to update Windows to match your Netscape settings?

Comment 39

17 years ago
Any L10N impact here (pls check with Paul Chen on new text)?

Todd - U ok with the text here?

Paul - Pls add new strings, and screen shot for michele.
Whiteboard: WinXP+ → WinXP+, PDT

Comment 40

17 years ago
Paul,

I just talked to Peter and Bill about this one and here's our thoughts on what
we should do:

1)  Use "default browser" dialog for initial prompt
2)  Check when opening for changes to http, https (ftp as well? - didn't discuss
this) protocol handlers and html file type only
3)  If changed, give the user the same "default browser" text they saw initially.
4)  Do not prompt the user in instances where other protocol handlers/internet
file types are changed.  This probably means that we should deselect the "Alert
me if other applications change these settings" checkbox on the pref panel by
default.

Bill, Peter, does that sound right?  Paul, Bill said that he thought this wasn't
too hard to do based on his knowledge of the code.  I think this path has less
of a l10n impact as well.   

Comment 41

17 years ago
What about:

You have set up Windows to open some types of documents or Internet shortcuts 
in Mozilla. However, another application has changed these settings. Do you 
want your previous settings to be restored?

Comment 42

17 years ago
Todd: yes, that sounds fine.  Paul: should Bill now have this bug, or can you
handle it?

Comment 43

17 years ago
Any and all UI changes need to be checked into the Branch by tomorrow's build
9/25. After that l10n cannot accept UI changes/additions. thanks

Comment 44

17 years ago
I recommend Todd's suggested wording dated 9/21. It's more in line with what
these "browser check" dialog boxes have looked like previously.

Comment 45

17 years ago
Created attachment 50619 [details] [diff] [review]
updated patch

Comment 46

17 years ago
Created attachment 50620 [details] [diff] [review]
patch to properties file

Comment 47

17 years ago
As per Michelle's comments, really need to get this r= and sr= and checked in
before tomorrow.

Comment 48

17 years ago
r=danm

Comment 49

17 years ago
Well, it's almost 7pm PDT, and I only have an r=danm (thanks, Dan!). I've been
trying to find hyatt (his laptop is still here), but haven't seen him. Also, I
need to get a PDT+. Thinks don't looks too promising.

Comment 51

17 years ago
If this is not a stop ship, and you can't get it checked in today, can you
please do this on the trunk only? We cannot accept any UI changes after today to
the branch. Any UI changes after today will not make it into the localized
products. Putting the localized products at risk. thanks.

Comment 52

17 years ago
PChen - Looks like the reviews are there. Please update Patch Status, and
resolve this ASAP. We need it, we like it ... bring it to the PDT @ noon for
approval.

Updated

17 years ago
Attachment #50619 - Flags: superreview+
Attachment #50619 - Flags: review+

Updated

17 years ago
Attachment #50620 - Flags: superreview+
Attachment #50620 - Flags: review+

Comment 53

17 years ago
check it in - PDT+
Whiteboard: WinXP+, PDT → WinXP+, PDT+

Comment 54

17 years ago
Checked into branch but I don't think we necessarily want this patch on the
trunk. Marking fixed and will open a new bug for trunk
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Verified FIXED using the commercial branch 2001-09-27 build on Windows 2000.
Status: RESOLVED → VERIFIED
I have been looking for the new bug that is supposed to cover the trunk's
behavior, but can't locate it.  Can you point this bug to it please?  Thanks.

Comment 57

17 years ago
Reopening. This bug was filed about the trunk, and it's still not fixed in the
trunk. (At least it wasn't in 0.9.6, months after this bug was marked fixed.)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Can we set the target milestone to mozilla0.9.7 or above ?
(Please have a look at www.MozillaQuest.com . I think its not good for the image
of moz.)

Comment 59

17 years ago
->law, nsbeta1, clear target
Assignee: pchen → law
Status: REOPENED → NEW
Keywords: nsbranch+ → nsbeta1
Whiteboard: WinXP+, PDT+ → WinXP+
Target Milestone: mozilla0.9.5 → ---
(Reporter)

Comment 61

17 years ago
fixed, rite?
(Assignee)

Comment 62

17 years ago
Yes, fixed (albeit in a slightly different fashion).
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
QA Contact: stephend → claudius
(Reporter)

Comment 63

17 years ago
v 20020222
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.