Don't offer Firefox 4 to PPC Mac and Mac OS < 10.5 users

VERIFIED FIXED in Future

Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: alex_mayorga, Assigned: rik)

Tracking

unspecified
Future
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b13pre) Gecko/20110322 Firefox/4.0b13pre
Build Identifier: 

Offering Firefox 4 to OSX 10.4 users would just annoy them, see
https://support.mozilla.com/en-US/questions/795424


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.mozilla.com/en-US/firefox/new/
2. Download Firefox 4.0.dmg
3. Try to install
Actual Results:  
The installer doesn't work.

Expected Results:  
http://www.mozilla.com/en-US/firefox/new/ does a bit of user agent sniffing and doesn't offer Firefox 4 to systems with not supported operating systems.

http://www.mozilla.com/en-US/firefox/4.0/system-requirements/

Comment 1

7 years ago
yeah, let's avoid this. easy fix?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
Adding it to the release queue - thanks!
Target Milestone: --- → 2.0

Comment 3

7 years ago
The bug headline mentions only 10.4 but the scope must be widened: All Mac OS < 10.5 and all systems with PPC must not be offered to upgrade to Fx4.

Comment 4

7 years ago
Changed the name of the bug per comment #3 (good catch). Steven/James/Anthony - this feels important enough to do as a one-off once we get through the mobile release if at all possible. Definitely bad form to be serving up a version to these people that they can't actually use.

My recommended fix:
- display 3.6 button with a small note that reads "Unfortunately Firefox 4 is not compatible with your computer's operating system. _Learn more_."

(the link would point to http://www.mozilla.com/en-US/firefox/4.0/system-requirements/)
Summary: Don't offer Firefox 4 to OSX 10.4 users → Don't offer Firefox 4 to PPC Mac and Mac OS < 10.5 users
Note that these new strings will require localization for all of our locales.

Also, this week end I changed the behaviour of all our localized whatsnew pages shown to our 3.0.x users to show 4.0 as a recommended upgrade if they are on windows/linux and 3.6 if they are one mac so as that we make sure we don't loose existing long term users by proposing a 4.0 version that doesn't work for them (those that do a 3.0 -> 3.6 can be upgraded selectively later with the Major Update upgrade process). It may be good to do the same for en-US.

Updated

7 years ago
Duplicate of this bug: 643783
This needs to be the highest priority thing for mozilla.com IMO. No strings needed, just remove the download button, or redirect to all-older.html.

Comment 8

7 years ago
Dupe of bug 644255?
Severity: normal → critical

Updated

7 years ago
Assignee: nobody → anthony
Severity: critical → normal
(In reply to comment #8)
> Dupe of bug 644255?

Not exactly, that bug is dealing specifically with the promos on the 3.6 whatsnew pages. Lets keep them separate as the technical fix is very different.

Anthony is going to work on this, but it's not a quick fix because of the various download buttons across the site. I'll see if I can help him out at all.

Comment 10

7 years ago
Thanks James and Anthony - really appreciate it. If this is complex enough that it needs to be done in stages, I'd start with the homepage. Fixing there asap will probably cover a lot of the problem and buy us a little time to resolve the rest of it.
done for locales in r86861 on production for mozilla.com, same thing on mozilla-europe.org in r86864

Ideally we would have this fix in product-details so as to propagate it to all sites easily and I guess Thunderbird will eventually have the same problem, so it's more of a temporary emergency fix (especially since I would prefer us to clean up product-details than to add even more stuff in it :) )
(Assignee)

Comment 12

7 years ago
Committed r86874 for a quick fix on the en-US home page.

http://www-trunk.stage.mozilla.com/en-US/firefox/new/
Is there any kind of message displayed to the user?
Keywords: qawanted

Comment 14

7 years ago
(In reply to comment #13)
> Is there any kind of message displayed to the user?

I think we need something explaining what's going on (see comment #4).
New strings mean localization, I intend to put the string in English for now as a short term fix though.

I would prefer a version-free message that we could reuse in the future, the one in comment 4 will become obsolete as soon as Firefox 5 is released.

Comment 16

7 years ago
Pascal, how about this?

Unfortunately the latest version of Firefox isn't compatible with your computer's operating system. _Learn more_."
it's a fine message, I wil use it in English for now and will put it on our localizers' plate, thanks :)
Keywords: qawanted
(Assignee)

Comment 18

7 years ago
Committed r86947 with John's message.
Keywords: qawanted
(Assignee)

Comment 19

7 years ago
Committed r87105 on stage and production.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Keywords: qawanted
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Comment 20

5 years ago
Raymond: We need to verify if this regressed. Here is a comment that we received:

"I just did some testing with a PPC Mac running 10.5.8 (I don't have 10.4):
When I used Safari, all of the Mozilla download buttons let me download 15.0.1 which will not run on that machine.
When I used Fx 3.6.28 I was taken to http://mozilla.org/firefox/update which tells me to update and let's me download 15.0.1. All Mozilla download buttons let me download 15.0.1."

We can check this out after the stub installer work.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 2.0 → Future
I just tested this on a PPC mac. We have indeed regressed this sitewide. The notification we used to display is also no longer there. 

Filed https://bugzilla.mozilla.org/show_bug.cgi?id=797647 to track stuff we need to to to fix this. resolving this so we can work off the new bug
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → FIXED

Comment 22

5 years ago
(In reply to raymond [:retornam] from comment #21)
> Filed https://bugzilla.mozilla.org/show_bug.cgi?id=797647 to track stuff we
> need to to to fix this. resolving this so we can work off the new bug

Bless you for filing a new bug instead of keeping this one re-opened. Marking as VERIFIED since this was initially fixed (and verified) long ago.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.