Closed Bug 649979 Opened 10 years ago Closed 10 years ago

don't switch tab groups when closing last tab

Categories

(Firefox Graveyard :: Panorama, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 633707
Future

People

(Reporter: cvmocanu, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Currently, when closing the last tab of a tab group, another tab group is opened (presumably one that has tabs).

Instead of this behavior, a new tab empty tab should be opened and the tab group should not change.
This makes sense especially if you use tab groups to keep things separate (e.g. per task). In that case, you don't want to continue browsing using a tabs group for a different task without noticing. It would also make it consistent with what happens when closing the last tab in a window (I have "browser.tabs.closeWindowWithLastTab=false").

Also take care that the new tab should be created exactly like when you would press Ctrl+T - see bug 648286 for more info.

Reproducible: Always
This goes against the default browser behavior. Closing all your tabs closes Firefox. Closing all your Panorama tabs should close the tab group. It is up to the devs to decide if they want to handle the additional complexity of supporting the browser.tabs.closeWindowWithLastTab pref.
Indeed, but for me (and I guess others), the default behavior in Firefox (and Chrome for that matter) is extremely inconvenient. If I want to close my window I can do that myself. If I close all my tabs, I simply want to continue browsing with a clean browsing session.

Both me and other like-minded people would be really grateful to the Panorama developers if they supported browser.tabs.closeWindowWithLastTab.
Version: unspecified → 4.0 Branch
I think we should support the browser.tabs.closeWindowWithLastTab pref and its associated behavior.
Blocks: 603789
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Target Milestone: --- → Future
Version: 4.0 Branch → Trunk
No longer blocks: 603789
Depends on: 654311
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633707
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.