Last Comment Bug 650241 - Location returned by accessibles sometimes incorrect when page zoomed
: Location returned by accessibles sometimes incorrect when page zoomed
Status: RESOLVED FIXED
: access, regression
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla13
Assigned To: alexander :surkov
:
Mentors:
Depends on:
Blocks: 659589 659863 528796 727942
  Show dependency treegraph
 
Reported: 2011-04-15 05:59 PDT by James Teh [:Jamie]
Modified: 2012-02-22 16:03 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case. (98 bytes, text/html)
2011-07-07 21:22 PDT, James Teh [:Jamie]
no flags Details
patch (9.88 KB, patch)
2012-02-21 06:20 PST, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review
improve testing (5.08 KB, patch)
2012-02-21 23:23 PST, alexander :surkov
no flags Details | Diff | Splinter Review
improve testing v2 (7.55 KB, patch)
2012-02-22 00:01 PST, alexander :surkov
mzehe: review+
Details | Diff | Splinter Review

Description James Teh [:Jamie] 2011-04-15 05:59:05 PDT
Sometimes, the screen location returned by accessible objects seems to be incorrect.

Str:
1. Open Google Calendar.
2. Open the Create Event page.
3. Press alt+d to move to the Location Bar, then tab a few times until focus lands on the "Mail" link.
4. Press alt+d to move to the location bar, then shift+tab a few times until focus lands on the Discard button.
5. Check the location returned by the focused accessible.
Expected: The location returned should be the location of the button on screen (inside the browser window).
Actual: The location returned is outside the browser window.

I've seen this issue in quite a few other places and it makes routing the mouse to and/or clicking these elements impossible, which is sometimes necessary. It has made some nasty sites literally unusable for me with NVDA. The example above is the easiest and most reliable to reproduce. Unfortunately, I have no idea at all what is causing this, so I haven't been able to come up with a simple, isolated test case.

This works fine in Firefox 3.6.
Comment 1 Marco Zehe (:MarcoZ) on PTO until August 15 2011-05-02 03:08:21 PDT
Jamie, can you re-test this with latest nightlies? We just recently got a bug fix in that fixes a few child/deepest child at certain locations issues.
Comment 2 James Teh [:Jamie] 2011-05-02 23:32:50 PDT
I can still reproduce as described using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110502 Firefox/6.0a1
Comment 3 Marco Zehe (:MarcoZ) on PTO until August 15 2011-05-03 01:05:32 PDT
Thanks, so bug 650235 didn't fix this one.
Comment 4 alexander :surkov 2011-05-25 02:33:49 PDT
Can't reproduce with accprobe on trunk, it shows red rectangle around discard button after I do steps to reproduce. Any idea, how else I can try to see a bug?
Comment 5 Marco Zehe (:MarcoZ) on PTO until August 15 2011-05-25 04:29:08 PDT
Again the question: Is this maybe fixed by bug 656089?
Comment 6 alexander :surkov 2011-05-25 04:32:24 PDT
(In reply to comment #5)
> Again the question: Is this maybe fixed by bug 656089?

I have doubts because bug 656089 is about caret rect, this one is about accessible object rect, they are calculated independently.
Comment 7 James Teh [:Jamie] 2011-07-07 21:22:04 PDT
Created attachment 544724 [details]
Test case.

Okay. Finally figured out what's causing this particular case.

1. Open the attached test case.
2. Press control+0 to reset page zoom.
3. Check the top left of the location reported for the first paragraph accessible.
Result (correct): The point is within the paragraph.
4. Press control+= (control+equals) twice to zoom the page in.
5. Check the top left of the location reported for the first paragraph accessible.
Expected: The point should be the top left of the paragraph.
Actual: The point is in the top part of the browser chrome.
Comment 8 alexander :surkov 2012-02-20 10:46:55 PST
regression from bug 528796, lack of testsuite, again.
Comment 9 alexander :surkov 2012-02-21 06:20:19 PST
Created attachment 599142 [details] [diff] [review]
patch
Comment 10 Marco Zehe (:MarcoZ) on PTO until August 15 2012-02-21 07:06:36 PST
Comment on attachment 599142 [details] [diff] [review]
patch

r=me with just one nit:
>+ * Return the accessible coordinates and size relative the screen.

"relative to the screen"
Comment 12 alexander :surkov 2012-02-21 23:23:45 PST
Created attachment 599495 [details] [diff] [review]
improve testing
Comment 13 alexander :surkov 2012-02-22 00:01:30 PST
Created attachment 599506 [details] [diff] [review]
improve testing v2

updated to trunk
Comment 14 Marco Zehe (:MarcoZ) on PTO until August 15 2012-02-22 02:28:23 PST
Comment on attachment 599506 [details] [diff] [review]
improve testing v2

r=me, veeery nice!
Comment 15 alexander :surkov 2012-02-22 03:24:37 PST
test landed https://hg.mozilla.org/integration/mozilla-inbound/rev/499846502bf3
Comment 16 Ed Morley [:emorley] 2012-02-22 10:32:35 PST
https://hg.mozilla.org/mozilla-central/rev/bde8c5a15988

(Leaving open for test to merge)
Comment 17 Ed Morley [:emorley] 2012-02-22 10:34:25 PST
https://hg.mozilla.org/mozilla-central/rev/715b6b383b4d
Comment 18 Ed Morley [:emorley] 2012-02-22 10:36:52 PST
I'm confused, there was another cset with this bug number (comment 17), but it's not the test.

Reopening; suspect wrong bug number in commit message for one of them - can I leave you to sort please?
Comment 19 alexander :surkov 2012-02-22 10:41:27 PST
(In reply to Ed Morley [:edmorley] from comment #18)
> I'm confused, there was another cset with this bug number (comment 17), but
> it's not the test.
> 
> Reopening; suspect wrong bug number in commit message for one of them - can
> I leave you to sort please?

there are three landings here
1) original patch + mochitest (central)
2) disabled test because mochitest of original patch failed (central)
3) improved test (inbound)

so this changeset was #2 (no patch is attached here).
Comment 20 Ed Morley [:emorley] 2012-02-22 16:03:39 PST
(In reply to alexander :surkov from comment #19)
> (no patch is attached here).

Ah - thank you :-)

https://hg.mozilla.org/mozilla-central/rev/499846502bf3

Note You need to log in before you can comment on or make changes to this bug.