Component Watching does not respect email preferences

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: ComponentWatching
--
enhancement
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jdm, Assigned: glob)

Tracking

(Blocks: 1 bug)

Production
x86
Windows XP
Dependency tree / graph

Details

(Reporter)

Description

6 years ago
I used to have a number of QA contacts in my watchlist, but moved them to be component watches. However, I now get _every_ email for that component, rather than my filtered user watch mails. For example, I turned off receiving mails about the CC field being updated, but now I'm getting them again because there's no granularity for watching components.
(Assignee)

Updated

6 years ago
Assignee: email-notifications → nobody
Severity: normal → enhancement
Component: Email Notifications → Bugzilla: Other b.m.o Issues
Product: Bugzilla → mozilla.org
QA Contact: default-qa → other-bmo-issues
Version: 4.0 → other

Updated

6 years ago
Blocks: 652325

Updated

6 years ago
Duplicate of this bug: 652437

Updated

6 years ago
Duplicate of this bug: 652512

Updated

6 years ago
Blocks: 652419
Summary: Component Watching is not granular → Component Watching does not respect email preferences
(Assignee)

Updated

6 years ago
Component: Bugzilla: Other b.m.o Issues → Component Watching
Product: mozilla.org → bugzilla.mozilla.org
QA Contact: other-bmo-issues → bmo-comp-watch
Version: other → Current
I switched my email watches to component watches, hit this, and had to switch back as well.  Component watching isn't useful to me if I also have to weed out CCs and the like.  For this to work, I think it needs to respect a separate column in the email preferences table for "When my relationship to this bug is:".
(Assignee)

Updated

6 years ago
Assignee: nobody → glob
Status: NEW → ASSIGNED
(Reporter)

Comment 4

6 years ago
Byron, I've been reading the source of User.pm and the component watching extension, and this doesn't look like a trivial fix to me. However, I'd like to propose a temporary workaround that will let me stop being bombarded by CC messages, since I really don't want to have to go through the process of converting my component watches again. From ComponentWatchingExtension.pm:

>192 while (my ($uid) = $sth->fetchrow_array) {
>193   if (!exists $recipients->{$uid}) {
>194     $recipients->{$uid}->{+REL_COMPONENT_WATCHER} = 1;
>195   }
>196 }

Let's change 194 to |$recipients->{$uid}->{+REL_QA} = 1;| which will take us back to the status quo, since that's how we use to fake component watching. Please?
(Assignee)

Comment 5

6 years ago
thanks josh; i have a full fix in hand which i'm currently testing, so this issue should be resolved soon :)
(Assignee)

Comment 6

6 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified Bugzilla/User.pm
modified extensions/ComponentWatching/Extension.pm
added extensions/ComponentWatching/reset-watch-preferences.pl
added extensions/ComponentWatching/template/en/default/hook/account/prefs/email-relationships.html.tmpl
Committed revision 7658.

note to self: after upgrading the server, the extensions/ComponentWatching/reset-watch-preferences.pl script needs to be executed.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Has this actually been deployed yet? (if not, how do I know when?)

I just got cc info for a component I'm watching via this that was sent about 15 mins ago - in my email preferences, I've got "The CC field changes" completely turned off.
(Assignee)

Comment 8

6 years ago
(In reply to comment #7)
> Has this actually been deployed yet?

not yet, sorry.  it's on our staging environment for final testing

> if not, how do I know when?

i'll comment here when it's live.
(Assignee)

Comment 9

6 years ago
(In reply to comment #8)
> i'll comment here when it's live.

it's live.
I don't understand why the "I'm added to or removed from this capacity" box is grayed out for Component -- I do want to get email when a bug is moved into a component that I watch.
(Assignee)

Comment 11

6 years ago
(In reply to comment #10)
> I don't understand why the "I'm added to or removed from this capacity" box
> is grayed out for Component -- I do want to get email when a bug is moved
> into a component that I watch.

that checkbox means "email me when i start watching a component" -- like how the CCed checkbox on the row means "email me when i'm CCed on a bug".

if you're watching a component you should always receive a notification when a bug is moved into that component.
You need to log in before you can comment on or make changes to this bug.