Closed Bug 654043 Opened 9 years ago Closed 9 years ago

increase size of selection boxes for Status, Resolution and Severity on advanced search query form

Categories

(bugzilla.mozilla.org :: General, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: wsmwk, Assigned: glob)

References

Details

(Keywords: regression)

currently, size 7 is specified for all boxes.  This is too small to prevent unnecessary scrolling  for Status, Resolution and Severity.  the size should be increased so that so that no scrolling is needed to select any choice in these frequently used boxes.

This is a regression from a change a couple years ago, though I don't recall if it had a bug. (it might have gotten communicated via IRC at the time) Nor do I recall whether the change was made in bugzilla prduct or locally for BMO. 


xref [Bug 654042] New: bugzilla query advanced search selection boxes are too wide, and can be narrower so they all fit on one row
Summary: increase size of selection boxes for Status, Resolution and Severity → increase size of selection boxes for Status, Resolution and Severity on advanced search query form
There are 7 statuses and 7 severities - if there's scrolling (which there seems to be a tiny bit of on my Firefox 4) isn't that a user agent bug?

There are 9 resolutions, so this is a valid request for the Resolution box.

The number 7 is hard-coded into search/field.html.tmpl, so would need to be changed there - or a bit of custom JS added to resize the field (which would avoid us needing to change the Bugzilla templates themselves).

Gerv
the height is actually controlled by css:

.search_field_grid select {
  height: 15ex;
}

22ex is probably a better size of all the selects.
Assignee: nobody → glob
Well, that's not great, because at least on my machine it leads to a totally unnecessary scrollbar to allow you to scroll 3 pixels. Why can't we let the user agent automatically lay them out based on the "size" parameter? If they all had the same size param, they'd all be the same height.

IOW, what if we just remove that rule? Testing, removing it has barely any effect apart from removing the pointless scrollbars.

We could fix the resolution one by using CSS, perhaps.

Gerv
yeah, removing the fixed height css rule is a better solution, so we can at least make the 'size' attribute work as expected.

with that in place, bumping up the size from 7 to 9 for almost all search fields is trivial, and looks nice.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified template/en/default/search/field.html.tmpl
Committed revision 7653.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Depends on: 654921
That's better, but I think 9 goes to far and 7 will do what's needed.  7 displays all the selection items where I multiselect.  (resolution has 9 selects, but no one picks EXPIRED or MOVED so 9 is not needed there)
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.