Figure out a keyboard shortcut for Get all new message on the mac

RESOLVED FIXED in Thunderbird 9.0

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Usul, Assigned: Usul)

Tracking

Trunk
Thunderbird 9.0
x86
macOS

Thunderbird Tracking Flags

(thunderbird8-)

Details

Attachments

(1 attachment, 5 obsolete attachments)

Assignee

Description

8 years ago
And avoid using Functions keys. This is a fallout of bug Bug 527467
I think it was not mentioned in bug 527467, but if you are using a macbook, then by default the function keys are mapped to the alternate function (I guess you could say "fn"-lock). This makes F5 the key for "decrease keyboard backlight brightness" and requires fn+F5 to be pressed to get a real F5. In Firefox users will probably use Cmd+R, but this is obviously taken.

Updated

8 years ago
Duplicate of this bug: 668615
I would like to point out that the shift-command-t shortcut has been around
since 1999... Users are _used_ to it, even if it's not perfect and in
particular on a Mac. I would also like to remind you that a lot of users
change the behaviour of their function keys on Mac through the OS X
preferences. I did it myself on all my macs. So basing "Get all messages" on
function keys to get rid of one of the three keys in "shift-cmd-t" will
in reality make the new shortcut a three-keys-based shortcut...

My suggestion is "don't touch shift-cmd-t", that is far too implanted in
users' habits even if I agree it's not optimal. This is the kind of changes
you just can't change like that or you'll make zillions of users angry.

SUGGESTION: revert to shift-cmd-t as soon as possible since there is not
shortcut visible for "Get all my msgs" in recent Earlybird builds.
Yeah, that's not going to happen.  Cmd-Shift-T is the "re-open last tab" key in all the other apps I use on the Mac, and there's no way Thunderbird will pick a different key for that feature.

Also, this bug is for finding a different keyboard shortcut for getting all new messages, not for advocating for reverting to a shortcut we're using for something else.

Thanks,
Blake.
Why not shift+cmd+G? Not far from the old one in terms of keyboard layout, "G" stands for "Get messages", it seems to be available and I like it far more than the new shortcut on Windows (shift+fn5, keys are too far from each other).

Comment 6

8 years ago
a) Please bring back CMD-T – at least as an option!
b) WHY is there no hint of F5 next to the menu entry like in any other menu of any other app?
c) WHY can’t I use a custom keybinding, provided by the MacOS X system preferences?

Bummer: Setting up a shortcut to Thunderbirds menu entry
> Get New Messages for › Mail 
as CMD-T in
> System Preferences › Keyboard › Application Shortcut › Thunderbird › 'Mail' = CMD-T 
does not work. It shows the shortcut CMD-T next to the menu entry, but does not trigger the action.
a) That's unlikely to happen, but I'ld love it if someone submitted a more generic "Change keybindings" patch…

b) F-keys don't seem to show up in the menu entries on Mac.  Perhaps because people don't use them that much?

c) I have no idea.  I would _love_ it if that worked, so if you can find out how to get that working, _please_ let me know!  (Can you set up shortcuts for Firefox?  If so, perhaps the same things would work for Thunderbird.  If not, you'll likely find more people who want to help you get those working…)

Thanks,
Blake.

Comment 8

8 years ago
Oliver,

The Story Of Thunderbird:

(1) Break UI, for no reason at all, for absolutely no gain.
(2) Mark complains from users WONTFIX.  If they're still unhappy, suggest they write and promote and distribute an addon, or add an dependency on an unrelated XUL issue that's been open since 2002.
(3) Repeat.


The moral:
Never ever EVER click "Yes" on the "An update is available do you wish to install it?" dialog.
That's something I really need for my future, I don't want to die w/o
knowing : what's the use case for "re-open last tab" in A MAIL USER AGENT ?!?

In Fx, I can understand, your web page has a context, a history, a state.
In Tb, that's almost pointless:

- unsent composed messages are never closed w/o a prompt
- folder views are reachable in one click and always preserve last selection
- message views are reachable in one click

Oh, ok, then if you open a msg in a tab and close it unwillingly, you want
to reopen it ? And FOR THAT, you're ready to break 12 years of users' habits?

Wow, to say the least.
Assignee

Comment 10

8 years ago
C) Is due to bug 429824 .

Cmd-shift-G ain't used in lightning (https://wiki.mozilla.org/Calendar:Lightning_keyboard_shortcuts ) so we woudln't get the issue we had when we used cmd-shift-d.

Comment 11

8 years ago
Straight from the MacOS X help:

Using global keyboard shortcuts

You can use keyboard shortcuts to quickly perform tasks on your computer by pressing keys on your keyboard. You can disable or change many of the computer’s “global” keyboard shortcuts, which are shortcuts that work the same in most applications (for example, taking a picture of the screen by pressing Command-Shift-3).

Changing or disabling a shortcut may be useful if, for example, one of the global shortcuts is used by a specific application for a different purpose. In this case, you can either disable the shortcut that you do not need, or assign it a different key combination.

NOTE:You can create keyboard shortcuts only for existing menu commands. You cannot define keyboard shortcuts for general purpose tasks such as opening an application or switching between applications.

To change global keyboard shortcuts:
1. Choose Apple menu > System Preferences, and then click Keyboard.
2. Click Keyboard Shortcuts.
3. Select the action in the Description list that you want to change.
4. Double-click the characters in the Shortcut column, and press the new key combination that you want to use. You cannot use each type of key (for example, a letter key) more than once in a key combination.
5. Quit and restart any applications you’re using for the new keyboard shortcut to take effect.

To disable a shortcut, deselect the checkbox next to its description in the list.

If you want to return all the shortcuts to their original key combinations, click Restore Defaults.

Updated

8 years ago
Duplicate of this bug: 669614
Assignee

Updated

8 years ago
Duplicate of this bug: 669882

Comment 14

8 years ago
I don't much care what it is but a short cut for Get Messages (this folder) and ideally also one for Get Messages (all folders) is essential.  I'd suggest one be a shift of the other, so if it could be M, ShiftM, or M, Shift+M, or T, Shift+T, or T, Shift+T and so on.
Assignee

Updated

8 years ago
Duplicate of this bug: 670616

Comment 16

8 years ago
(In reply to comment #7) -- re custom keystroke binding on Mac ...
<snip>
> 
> c) I have no idea.  I would _love_ it if that worked, so if you can find out
> how to get that working, _please_ let me know!  (Can you set up shortcuts
> for Firefox?  If so, perhaps the same things would work for Thunderbird.  If
> not, you'll likely find more people who want to help you get those working…)

Custom keystrokes have been broken on Firefox ever since version 3. 
 
And in both applications there are numerous instances of the same exact string (e.g., File/New/Message and Go/Next/Message) being used in various submenus. For custom keystrokes to work well on Mac the strings used for menu and submenu names would each have to be unique (e.g., File/New/New Message and Go/Next/Next Message
 
I also dearly wish that custom keystrokes worked in Mozilla products on Mac but I'm not holding my breath for the menus to be renamed, never mind the bug to be fixed that breaks functionality even on uniquely named menu items.

Comment 17

8 years ago
This is still not fixed in beta 6.02
It's true.  We're still waiting for someone to submit a patch.

I'm not a fan of single-key shortcuts, so something with the Command () key would be preferred.

Cmd-T/Cmd-Shift-T are being used for tabs, so they're out.
Cmd-M is used for minimizing, so that's not a great choice.

Cmd-G/Cmd-Shift-G seems available, and reasonably mnemonic…

Thanks,
Blake.
(In reply to comment #18)
> Cmd-G/Cmd-Shift-G seems available, and reasonably mnemonic…

That's Find Next/Previous.

Based on <http://support.mozillamessaging.com/en-US/kb/Keyboard-shortcuts>, it looks like Cmd-[Shift]-H is available? Cmd-[Shift]-D (for "Download") would be available if not for Lightning.

What do other Mac programs do for this? Maybe we should just try to follow suit with them, though it would probably involve some changes to other key combos.

Comment 20

8 years ago
a) The shortcut should be doable with ONE HAND.

`F5` (on my MBP: fn+F5) is inconvenient, because it’s hard to trigger with one hand.

b) Please fix the incompatibility with the MacOS X ›Global keyboard shortcuts‹ system. With this system one can assign any shortcut to any menu entry of any application themselfes!

Description & screenshots:
http://support.apple.com/kb/HT2490#l4

c) Is there an internal text configuration file in TB where the keyboard shortcuts are defined? So that I can patch the F5 to CMD-T (I don’t use tabs) myself.
Argh, Find Next/Previous.  I knew I was forgetting something.

Cmd-H appears to be "Hide".

Mail.app uses Cmd-Shift-N for "Get All New Messages", and apparently nothing for "Get New Messages for this account"…


Oliver:

a) I disagree that shortcuts should be reachable with one hand, and your use of caps makes me less likely to agree with you.  F5 _is_ inconvenient, which is why we're trying to find a better key in this bug.

b) There is already a bug for that, thus your comments here are out of place, and redundant (since you posted them above).  Please find the appropriate bug before commenting next time.

c) No, the keys are scattered around XUL files which are packed into the application.


Thank you,
Blake.
Shif-cmd-T is hardly reachable with one hand. That is doable, but hey
it's not the most convenient shortcut ever for one hand.

So I guess we don't really mind, but a shortcut should come back as soon
as possible.

Another strategy would be to allow OS X Preferences > Keyboard > Application
Shortcuts to work...

Updated

8 years ago
Duplicate of this bug: 674518

Comment 24

8 years ago
first, before i eviscerate the mozilla team for taking away my Cmd-Shift-T ...

my attempt at useful suggestions:
Cmd-Shift-M to Get Messages for Current Account
Cmd-Shift-A to Get Messages for All Accounts

these are generally unbound elsewhere, and since Cmd-A is "Select All", Cmd-Shift-A is not very likely to become bound to something similar soon, and since Cmd-M is "Minimize", Cmd-Shift-M is similarly not likely to become bound to something soon.

that said ...

Cmd-T and Cmd-Shift-T are BRAINLESS operations at this point.  even though i now know from several weeks of experience that they do not work, my fingers still perform them regularly every time i am in thunderbird.

i would gladly use the System Preferences -> Keyboard Shortcuts solution and more than gladly override the extremely useless "re-open last closed tab" since i don't give a flying XXX about tabs in thunderbird and never use them ... but of course, that's also broken in mozilla and has been for ages (Bug 429824).

i would prefer to Vote up getting Cmd-Shift-T back for get all messages, even if we lose Cmd-T to new Tab.
(In reply to comment #24)
> since Cmd-A is "Select All",
> Cmd-Shift-A is not very likely to become bound to something similar soon,

Select Thread.

> since Cmd-M is "Minimize", Cmd-Shift-M is similarly not likely to become
> bound to something soon.

New Message.

Good try, though.  :(

Later,
Blake.

Comment 26

8 years ago
(In reply to comment #25)
> (In reply to comment #24)
> > since Cmd-A is "Select All",
> > Cmd-Shift-A is not very likely to become bound to something similar soon,
> 
> Select Thread.

kill it.  select thread?  why does that need a key-binding over "get all messages"?!?  don't you have to get all messages before you can select the thread in any of your messages?

> > since Cmd-M is "Minimize", Cmd-Shift-M is similarly not likely to become
> > bound to something soon.
> 
> New Message.

Cmd-N is new message.  why does New Message need 2 bindings?!?


anyway ... why don't we just go back to Cmd-Shift-T like it was for ages?!?
Do _you_ have any data on how many people use either of those shortcuts?

(It's been my experience that people get quite irate when you change a shortcut, so I'ld like to avoid that until I can tell how many people I'll be pissing off.)

Fortunately, we'll be getting Test Pilot working soon (I hope), and then we can find the least-used keys and menu items, and clear out some of the dead weight.

And I've said before why Cmd-Shift-T is out of the running.

Later,
Blake.
(In reply to comment #27)

> Do _you_ have any data on how many people use either of those shortcuts?

Metrics are good but metrics will never say how people feel when an app
changes a 12 years old behaviour. Even if only 5% of Tb users use cmd-shift-T,
they probably heavily rely on it like myself, because it's far easier to
use the keyboard shortcut than to use the mouse.  Again, this shortcut
has remained the same for the last 12 years and switching to another shortcut
does have an impact on users. I don't even think cmd-shift-T, my fingers find
themselves the shortcut on the keyboard...

In the meantime, Earlybird still has no shortcut for that and that's _really_
painful. Please, please, pick up a cmd-something shortcut and do it. I do not
recommend *at all* F5 or other function keys because of laptops. A lot of
people activate the OS X pref inverting the shifted/unshifted behaviour of
function keys...

Comment 29

8 years ago
(In reply to comment #27)
> (It's been my experience that people get quite irate when you change a
> shortcut, so I'ld like to avoid that until I can tell how many people I'll
> be **** off.)

your experience in this regard must have come from changing command-shift-t to be something else.

if this is the reason for not overriding established shortcuts, then it should make sense to you to switch back Command-Shift-T for the reason of not wanting to **** off long-standing Thunderbird users.

> And I've said before why Cmd-Shift-T is out of the running.

from your comments before, what you said before is "monkey see, monkey do".  and that is never a good reason in and of itself for doing something.

and even if it is a good idea and copied by many other _browsers_ on the mac doesn't mean that it even begins to be a good idea for a _mailreader_ .

Cmd-Shift-T should be back in the running until a more compelling argument can be made for throwing away a 12-year-old functionality that many people have so ingrained they don't even think about any more for a functionality that is of a lesser use in a mail-reader than it is in the browsers which it copies.
I'm with all the folks saying "changing a long provided shortcut is a way to severely annoy people. I am, indeed, severely annoyed. 

The F5 option is very bad:
 - In order to press F5, I have to hold down the (left hand) fn key while simultaneously striking the (left hand) function/lower-intensity F5 key. To do that for all accounts, I have to <strong>also</strong> hold down the shift key. This requires removing both my hands from home keys. I'd actually be better off using the scratch pad to click on 'Get Mail' and I <strong>hate</strong> using the scratch pad/mouse.
 - I've trained my synapses to use Command-Shift-T to the point where I'm not even conscious of the finger movement. I can probably kill that motor response in the next 6 weeks or so, but I really should have no reason to need to do that.
 - Even if I didn't have to hold the damned function key, I have never ever used the function keys while just using the keyboard, so my fingers have no idea where they are. 
Bottom line: F5 sucks very powerfully as a shortcut for any mail option.

The Command-T option works excellently well for me. But I can see that it is an impossible battle to get it back, despite that the arguments for keeping it are 100% persuasive and the arguments for changing it are, well, from my perspective, lame. So I'll just add another tally mark to the count of reasons to use some other email tool. There aren't very many, yet, but they seem to never go away...

I'm also very much in agreement with the people who would like to see Thunderbird bless an in-house way to modify and create shortcut key maps. Is there any hope?
I'm sorry to hear that you're annoyed, and I agree that F5 is a terrible option for many of the reasons you listed, as well as because very few Mac programs use Function keys.

Can you think of any suggestions other than Command-T for getting new messages?

I would also love to see the ability to modify shortcuts, but the Thunderbird team doesn't have the resources to develop it ourselves, and so we'll have to wait for Firefox (well, Gecko) to provide the feature for us.  (Bug 57805 is tracking the current amount of hope.)
> Can you think of any suggestions other than Command-T for getting new messages?
Thanks for your quick response.

I do wonder if I'm the right person to do this research. (I'm a Mac user, but pretty restricted to doing the small set of things I do). Still, using this information: http://guides.macrumors.com/Keyboard_shortcuts and testing against my own three most commonly used apps (not counting vi, bash or emacs):

Command-2 and Command-Shift-2: Mac-only, Command-digit is used only in the Finder (and there, command-2 puts it into list mode, which is also not entirely different than getting the next bunch (list?) of emails. Firefox does use Command-2 to go to the second open tab. Safari uses it to go to (some bookmark: I neither use Safari nor understand it). LibreOffice makes the current line into a Heading-2 format. Mnemonic: shift-2 is the @ in an email address.

Note: Except for mnemonic, Command-Digit for any digit in 7,8,9,0 would be easier to reach using two hands. (I'm a left-command user). Command-0 conflicts with Zoom-normal but the others appear to be ok. Less easy, but also ok: 3,4,5,6. 1 conflicts with go to Mail and Newsgroups Window.

Command-D and Command-Shift-D appear to have no major problems. Cmd-D "duplicates" in the finder, and does something with bookmarks in Firefox and Safari. LibreOffice Underlines the selection. Mnemonic: None.

Command-J and Command-Shift-J: Minor conflict (in my opinion of course! ) with current Command-J: Show Saved Files. Firefox uses it to open the downloads window, a reasonably near match to 'download' your email. Maybe. LibreOffice uses the Shift one to maximize the window, which is not apparently standard behavior. Mnemonic: None

Command-K and Command-Shift-K would be easy to strike, have no current conflict in Thunderbird. Safari uses the second to block pop-up windows, while Firefox uses the first to initiate a web search... not too far from 'search' for your email, I suppose. Mnemonic: None

Command-Y, Command-Shift-Y seem to be good candidates. No conflict that I can see (some "quick look" things, maybe). Mnemonic: Y_es I want my email. 

Of these, I like 'J' and 'K' best (easy to reach), followed by 'Y', '7', '8', '9', '2', '3', '4' then 'D', '5', '6'. Much as I like 'J', I would probably have to vote against hijacking existing functionality to meet my own needs.
Assignee

Comment 33

8 years ago
So we briefly had cmd-D and the shift from cmd-sfit-T was quite easy. Unfortunately cmd-D is used in lightning and we decided not to break lighting.

Comment 34

8 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #33)
> So we briefly had cmd-D and the shift from cmd-sfit-T was quite easy.
> Unfortunately cmd-D is used in lightning and we decided not to break
> lighting.

and instead of breaking lightning, you break the experience of those who have been using Thunderbird for 12 years, and who, despite months of effort, are still trying the old Cmd-T/Cmd-Shift-T.  brilliant.

Cmd-D/Cmd-Shift-D is what Mail.app uses.

break ligntning.  i don't even know what lightning is.

Comment 35

8 years ago
and would everyone who detests this bug vote it up, please?  that's what your votes are for.
(In reply to johndoe from comment #34)

> and instead of breaking lightning, you break the experience of those who
> have been using Thunderbird for 12 years, and who, despite months of effort,
> are still trying the old Cmd-T/Cmd-Shift-T.  brilliant.
> 
> Cmd-D/Cmd-Shift-D is what Mail.app uses.
> 
> break ligntning.  i don't even know what lightning is.

I agree 100000% with the above.
Lightning is by far our most-used add-on, so breaking it would be a bad idea.

(In reply to Frank Griswold [:griswolf] [:fgriswold] from comment #32)
> I do wonder if I'm the right person to do this research.

Well, you've done the research where most of the other people commenting didn't, so I think you're a great person to do it.  :)


> Command-2 and Command-Shift-2: Mac-only, Command-digit is used only in the
> Finder (and there, command-2 puts it into list mode

Yeah, Command-2 is kinda weird.

> Command-D and Command-Shift-D appear to have no major problems.  Mnemonic: None.

Conflicts with Lightning, but "Download messages" would have been a good mnemonic.

Command-K is the global search, and Command-Shift-K is the quick filter (which will be merged into the global search sometime in the future).

> Command-Y, Command-Shift-Y seem to be good candidates. No conflict that I
> can see (some "quick look" things, maybe). Mnemonic: Y_es I want my email. 

I also don't see any conflicts with this.  Unless someone comes up with a good reason we can't use this, I'm prepared to bless Command-Y/Command-Shift-Y as the official new key to get messages.

Thank you very much, Frank!
(In reply to johndoe from comment #34)
> Cmd-D/Cmd-Shift-D is what Mail.app uses.

Mail.app uses Shift-Cmd-D to send email.
It uses Shift-Cmd-N to check for all new mail.

> break ligntning.  i don't even know what lightning is.

Lightning is a calendering plugin for Thunderbird.

This bug was for me the final straw to stop using Thunderbird after years of putting up with its quirks.

Comment 39

8 years ago
(In reply to Jeroen van der Ham from comment #38)
> (In reply to johndoe from comment #34)
> > Cmd-D/Cmd-Shift-D is what Mail.app uses.
> 
> Mail.app uses Shift-Cmd-D to send email.
> It uses Shift-Cmd-N to check for all new mail.
> 

my mistake, you are right.  i had gotten so used to Cmd-T/Cmd-Shift-T in thunderbird that i had changed the key-bindings for get mail/get all mail in Mail.app to Cmd-T/Cmd-Shift-T .

now Cmd-T/Cmd-Shift-T works there, but not as it has for 12 years in thunderbird and it's pre-cursors.

bring back Cmd-T/Cmd-Shift-T in thunderbird to do what they've always done, and help people using Tabs in thunderbird learn Cmd-Y/Cmd-Shift-Y for that.

Comment 40

8 years ago
After all this discussion, which I've been loosely following all this time, I must ask:

What, exactly, is Command-T supposed to do in Thunderbird? In Firefox it opens a new tab. In Thunderbird it does not.

 In Thunderbird help at http://support.mozillamessaging.com/en-US/kb/keyboard-shortcuts we are told:

Close window or tab	Command + W
Redo close window or tab	Command + T

First of all, what does it mean to "redo close window or tab"?

Second of all, if I open numerous tabs in my copy of Thunderbird, press Cmd-W to close a tab, then press Cmd-T to "redo close window or tab", NOTHING HAPPENS.

I'm really confused now as to what Cmd-T does (or is supposed to do) that is a valuable enough functionality to have taken the combo away from Get Messages. Can anyone explain in what way Cmd-T has conformed Thunderbird behavior to Firefox behavior? Thanks.

Comment 41

8 years ago
Re #40 I am using 6.0.2. and, yes, I have also tested Cmd-T in Safe Mode.
Assignee

Comment 42

8 years ago
Posted patch Cmd-Y cmd-Shift-Y (obsolete) — Splinter Review
Ain't sure if I also need to tweak /mail/locales/en-US/chrome/messenger/messenger.dtd to add the Y and only for OSX.  XUL's not really something I'm completely familiar with. This patch is untested and written while jetlagged. I'll happily update tweak and correct it until it lands (my target for that is *this* week).
Assignee: nobody → ludovic
Status: NEW → ASSIGNED
Attachment #559855 - Flags: review?(bwinton)
Comment on attachment 559855 [details] [diff] [review]
Cmd-Y cmd-Shift-Y

Review of attachment 559855 [details] [diff] [review]:
-----------------------------------------------------------------

"Ain't sure if I also need to tweak /mail/locales/en-US/chrome/messenger/messenger.dtd to add the Y"

Yes, that seems like the right thing to do.

I'll say "r-" cause you're a newbie, but the changes I've asked for are pretty small, so I expect the next version will be just fine.

Thanks,
Blake.

::: mail/base/content/mailWindowOverlay.xul
@@ -435,0 +435,6 @@
> > +#ifdef XP_MACOSX
> > +  <key id="key_getNewMessages" keycode="Y"
> > +       oncommand="goDoCommand('cmd_getNewMessages');"/>
> > +  <key id="key_getAllNewMessages" keycode="Y" modifiers="shift"
NaN more ...

I don't think we should prevent F5 from working on Mac.  It's probable that no-one will use it, but it reloads in Firefox, and would be nice for people coming from Windows.
Attachment #559855 - Flags: review?(bwinton) → review-
Assignee

Comment 44

8 years ago
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #43)
> Comment on attachment 559855 [details] [diff] [review]
> Cmd-Y cmd-Shift-Y
> 
> Review of attachment 559855 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> "Ain't sure if I also need to tweak
> /mail/locales/en-US/chrome/messenger/messenger.dtd to add the Y"
> 
> Yes, that seems like the right thing to do.

Standard8 said that wasn't necessary
Assignee

Comment 45

8 years ago
Posted patch Making F5 still work (obsolete) — Splinter Review
Attachment #559855 - Attachment is obsolete: true
Attachment #559999 - Flags: review?(bwinton)
Comment on attachment 559999 [details] [diff] [review]
Making F5 still work

Review of attachment 559999 [details] [diff] [review]:
-----------------------------------------------------------------

Now I'm glad I asked for another review.  ;)

(All the things below were the stuff we chatted about in person.)

Thanks,
Blake.

::: mail/base/content/mailWindowOverlay.xul
@@ -432,3 +432,5 @@
> >    <key id="key_print" key="&printCmd.key;"                           oncommand="goDoCommand('cmd_print')" modifiers="accel"/>
> >    <key id="key_saveAsFile" key="&saveAsFileCmd.key;"                 oncommand="goDoCommand('cmd_saveAsFile')" modifiers="accel"/>
> >    <key id="key_viewPageSource" key="&pageSourceCmd.key;"             oncommand="goDoCommand('cmd_viewPageSource')" modifiers="accel"/>
> > +#ifdef XP_MACOSX
> > +  <key id="key_getNewMessages" keycode="Y"

This should be 'key="&getNewMessagesCmd.key;"' instead.

@@ -433,2 +433,5 @@
> >    <key id="key_saveAsFile" key="&saveAsFileCmd.key;"                 oncommand="goDoCommand('cmd_saveAsFile')" modifiers="accel"/>
> >    <key id="key_viewPageSource" key="&pageSourceCmd.key;"             oncommand="goDoCommand('cmd_viewPageSource')" modifiers="accel"/>
> > +#ifdef XP_MACOSX
> > +  <key id="key_getNewMessages" keycode="Y"
> > +       oncommand="goDoCommand('cmd_getNewMessages');"/>

We need to add 'modifiers="accel, shift"' to the keys, since we want it to be Cmd-Y, not just Y.

@@ -439,0 +444,6 @@
> > +#else
> > +  <key id="key_getNewMessages" keycode="VK_F5"
> > +       oncommand="goDoCommand('cmd_getNewMessages');"/>
> > +  <key id="key_getAllNewMessages" keycode="VK_F5" modifiers="shift"
NaN more ...

Since this is the same as the previous block, we should just move the #endif up, and have this be constant.
Attachment #559999 - Flags: review?(bwinton) → review-
Assignee

Comment 47

8 years ago
Attachment #559999 - Attachment is obsolete: true
Attachment #560055 - Flags: review?(bwinton)
Assignee

Comment 48

8 years ago
Posted patch adding the space (obsolete) — Splinter Review
Attachment #560055 - Attachment is obsolete: true
Attachment #560055 - Flags: review?(bwinton)
Attachment #560069 - Flags: review?(bwinton)
Comment on attachment 560069 [details] [diff] [review]
adding the space

Review of attachment 560069 [details] [diff] [review]:
-----------------------------------------------------------------

Turns out you can't have two elements with the same id in an XML file, so we need to make the Mac-specific ones something like "key_getAllNewMessagesMac", otherwise we get the modifiers from one of the elements and the key from the other.

Thanks,
Blake.
Attachment #560069 - Flags: review?(bwinton) → review-
Assignee

Comment 50

8 years ago
Posted patch corrected pacth (obsolete) — Splinter Review
Thanks for helping make the patch thru to review blake.
Attachment #560069 - Attachment is obsolete: true
Attachment #560133 - Flags: review?(bwinton)
Assignee

Comment 51

8 years ago
Attachment #560133 - Attachment is obsolete: true
Attachment #560133 - Flags: review?(bwinton)
Attachment #560190 - Flags: review?(bwinton)
Comment on attachment 560190 [details] [diff] [review]
Probably the good version

Review of attachment 560190 [details] [diff] [review]:
-----------------------------------------------------------------

Well, it took far longer than I thought it would, but I like this patch.  r=me, and ui-r=me, cause I'm a nice guy.  ;)

Thanks,
Blake.
Attachment #560190 - Flags: ui-review+
Attachment #560190 - Flags: review?(bwinton)
Attachment #560190 - Flags: review+
Assignee

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/f8b905d34cd4
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Assignee

Updated

8 years ago
This requires string changes, and hence can't ship for 8.

Comment 55

8 years ago
This is now working for me with shortcut
Y for get messages for selected mailbox folder
Shift Y for all folders
You need to log in before you can comment on or make changes to this bug.