Last Comment Bug 66015 - WMP: Windows Media Player broken on NT and 95 only
: WMP: Windows Media Player broken on NT and 95 only
Status: VERIFIED FIXED
[Need Impact] [Liveconnect:GetJavaEnv...
: helpwanted
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows NT
: P3 major with 2 votes (vote)
: mozilla1.2alpha
Assigned To: av (gone)
: shrirang khanzode
: Benjamin Smedberg [:bsmedberg]
Mentors:
http://msnbc.com/m/lv/default.asp?0cv...
: 39208 97448 148483 (view as bug list)
Depends on: 73856
Blocks: 104166
  Show dependency treegraph
 
Reported: 2001-01-19 13:35 PST by shrirang khanzode
Modified: 2003-03-18 18:36 PST (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
npdsplay.dll (356.00 KB, text/html)
2001-01-23 12:55 PST, shrirang khanzode
no flags Details
simplifed testcase (...of Britney Spears) (1.17 KB, text/html)
2001-01-26 16:28 PST, Peter Lubczynski
no flags Details
Windows Media Player Plugin DLL (try #2) (356.00 KB, application/octet-stream)
2001-01-26 16:30 PST, Peter Lubczynski
no flags Details
plugins.zip (225.91 KB, application/octet-stream)
2001-03-11 17:53 PST, Peter Lubczynski
no flags Details
patch to ns4xPlugin.cpp to "beep" when LiveConnect tries to be used (880 bytes, patch)
2001-03-11 19:03 PST, Peter Lubczynski
no flags Details | Diff | Splinter Review
CCNonWin2K (64.75 KB, image/jpeg)
2001-08-02 10:36 PDT, Susie Wyshak
no flags Details
Associated class files for WMP7 plugin (3.40 KB, application/zip)
2002-05-29 18:10 PDT, Colin Snover
no flags Details
WMP7.1 plugin on Windows 2000 Professional (inoperative) (99.36 KB, image/png)
2002-06-03 15:06 PDT, Colin Snover
no flags Details
2 Dr. Watson log files, zipped, generated when WMP6.4 crashes Moz1.0RC3 (37.97 KB, application/x-zip-compressed)
2002-06-03 15:58 PDT, earthsound
no flags Details
screenshot #1 of "new behavior" using wmp7.1/Win98SE (47.75 KB, image/jpeg)
2002-06-19 09:03 PDT, Jan M
no flags Details
screenshot #2 (27.17 KB, image/jpeg)
2002-06-19 09:04 PDT, Jan M
no flags Details
nsmp2inf.cab manually downloaded (6.67 KB, application/x-zip-compressed)
2002-06-19 09:06 PDT, Jan M
no flags Details
the nsmp2inf.inf from samenamed cabfile above (23.93 KB, text/plain)
2002-06-19 09:09 PDT, Jan M
no flags Details

Description shrirang khanzode 2001-01-19 13:35:44 PST
Plugin : windows media player 6.4
seen on 0119 trunk 

Windows media player works as a seperate application but does not launch when 
embedded in a webpage.
steps:

1 Go to the above url
2 Click on any movie (100k)
3 Observe that a javascript window opens up but no media player appears in the 
page.
Comment 1 Peter Lubczynski 2001-01-23 12:08:13 PST
I think this happens in 4.x too. Where are the plugin DLL's to copy to our 
plugins folder?

Shrir, have you been able to get this to work in Nav 4?

Comment 2 shrirang khanzode 2001-01-23 12:53:52 PST
Yes, works in 4.72 fine for me. Attaching the npdsplay.dll to copy to your 
plugins folder....
Comment 3 shrirang khanzode 2001-01-23 12:55:47 PST
Created attachment 23279 [details]
npdsplay.dll
Comment 4 Peter Lubczynski 2001-01-26 16:28:42 PST
Created attachment 23592 [details]
simplifed testcase (...of Britney Spears)
Comment 5 Peter Lubczynski 2001-01-26 16:30:22 PST
Created attachment 23593 [details]
Windows Media Player Plugin DLL (try #2)
Comment 6 Peter Lubczynski 2001-01-26 16:35:17 PST
The first attached DLL (#23279) didn't work at all for me. I think something was 
wrong with the MIME type so I attached the one on my system (#23593).

From the testcase I've attached, I can see that the plugin is trying to go back 
one page by asking for the url: javascript:history.back(). Some other weird 
stuff is going on as well. 
Comment 7 Joseph Elwell 2001-02-04 00:10:18 PST
nominating nsbeta1. This makes us less usable as a multimedia platform.
Comment 8 shrirang khanzode 2001-02-06 14:01:29 PST
seen on mac too, OS :all
Comment 9 Peter Lubczynski 2001-02-08 08:52:05 PST
*** Bug 39208 has been marked as a duplicate of this bug. ***
Comment 10 Joseph Elwell 2001-02-21 18:19:14 PST
marking as dogfood, this meets the new interpretation of dogfood.
Also ressummarizing, as it doesn't really matter that the window is opened via
javascript. Windows Media Player just doesn't work in Mozilla. tested using
win2000 build 2001022105.
Comment 11 Peter Lubczynski 2001-02-28 14:39:38 PST
This could be a LiveConnect.
Comment 12 Peter Lubczynski 2001-03-01 15:43:30 PST
This is not a LiveConnect issue (at last not totally) because my testcase works 
in 4.x if Java and Javascript (effectivly LiveConnect) are turned off. 
Comment 13 Peter Lubczynski 2001-03-11 17:53:11 PST
Created attachment 27421 [details]
plugins.zip
Comment 14 Peter Lubczynski 2001-03-11 19:03:47 PST
Created attachment 27428 [details] [diff] [review]
patch to ns4xPlugin.cpp to "beep" when LiveConnect tries to be used
Comment 15 Peter Lubczynski 2001-03-11 19:06:38 PST
The patch below is a good test if a 4x plugin tries to use LiveConnect and is 
failing. 

If there is interest, perhaps they should be ASSERTS and checked-in?
Comment 16 Peter Lubczynski 2001-03-23 12:03:15 PST
This is a LiveConnect issue for sure. The Spy Plugin show a call to GetJavaEnv
() as one of it's first calls. 
Comment 17 av (gone) 2001-03-28 17:05:11 PST
I don't think this is right dependency. What 73856 is about will require 
rewriting the plugin itself. So this will not help with the existing media 
player.
Comment 18 Peter Lubczynski 2001-03-28 17:13:41 PST
I don't think Microsoft will want to re-write the plugin. I agree.
Comment 19 selmer (gone) 2001-04-06 08:14:09 PDT
converting from dogfood to catfood+.  Now that bug 73856 is fixed, what's the
next step?
Comment 20 Peter Lubczynski 2001-04-06 13:52:57 PDT
Arun,

What's the deal with the Windows Media Player?
Comment 21 Arun Ranganathan 2001-04-25 09:39:20 PDT
I'm going to try and find contacts at Microsoft to talk to.  Any leads would be
greatly appreciated!  
Comment 22 Joseph Elwell 2001-04-25 09:55:22 PDT
http://www.microsoft.com/windows/windowsmedia/en/support/default.asp
There is a listserv as well as other contact info on the above site. Hopefully
this will help.
Comment 23 Peter Lubczynski 2001-04-25 10:36:59 PDT
Shrirang, this bug is set to "All" but has the Windows Media Player been tested 
on the Mac?
Comment 24 shrirang khanzode 2001-04-25 11:19:36 PDT
20010419 mac build recognizes and loads the windows media player 7.0 and plays 
the test url above. I will do more testing on that soon. Changing bug to windows 
only.
Comment 25 Arun Ranganathan 2001-04-30 15:52:26 PDT
cc'ing todd pringle.
todd: what we have here is a situation where we'd like these folks to rewrite
their plugin to make it work (w.r.t scriptability) in the new xpcom world.  can
you give me a contact to write to there?  i can send them av's latest write up
on scriptability.
Comment 26 Hixie (not reading bugmail) 2001-07-22 08:08:18 PDT
I went to:
   http://bugzilla.mozilla.org/showattachment.cgi?attach_id=23592
...which redirected me to a plugin installation page. I followed the 
instructions on that page to install a Netscape plugin. I restarted my browser,
and then went to:
   http://bugzilla.mozilla.org/showattachment.cgi?attach_id=23592
...again. Streaming video (of Britney Spears) appeared.

This seems to now be RESOLVED WORKSFORME. Marking as such. Please reopen if
I did something wrong in the steps above which would not have triggered the bug.
Comment 27 shrirang khanzode 2001-07-27 14:01:29 PDT
reopening..did not work for me on windows.
Comment 28 av (gone) 2001-07-27 16:50:21 PDT
Shrirang, could you specify? The latest versions they have are different for
NT40 and other Windows releases. Which one doesn't work for you?
Comment 29 shrirang khanzode 2001-07-27 16:51:56 PDT
i think they only have 6.4 for NT which does not work at all on my box.
Comment 30 Peter Lubczynski 2001-07-27 17:23:43 PDT
Update from Arun K. R. logged in as peterl (we're at a conference).  Windows
Media Player works as a helper application. Can a quick workaround be to have
MSNBC detect our user-agent, and then invoke their media player as a helper
app.?  if so, it bypasses ugly plugin issues.  This requires high level contacts
at Microsoft; chrisn, can you give it a shot?
Comment 31 Peter Lubczynski 2001-07-27 18:09:20 PDT
Nominating WORKSFORME....

Could someone better explain this bug or problem which caused this to be
reopened because the above test URL:
http://msnbc.com/m/lv/default.asp?0cv=c642

...works great for me using npdsplay.dll (3.0.2.627) on W2K (SP2) with BuildID:
20010726 commercial NS6.1 bits.
Comment 32 av (gone) 2001-07-27 19:35:47 PDT
Maybe it works for because for w2k you have the newer version 7.1 while it is 
not available for NT40, the latest there is 6.4. Your url doesn't play for me on 
NT40.
Comment 33 Peter Lubczynski 2001-07-27 20:20:30 PDT
Ahh...so maybe it is a version problem just on NT 4. I just tired the test URL
on a Windows XP machine, and it played and worked for me fine. This is a valid
bug for NT 4, but I don't think so on Windows XP or Windows 2000. Can anyone
confirm my results?
Comment 34 Arun Ranganathan 2001-07-28 12:53:09 PDT
This appears to be a WinNT4.0 *ONLY* bug.  I just tested on Win98.  In fact, I
went to the website, obtained the plugin by clicking on the 
'plugin not found" link, went to microsoft's website, and downloaded Windows
Media Player 7.1.  Here's the *astounding* thing.  It appears that Media Player
7.1 has an installer that recognizes N6.1 -- could Microsoft know about bug
77244 ? :-) More to follow.
Comment 35 Susie Wyshak 2001-08-02 10:36:42 PDT
Created attachment 44407 [details]
CCNonWin2K
Comment 36 Susie Wyshak 2001-08-02 10:37:46 PDT
I experience this bug using Win2000 Version 5 using CNN's site
http://www.cnn.com/video/popup/section_framesets/audio.frameset.exclude.html
Screenshot attached.
Comment 37 Ilgaz Öcal 2001-08-08 09:10:45 PDT
I am not a windows media preferrer but I found another page.

Go to http://www.broadcast.com (Yahoo one), it will test the plugins, dispay
versions greatly and correct.

When test finishes, broadcast popup window (they made kind of a browser via
javascript) opens. I was also happy to see wmedia player there (I saw the
plugin, it allocated its space perfectly) than NS 6.1 Final told me "This plugin
generated errors" than crashed

Since Yahoo Broadcast is a major site I wanted to note this quick.

Win2k pro here with wmedia 7.1 (netscape plugin installed)


PS: Reported to Yahoo too
Comment 38 shrirang khanzode 2001-08-09 10:33:48 PDT
Susie Wyshak 2001-08-02 10:37 -------

Susie, pls download the latest ..ie 7.1 version on 98 or 2000. The link you 
mentioned and also the video links on this page work great on 98...win 2k.Thx!
Comment 39 shrirang khanzode 2001-08-09 10:36:33 PDT
Arun, I downloaded the media player with 6.1 candidate build..but the installer 
did not put the plugin in my 6.x plugins folder..hmm. I had to manually copy it 
from 4.x
Comment 40 shrirang khanzode 2001-08-09 10:58:01 PDT
Arun:
the video links here give the error message of 6.x not being supported:

http://msnbc.com/m/v/video_news.asp?0cv=c641

Comment 41 Benoit 2001-08-13 09:34:36 PDT
This happens with Windows 95 too. Windows Media Player isn't available in any
version higher than 6.1 for this operating system. The installer for WMP 6.1
(Win95/NT4) installs the plugin in the 4.x directory only.

I've tried to copy the npdsplay.dll to my mozilla directory (0.9.3), the WMP
plugin is then listed in "about:plugins" but :
- On the testcase
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=23592, I get the
window, the box containing the video resizes and then the browser goes back TWO
pages back in his history.
- When I try the url at msnbc, the window opens but i don't see anything where
the video is supposed to be. 
Comment 42 av (gone) 2001-08-27 17:27:49 PDT
Arun, this is your call. We all know what is going on.
Comment 43 shrirang khanzode 2001-08-29 16:01:34 PDT
*** Bug 97448 has been marked as a duplicate of this bug. ***
Comment 44 Arun Ranganathan 2001-09-05 11:10:49 PDT
Here are questions/comments:

1. I know that the Yahoo folks are using the scriptability of plugins such as
WMP, and therefore, since WMP is NOT scriptable owing to architecture dependent
on LiveConnect, it doesn't work.  MSNBC also use the scriptability of plugins,
and thus it won't work there, but yet they have *other* pages which do not
script the plugin.  These pages work fine.  I'm sure MSNBC can be accomodating .  

2. The Player 7.1 installer *should* install to N6.1 correctly.  Shrirang, was
this NOT the case?  I tested on Win98 and found that installation was correct. 
What did you test on?  Note that if you tested on WinNT or Win95, you would not
find this to be the case.

3. Has anyone else reproduced the crash noticed by Ilgaz Ocal on O8/08/01 above?
 If so, this crash could be a 4xp crash and should be logged separately.
Comment 45 shrirang khanzode 2001-09-07 09:15:05 PDT
Update: 

Just tried the 7.1 media player installer on a win 98.
Arun, the installer *does* install in 6.1 after a machine restart.

The testcase, www.broadcast.com and other links in this bug work fine. I do not 
see a crash. However, the links on this page(as mentioned earlier) 

http://msnbc.com/m/v/video_news.asp?0cv=c641

do not work. 'Browser not supported' error is seen. 

All those who have mentioned their issues in this bug, pls retry with 7.1 media 
player and a recent build. 

www.broadcast.com does not crash anymore. The Media helper correctly 
detects the players on my system and lists them.However, trying to change 
preference to realplayer does not work and media player launches even when I had 
selected realplayer...I am filing a new bug for that.

So ,what do we do with this bug? fxd, wfm ?
Comment 46 Arun Ranganathan 2001-09-07 13:06:40 PDT
shrir, could you test on Win2k as Ilgaz Ocal suggests above using Windows Media
Player 7.1?  We're looking for a crash and some tangible "machine data" of a crash.
Comment 47 shrirang khanzode 2001-09-10 12:51:17 PDT
tested on win 2k with  7.1 media player. i could not repro the crash on 
broadcast.com...
Comment 48 David Walker 2001-09-12 15:58:19 PDT
Hi, I'm an occasional reader of these pages and would like to point out that 
there was some version number-related confusion in this bug commentary. 

Benlu's 8/13 post pointed out that "The installer for WMP 6.1 (Win95/NT4) 
installs the plugin in the 4.x directory only."

Arun then apparently miscontrues this on 9/5 and asks a question, to which 
shirang points out on 9/7 (correctly) that the 7.1 media player installs 
correctly on Win 98 into the Moz 6.1 directory.  This is true but unfortunately 
irrelevant; the Moz 6.1 directory is not the WMP 6.1 player. 

The next-to-last post asks for retests with WMP 7.1 (not available for Win95 or 
WinNT 4.0).  Still not addressed is the fact that WMP 6.1, the most recent 
available for Windows NT 4.0 and Win95, doesn't install into the right Mozilla 
folder.  Retesting with WMP 7.1 won't help this.  NT 4.0 users can use WMP 6.4, 
I think, but Win95 users are stuck with WMP 6.1.

Thanks, hope this helps. 
Comment 49 grega 2001-09-17 11:31:45 PDT
marking nsenterprise-.
Comment 50 Martin Poirier 2001-10-14 12:05:08 PDT
I used Media player 6.4 on Win95 in the past and worked fine ... at least on Win95B.
Comment 51 Asa Dotzler [:asa] 2001-12-03 11:19:04 PST
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Comment 52 Peter Lubczynski 2001-12-03 11:36:23 PST
-->Future
Comment 53 Leonardo Morelli 2002-02-06 05:12:32 PST
mmmkay

trying here on XP Pro, mozilla 0.9.8

media player plugin does not work at all. Just shows a black screen where it
should appear.

tried with asf and avi.

unzipped manually the files from wmpplugin.exe (microsoft page) to plugins dir,
and tried the dll posted here as well (same file??). Plugin is listed on
help:about plugins, but shows only a black screen.

oh, and on yahoo streamer, it lists as media player 6.4 (XP has the 8.0 or XP
version)... but I think that is to be expected.
Comment 54 Peter Lubczynski 2002-02-06 10:48:46 PST
WFM on Windows XP Pro on the trunk (did not try 0.9.8) viewing videos on CNN.com
with Windows Media Player 8.0.

Copied np*.dll from c:\Program Files\Windows Media Player

Can you post a testcase with detailed steps to reproduce the problem?
Comment 55 Leonardo Morelli 2002-02-06 13:38:14 PST
okay Peter, that works.

shouldn't Mozilla, when installing, find these files and copy them, or maybe
microsoft perhaps be more friendly and just make a plugin installer for that?
...cause when you go to the media player download page, they say "well buddy,
you have windows XP, so you don't need to download anything"

anyway, that's a design decision perhaps

sorry about the false alarm
Comment 56 R.K.Aa. 2002-03-11 17:15:20 PST
the patch in bug 127259 fixes MP 6.4 plugin on Linux, at least
(used to load "blanks" till i applied it on a cvs build)
Comment 57 Jan M 2002-04-08 08:28:43 PDT
for me the msnbc url works, using media player 7.1 on Win98SE and 0.9.9+ (todays
latest)
but the testcase (with britney spears does not work!

and there is also no chance in watching the videos at www.vision.t-online.de to
(the streamig videos that are emmbeded) And i don#t mean that content to pay
for... try the music videos or try the cinema trailers 
the site and the trailers are in german language, so this should be reworked by
someone who is capable of it...
Comment 58 Colin Snover 2002-05-29 18:10:22 PDT
Created attachment 85516 [details]
Associated class files for WMP7 plugin

Plugin does not work on Windows 2000 [build 2195]. Plugin buildspace appears,
along with Windows Media Player logo (where video would display) and controls,
but controls are inoperative and nothing plays (also, no status). Have tried
several different configurations (and levels of extraction of the associated
WMP plugin files NPDS.ZIP and NPDRMV2.ZIP) but to no avail.

VERSIONS:
Windows: 5.00.2195 [Windows 2000 Service Pack 2]
Windows Media Player: 7.01.00.3055
Plugin: NPDSPLAY.DLL - 3.0.2.627
  NPDRMV2.DLL - 7.1.0.3055
Mozilla: 2002052306 [release 1.0RC3 - Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.0rc3) Gecko/20020523]

There are also several Java (CLASS) files that are included with the Microsoft
plugin. I'm creating an attachment with decompiled versions (oops,
reverse-engineering M$ products, bad me). Perhaps they'll shed some light on
the problem.

Tested and reproducible: sputnik7.com

Some testcases can be related to bug <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=137856">137856</a> [eg.
musicvideos.com] in which there is no forwarding at a blank pop-up (which uses
a clunky Javascript command that [sh,w]ould redirect the window to a page that
says "Upgrade your browser").

Also (separate bug?) when opening an ASX/ASF file from a link, player program
opens and Mozilla window bugs -- it displays what was last on the screen (can
someone describe this better, please?). [eg. <a
href="http://web.servicebureau.net/conf/meta?i=1112246260&c=2343&m=was&u=/w.xsl&date_ticker=7/10/2001_ARMhttp://web.servicebureau.net/conf/meta?i=1112246260&c=2343&m=was&u=/w.xsl&date_ticker=7/10/2001_ARM">this
test</a>]
Comment 59 earthsound 2002-05-31 21:22:50 PDT
Windows 98, Mozilla 1.0RC3 Build ID 2002052306, media player v6.4 crashes
Mozilla when embedded and pressing either the play or stop button while page is
loading. See bug 148483 http://bugzilla.mozilla.org/show_bug.cgi?id=148483
Comment 60 Julius Schwartzenberg 2002-06-01 08:47:52 PDT
This site gives some info about why the older plugin doesn't work with  
Mozilla/Netscape: 
  
http://www.nwlink.com/~zachd/pss/pss.html  
Comment 61 Michael Hendy (Hendikins) 2002-06-03 08:35:16 PDT
Does the 7.1 Plugin work on Win95/NT4 if the instructions at
http://plugindoc.mozdev.org/WMP7_Win95_NT4.html for installing WMP7.1 on the
older OSes are followed, and the 7.1 Plugin is installed?
Comment 62 shrirang khanzode 2002-06-03 10:04:03 PDT
*** Bug 148483 has been marked as a duplicate of this bug. ***
Comment 63 earthsound 2002-06-03 14:04:22 PDT
Shouldn't crash & WMP 6.4 be added to the summary & "NT and 95 only" be removed,
since bug 148483 was marked a dup of this? Also, it's not so much an NT/95 issue
as it is a WMP 6.4 issue. As per my initial report in bug 148483 & bug 148483,
comment #2, this bug not only crashes MozRC3, but Netscape 4.79, as well. It is
seems to be related to the fact that Mozilla is not backwards compatible with
LiveConnect-supporting scriptable plug-ins, but given that 4.79 will crash, I'm
not 100% positive...
Comment 64 Colin Snover 2002-06-03 15:06:03 PDT
Created attachment 86117 [details]
WMP7.1 plugin on Windows 2000 Professional (inoperative)

This is NOT just a 6.4 problem, and this is NOT just a Windows 95/NT problem,
as this screenshot clearly shows.
Comment 65 earthsound 2002-06-03 15:58:51 PDT
Created attachment 86131 [details]
2 Dr. Watson log files, zipped, generated when WMP6.4 crashes Moz1.0RC3
Comment 66 earthsound 2002-06-03 16:02:37 PDT
Win98, Moz1.0RC3, WMP6.4:
Fwiw & to answer comment #46, see Talkback IDs TB6877649G, TB6878029Q,
TB6882296M, TB6883071E & TB6883731Z

In addition to the TB IDs, I have attached (attachment 86131 [details]) a zip file
containing 2 Dr. Watson log files. One was generated when Mozilla crashed b/c of
pressing the play button on the embedded WMP & it listed an unknown module
causing the crash. The 2nd log was generated after Mozilla was crashed when
pressing the stop button on the embedded WMP & it indicated:

"Windows Media Player 2 ActiveX Control attempted to read from memory that does
not exist.  It may be using an uninitialized variable, or it may be attempting
to access memory after having freed it.

Module Name: MSDXM.OCX
Description: Windows Media Player 2 ActiveX Control
Version: 6.4.07.1112
Product: DirectShow
Manufacturer: Microsoft Corporation"

Please see the section titled "*----> Details <----*" in each log file. There
you will find stack trace, etc...

For more info, steps to repro, etc., see bug 148483
Comment 67 Tony Tovar 2002-06-12 16:31:03 PDT
I'm having problems with build 2002-6-11 (WinNT), Media Player 6.4 (plus the
WM308567 security patch) and the npdsplay.dll and npwmsdrm.dll files copied to
Mozilla.

I get a hung browser whenever I click on a "Windows Media" link at:
www.cdnow.com/cgi-bin/mserver/pagename=/RP/CDN/FIND/album.html/ArtistID=ROSARIO/ITEMID=1463151
If I click the Back button, the window recovers.  Is this the same problem
y'all're talking about?

Also, when Media Player appears, it doesn't start playing automatically; if I
manually click the Play button, the song sample plays ok.
Comment 68 Jan M 2002-06-19 08:53:37 PDT
still testcase with britney does NOT work on Win98SE using WMP7.1 I copied all
np*.* files to mozillas pluginfolder.
By the way the behavior now changed: mozilla trys to download and install a
plugin, but if i click "Get the plug-in" a new window opens and remains blank.
if someone doubts: I'll create and attach a screenshot.
However, I downloaded that cabfile manually, unpacked it with WinAce and what i
found was an inf file (I will attach it, too.)
Comment 69 Jan M 2002-06-19 09:03:11 PDT
Created attachment 88307 [details]
screenshot #1 of "new behavior" using wmp7.1/Win98SE

so here i go...
i need to say that this i new to 1.1 alpha release /trunk
until 1.0 the testcase did not work (but showing an wmp6.4alike window that
didn't show the movie but, on right click, it had an option to tell you
something about an error.)
Comment 70 Jan M 2002-06-19 09:04:22 PDT
Created attachment 88308 [details]
screenshot #2
Comment 71 Jan M 2002-06-19 09:06:33 PDT
Created attachment 88309 [details]
nsmp2inf.cab manually downloaded
Comment 72 Jan M 2002-06-19 09:09:13 PDT
Created attachment 88310 [details]
the nsmp2inf.inf from samenamed cabfile above 

Does anyone now something to do with it, to me it looks like it was made for
IE4
Comment 73 Johnny Stenback (:jst, jst@mozilla.com) 2002-06-19 09:22:22 PDT
Sounds like this isn't quite resolved yet for everybody. Is there more that
needs to be done here? Nominating for RTM to get some traction on this one.
Comment 74 Jan M 2002-06-21 03:57:40 PDT
i think my bug(at least the new one) is not that on that this was in the
begining, i think bug 151772 could be the right place to track it (?)
Comment 75 James Adams 2002-06-21 04:02:27 PDT
WinXP Professional with Media Player 8.0 and Mozilla 1.0 - worked fine.  After
upgrading to 1.1, stopped working.  Verified np*.dll files were in plugin directory.

Downgraded to 1.0 and Media Player plugin worked.
Comment 76 Jan M 2002-06-21 04:20:01 PDT
thats right this bug (asking about the x-oleobject plugin) is new and only on
the 1.1 trunk , but i was unable to utilize embeded wmp on win98SE  with wmp7.1,
too.
do i still have the wrong plugins or is this only working on WinXP with 1.0?
Comment 77 rubydoo123 2002-06-21 15:02:04 PDT
moving to 1.2 alpha
Comment 78 scottputterman 2002-06-23 20:03:36 PDT
adt1.0.1- per ADT.
Comment 79 steven midyette 2002-06-30 11:36:53 PDT
Bug also appears on a win ME system (id 2002053012)
Comment 80 Jan M 2002-07-04 10:06:24 PDT
MS does not support Win95 anymore and Win NT in VERY VERY VERY few cases (and
not in this case!!) so isn't this a won't fix.
-As anything else discribed here is not this, but another bug.
Comment 81 Brian 'netdragon' Bober 2002-07-04 21:42:23 PDT
No,IMHO, because we shouldn't exclude users from Mozilla just because Microsoft 
considers they systems obsolete. If DOS weren't completely dead, then it would 
be cool to drag Mozilla onto DJGPP. Then you could have a Mozilla boot CD to 
run it on a computer with no operating system. ;-)
Comment 82 Jan M 2002-07-05 04:37:23 PDT
users on win95 and winnt will still be able to use mozilla
but the plugins will not be updated for wmp6.4!(As there is a a newer wmp for
the other versions of Windows.)



-------this is not bug related and should be discussed elsewhere!--------
and: yes running on dos would be cool, but dos is an operating system (the full
name is "Dirty Operating System!)
you can run mozilla from cd anyway, if you use linux(there are distros that run
from cd) 
Comment 83 rubydoo123 2002-07-09 14:45:47 PDT
based on plug-in team triage, this is a wfm - Shrir can you please verify that
this is truly fixed
Comment 84 Colin Snover 2002-07-30 23:43:19 PDT
Confirming WORKSFORME - Windows 2000, 2002072918, WMP7.1 (with IE6 update).
Did not work previously.

Two things may have resolved this:
1) work from Mozilla team
2) the Windows Media Player update that comes with IE6
Comment 85 Matt Seitz 2002-07-31 11:58:30 PDT
Confirming wfm, NT 4, WMP 6.4 with Netscape Plugin, Mozilla build 2002073008 (1.1b+)
Comment 86 shrirang khanzode 2002-07-31 12:09:45 PDT
absolutely, Verified.
Comment 87 Keyser Sose 2002-09-05 19:44:29 PDT
Reopening..Lets straighten this out.

1) 7.1 or greater (seems to be with the latest security patches) does work if
you copies files into your plugins directory as directed to by plugindoc.mozdev.org

2) 6.4 still does *not* work what ever version. The reason this is still
important is because 95 and NT do *not* have an upgrade to 7.1

3) when putting the npdsplay.dll npwmsdrm.dll file into the plugins directory
the file starts to load then suddenly it returns you the previous page.
Comment 88 rubydoo123 2002-09-06 11:37:48 PDT
I am reclosing this bug, please do not reopen this bug, rather open a new bug
for new issues.

Reopening..Lets straighten this out.

1) 7.1 or greater (seems to be with the latest security patches) does work if
you copies files into your plugins directory as directed to by plugindoc.mozdev.org

>> right, this is an issue with the WMP plug-in. If the vendor developer
(Mircosoft) determines that they are not supporting a platform, then that is
their decision alone. We cannot override that decision, nor should we.

2) 6.4 still does *not* work what ever version. The reason this is still
important is because 95 and NT do *not* have an upgrade to 7.1
>> in the current released versions, version 6.4 does work in regard to the
original reported issue.

3) when putting the npdsplay.dll npwmsdrm.dll file into the plugins directory
the file starts to load then suddenly it returns you the previous page.
>> if this is the case, then you would need to open a new bug, include a test
case and provide the plug-in data and tested build data (current versions of the
browser, older versions of the browser will not be modified).
Comment 89 shrirang khanzode 2002-09-10 15:34:14 PDT
.
Comment 90 kdekorte 2003-02-18 08:24:10 PST
The Plugin api function NPN_GetURL does not handle urls of the form: mms://

Note You need to log in before you can comment on or make changes to this bug.