Closed Bug 660992 Opened 8 years ago Closed 3 years ago

Command+? (Command+Shift+/) should open OS X Leopard's new Help Menu Search

Categories

(Thunderbird :: OS Integration, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: haridara, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/534.30 (KHTML, like Gecko) Chrome/12.0.742.68 Safari/534.30
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110414 Lightning/1.0b2 Thunderbird/3.1.10

This is like the bug 417720 for Firefox, except that it happens for Thunderbird as well and I can't find an issue that tracks this. As of Firefox 4.0, this is no longer an issue, but Thunderbird continues to have the issue. 

Reproducible: Always

Steps to Reproduce:
1. Hit Command+? (Command+Shift+/ in English keyboard)


Actual Results:  
Help page opens

Expected Results:  
Move focus to the search box in the Help menu.

Note that clicking the Help menu item with mouse works as expected, so only the keyboard shortcut has the issue.

With every other application working as expected, it is a huge inconvenience to not be able to make use of this functionality in Thunderbird and causes broken workflow. Also note that OS X allows you to type in the partial name of a menu option and select it, sort of like how Vim allows you to complete menu's for the :emenu command, so what we are loosing is not just the ability to get online help.
So I gave this a quick try and :

Firefox, Colloguy, Skype and Thunderbird behave the same way they open a support/help page on that shortcut because they don't come with help articles in the system's help application.

Other apps preview terminal etc .. will open apple's help application.

http://developer.apple.com/library/mac/#documentation/userexperience/conceptual/applehiguidelines/XHIGKeyboardShortcuts/XHIGKeyboardShortcuts.html says :
Open the application's help in Help Viewer.

We don't have that but we do open our help forums.

Based on that I'd say there :
1) is no bug
2) we should wontfix this bug.
See Also: → 714036
wontfix per comment 1
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.