Closed Bug 663370 Opened 9 years ago Closed Last year

Advice links in Web Console error messages can't be followed [earlier also couldn't be copied separately)

Categories

(DevTools :: Console, enhancement, P2)

enhancement

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aleksej, Unassigned)

References

Details

(Whiteboard: [fx6][testday-20110610][bugday-20140108])

Web Console has an error message:

---
An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing @ <URL>
---

The link to developer.mozilla.org can be neither followed, nor copied directly.
You can only type it down, or copy the whole message and remove stuff on the left and on the right side. The page URL can be long, and the error message itself is not very short, so that is not very convenient.

There should probably be a way to follow the link, or to copy the link without the rest of the message.
Bug 638949 requests a facility to copy the link without the extra baggage. We can use this bug to track the feature of providing a click handler for all log messages that opens a hyperlink, if present in the message.
Whiteboard: [testday-20110610] → [fx6][testday-20110610]
Version: 5 Branch → Trunk
Speculatively tracking-firefox-6+ on this because it looks like a regression as a result of firefox-6-specific changes - we need to understand pretty quickly whether this is trivially fixable, or whether we should back out the change that caused it.

Rob,Panos,Kevin  - can we get some analysis here?
This is not a regression, just a request for enhancement. The Web Console displays all messages as text since Firefox 4, this is why jbalogh filed bug 638949 some time ago with a similar enhancement request.
triage. Filter on PINKISBEAUTIFUL
Component: Developer Tools → Developer Tools: Console
Priority: -- → P2
Duplicate of this bug: 935477
Blocks: 944048
Request for changing this issue to 
"Links in console messages can't be followed"

All links in a log item should automatically be converted to a hyperlink. At least the http(s)//: ones.
Just as the links in this comment.

Eg. test this in Chrome devtools: 

console.log("This links to: https://bugzilla.mozilla.org/show_bug.cgi?id=663370 and can be clicked");

Notice that you can click the BugZilla link in the console's output.

Now that the console output is html this should be easier to do.

See also https://bugzilla.mozilla.org/show_bug.cgi?id=843004
Summary: Advice links in Web Console error messages can't be followed or copied separately → Advice links in Web Console error messages can't be followed [earlier also couldn't be copied separately)
Whiteboard: [fx6][testday-20110610] → [fx6][testday-20110610][testday-20140108]
Whiteboard: [fx6][testday-20110610][testday-20140108] → [fx6][testday-20110610][bugday-20140108]
Duplicate of this bug: 969788
Product: Firefox → DevTools
As far as I know, this work has been done a few years ago already, and we do linkify URLs now.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.