Open Bug 667357 Opened 10 years ago Updated 2 years ago

Add an item in preferences window to allow user to decide to prevent autoplay for video/audio content

Categories

(Firefox :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

()

People

(Reporter: anti-stress, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110624 Firefox/7.0a1

Bug 478982 created a pref (media.autoplay.enabled) to prevent autoplay for video/audio content.

But this is not discoverable from a user point of view, whereas video element can be very disturbing for users (in a similarr way that popup windows were before). Some user may want to prevent autoplay for video/audio content.

There has been quite some evangelism to explain how much html5 video is better than flash videos since html5 videos are under the control of the browser and then under the control of the user.

it would be a good idea i think to allow the user to set the pref from the preference window

Note that preference window [1] already has an item in Content panel to choose to load images automatically or not. The trouble is much bigger with audio/video (because audio may be very disturbing and also it use a lot of bandwith)

Thanks

[1] http://support.mozilla.com/en-US/kb/Options%20window%20-%20Content%20panel

Reproducible: Always
About how disturbing audio/video content can be, note that a user even asked to treat audio/video like popup windows https://bugzilla.mozilla.org/show_bug.cgi?id=449531
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact is noted as preferences@firefox.bugs 
Shouldn't it be video.audio@core.bugs ?
Note that Bug 711827 is about allowing the user to stop all animations, included HTML5 audio/video, by pressing the Escape key
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493217
You cannot mark a FF preferences front-end bug as a dupe of a SM preferences front-end bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Sorry, didn't spot that it was a Seamonkey bug beforehand.
Depends on: 727273
Blocks: 661822
media.autoplay.enabled doesn't do enough to warrant being in the Preferences UI.

This is because we currently don't block script from starting the video using the HTML5 media API.

If we want to add something like this to primary UI, we will need to implement some checks to make sure that media can only begin playing when triggered by some user interaction (similar to how we treat popups).
This is now partially fixed, but don't close this bug. The current implementation only blocks autoplay on videos that play sound (ie are not muted), which is pretty arbitrary and IMHO hardly sufficient. It's nice to not be freaked out by some stupid sound, but an annoying blinking rectangle covering half of the page (and in worst case scrolling with the content) isn't any better.
You need to log in before you can comment on or make changes to this bug.