Dragging message(s) over a folder doesn't give highlight the drop folder

RESOLVED FIXED in Thunderbird 8.0

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: benjamin, Assigned: Paenglab)

Tracking

({regression})

unspecified
Thunderbird 8.0
x86
Windows 7

Thunderbird Tracking Flags

(thunderbird6+ fixed, thunderbird7+ fixed)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Posted image Screenshot of drag
I frequently drag messages to folders in the folder pane. In the previous version of Thunderbird, when I dragged over the folder the folder would highlight. This was very useful because I knew I had "hit" the correct folder. Now I get no visual feedback that I've got the correct folder because it doesn't highlight.

Thunderbird 5.0 (release), Windows.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668477
Reopening since this has tracking+ already, thus reversing the dupe.
See bug 668477 comment #1 though for dependency on the desktop theme.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 668477
Status: REOPENED → NEW
Posted patch Highlight the drop folder (obsolete) — Splinter Review
This patch highlights the drop folder. I tried to add a border but this didn't work well for the -moz-tree-cell. I gave the gradient a little more intense color to see it also through the moved message.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #543485 - Flags: review?(bwinton)
Comment on attachment 543485 [details] [diff] [review]
Highlight the drop folder

Review of attachment 543485 [details] [diff] [review]:
-----------------------------------------------------------------

Other than the tiny nit below, I like it!  r=me.

Thanks,
Blake.

::: mail/themes/qute/mail/mailWindow1-aero.css
@@ +154,5 @@
>    }
>  
> +  #folderTree treechildren::-moz-tree-cell(dropOn) {
> +    background-image: -moz-linear-gradient(rgba(255, 255, 255, .7),
> +                      rgba(255, 255, 255, .45));

This should line up with the other "rgba".
Attachment #543485 - Flags: review?(bwinton) → review+
Carrying over the r+

Asking for approval‑comm‑beta and approval‑comm‑aurora because this shouldn't break something and already a lot of TB5 users are mentioning this problem.
Attachment #543485 - Attachment is obsolete: true
Attachment #545711 - Flags: review+
Attachment #545711 - Flags: approval-comm-beta?
Attachment #545711 - Flags: approval-comm-aurora?
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/86474babc711
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
Attachment #545711 - Flags: approval-comm-beta?
Attachment #545711 - Flags: approval-comm-beta+
Attachment #545711 - Flags: approval-comm-aurora?
Attachment #545711 - Flags: approval-comm-aurora+
Duplicate of this bug: 671494
Duplicate of this bug: 675862
You need to log in before you can comment on or make changes to this bug.