Closed Bug 670974 Opened 11 years ago Closed 10 years ago

Unable to invoke virtual keyboard to provide input in text field at Google Maps

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec+)

RESOLVED WORKSFORME
Tracking Status
fennec + ---

People

(Reporter: aaronmt, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [website-compatibility], [short-list])

Attachments

(1 file)

Attached image Google Maps
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110712 Firefox/8.0a1 Fennec/8.0a1
Device: HTC Nexus One, Samsung Nexus S
OS: Android 2.3.4

Currently when you tap into the text field at Google Maps in order to specify a location, there is an orange highlight alongside a blinking cursor but no invocation of the virtual keyboard, thus I am unable to specify any input.

STR: maps.google.com, tap the text field

See screenshot
both bug 655398 and bug 663335 mention this problem. Can we dupe these?
(In reply to comment #1)
> both bug 655398 and bug 663335 mention this problem. Can we dupe these?

Woops, go for it.
This is the more general bug with better summary for the editbox/vkb issue. Bugs with narrow focus are better than big and vague. Duping bug 655398 to this bug.
Duplicate of this bug: 655398
tracking-fennec: --- → ?
Matt and Wes - is this another oddity with google maps and touch events?
Blocks: 663335
Assignee: nobody → mbrubeck
tracking-fennec: ? → 7+
This issue doesn't occur on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110711 Firefox/8.0a1 Fennec/8.0a1 
http://hg.mozilla.org/mozilla-central/rev/e898a773a4fb

but it occurs on:
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110720 Firefox/8.0a1 Fennec/8.0a1 
http://hg.mozilla.org/mozilla-central/rev/8753de11b181

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e898a773a4fb&tochange=8753de11b181
Oops, 

The build ID on which it occurs is: Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110712 Firefox/8.0a1 Fennec/8.0a1 

Sorry about that..

The rest is fine.
While finding out the regression range for bug 671273: Alt & Alt lock keys don't work correctly for maps.google.com text fields, I realized that this issue reproduces on previous builds than that of 07/11, when I could not reproduce it on a clean profile in portrait mode and so I thought that this is the last build on which it worked. So, in fact what I am trying to say is that if you install the build from 07/11, load www.maps.google.com in landscape mode and then switch orientation to  portrait and tap into the text field at Google Maps the VKB doesn't pop anymore (even though it did pop when it was on portrait mode).

This bug has the same regression range as bug 671273 and bug 655212 (which is now WFM) and that is :

It doesn't occur on: 
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110429 Firefox/6.0a1 Fennec/6.0a1 
http://hg.mozilla.org/mozilla-central/rev/ff152a406ed3

it started happening on:
Build ID : Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110430 Firefox/6.0a1 Fennec/6.0a1 
http://hg.mozilla.org/mozilla-central/rev/7162a399c334

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ff152a406ed3&tochange=7162a399c334

Sorry for any inconveniences.
tracking-fennec: 7+ → +
Duplicate of this bug: 678916
Whiteboard: [website-compatibility] → [website-compatibility][short-list]
Whiteboard: [website-compatibility][short-list] → [website-compatibility], [short-list]
This is still a problem on a Native Trunk build. Google maps is the mobile version.
Assignee: mbrubeck → nobody
Keywords: qawanted
Product: Fennec → Fennec Native
Hardware: x86 → ARM
Still an issue, Firefox 15 Beta 2 (07/25).
This is no longer an issue on Firefox Mobile 16.0b3 on Samsung Galaxy Tab 2 7.0 running Android 4.0.4 and on the Samsung Galaxy R running Android 2.3.4. I still get the mobile page but I can tap in the search field, suggestions appear if I type something and I can select any of the suggestions and the search is performed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.