Forwarding an .eml message causes message compose error

RESOLVED FIXED in Thunderbird 8.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: davepenfold, Assigned: squib)

Tracking

(Blocks: 1 bug, {regression})

Thunderbird 8.0
All
Other
regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird6 fixed, thunderbird7 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

Save a message to .eml format
Open .eml message in TB (opens in new window)
Click on Forward



Actual results:

First attempt, compose window opens with blank subject line
On second attempt, error: An error occurred while creating a message compose window. Please try again.



Expected results:

Compose window should open as normal without error so email can be forwarded
Does this happens in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ?
(Reporter)

Comment 2

6 years ago
Yes same issue in safe mode
(Assignee)

Comment 3

6 years ago
Confirmed on nightly. I'm in the process of narrowing down where this is happening...
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

6 years ago
Fallout from bug 583587, which adds references to forwarded messages, but this breaks for .emls because we can't get an nsIMsgDBHdr for them.
Blocks: 583587
(Assignee)

Comment 5

6 years ago
Created attachment 547338 [details] [diff] [review]
Fix this

Here's a quick one-line patch to fix this. No tests, since it's just one line (though I keep thinking when my patch queue isn't full to bursting that I should write some more tests for .emls).
Attachment #547338 - Flags: review?(jonathan.protzenko)
(Assignee)

Comment 6

6 years ago
Created attachment 547339 [details] [diff] [review]
Fix this (again)

Sorry, *this* is a one-line fix. (The previous patch had an extra blank line that snuck in.)
Attachment #547338 - Attachment is obsolete: true
Attachment #547339 - Flags: review?(jonathan.protzenko)
Attachment #547338 - Flags: review?(jonathan.protzenko)
Comment on attachment 547339 [details] [diff] [review]
Fix this (again)

Looks like the right to do. Thanks for fixing this so quickly.
Attachment #547339 - Flags: review?(jonathan.protzenko) → review+
(Assignee)

Comment 8

6 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/bfee0c972a27
Assignee: nobody → squibblyflabbetydoo
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

6 years ago
Comment on attachment 547339 [details] [diff] [review]
Fix this (again)

Asking for approval on branches. This is extremely low-risk, and high-gain for anyone who uses .eml files regularly.
Attachment #547339 - Flags: approval-comm-beta?
Attachment #547339 - Flags: approval-comm-aurora?
(Assignee)

Updated

6 years ago
Keywords: regression
(Assignee)

Updated

6 years ago
Duplicate of this bug: 674178
(Assignee)

Updated

6 years ago
Duplicate of this bug: 674495
Attachment #547339 - Flags: approval-comm-beta?
Attachment #547339 - Flags: approval-comm-beta+
Attachment #547339 - Flags: approval-comm-aurora?
Attachment #547339 - Flags: approval-comm-aurora+
(Assignee)

Comment 12

6 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/5ae46961864a
http://hg.mozilla.org/releases/comm-beta/rev/122457f20209
status-thunderbird6: --- → fixed
status-thunderbird7: --- → fixed
Odd, this bug looks entirely mailnews core, yet my test on SeaMonkey 2.2 (roughly == to miramar) appears to be fine.
Target Milestone: --- → Thunderbird 8.0
Blocks: 269826
You need to log in before you can comment on or make changes to this bug.