The default bug view has changed. See this FAQ.

When creating a new TabGroup near the edge of the screen in Panorama, a part of it is invisible

VERIFIED FIXED in Firefox 8

Status

Firefox Graveyard
Panorama
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: pretzer, Assigned: ttaubert)

Tracking

({regression})

Trunk
Firefox 8
All
Other
regression
Dependency tree / graph
Bug Flags:
in-testsuite +

Details

(Whiteboard: [testday-20110930])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 547462 [details]
Screencast of the issue (WebM)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110721 Firefox/8.0a1
Build ID: 20110721030828

Steps to reproduce:

When creating a new TabGroup by daragging a Tab near the edge of the screen in Panorama, a part of it will be hidden behind the edge of the screen and is therefore invisible. This is especially a problem when dragging to the top of the screen, since the groupname textfield is now automatically focused but not visible.
When dragging an existing group the the edge though, an animation takes place that moves the group back into the visible area.
This animation should be applied to the above case as well.
(Reporter)

Updated

6 years ago
Attachment #547462 - Attachment mime type: application/octet-stream → video/webm
(Assignee)

Updated

6 years ago
Assignee: nobody → tim.taubert
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

6 years ago
Blocks: 654721
Keywords: regression
(Assignee)

Updated

6 years ago
Depends on: 625668
(Assignee)

Comment 1

6 years ago
Created attachment 547593 [details] [diff] [review]
patch v1

I removed a legacy code line (from bug 579223) that called groupItem.setBounds() a second time after it already snapped into its place - even if that position was out of screen.
Attachment #547593 - Flags: feedback?(raymond)
Attachment #547593 - Flags: feedback?(raymond) → feedback+
(Assignee)

Updated

6 years ago
Attachment #547593 - Flags: review?(dietrich)
Comment on attachment 547593 [details] [diff] [review]
patch v1

Review of attachment 547593 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #547593 - Flags: review?(dietrich) → review+
(Assignee)

Updated

6 years ago
Duplicate of this bug: 670680
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/integration/fx-team/rev/d0d55ead551a
Whiteboard: [fixed-in-fx-team]
(Assignee)

Comment 5

6 years ago
http://hg.mozilla.org/mozilla-central/rev/d0d55ead551a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 8
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:9.0a2) Gecko/20110929 Firefox/9.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0

Verified on Ubuntu 11.04, Mac OS 10.6, Windows 7 and XP.

In Panorama, tab group are displayed correctly when tabs are dragged to the edges of the screen.
Status: RESOLVED → VERIFIED
Whiteboard: [testday-20110930]

Comment 7

6 years ago
verified fixed Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.