"Compact folders" when in newsgroup closes message pane and list-of-messages pane

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
7 years ago
9 months ago

People

(Reporter: John David Galt, Unassigned)

Tracking

(Blocks: 1 bug, {reproducible})

x86
Windows XP
reproducible

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

When I stopped viewing mail messages (in subfolders of "Local Folders") and started reading Usenet newsgroups, a popup appeared on the screen asking whether I'd like to compact the mail folders now.  I answered Yes.


Actual results:

Both the message pane and the list-of-messages pane disappeared from the screen and were replaced by a blank area with a few buttons on it, as if I had changed focus from the newsgroup I was reading to one of the top-level account folders.


Expected results:

The newsgroup message I was reading, and the list of messages, should have stayed right where they were.
Do you have some extensions installed ?

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367689
(Reporter)

Comment 3

7 years ago
The only extension I use in TB is Enigmail.

And I don't see how this could be the same problem as 367689, since this happens while viewing newsgroups (where I would hope compaction never reaches -- certainly if it ever does, the message about compacting *mail* messages needs changing).

Comment 4

7 years ago
compact does in fact operate on newsgroups. if you turn on the "ask" preference (iirc mail.purge.ask) you will encounter the prompt upon entering a newsgroup

Comment 5

6 years ago
Hi John. took me a while to find this sucker.
I'm seeing this behavior, and I've seen it long ago as well. 
In account settings and newsgroup retention settings, it is set to NOT delete any articles?

Do you have the same settings?

It think compact should affect a newsgroup ONLY if articles have been deleted (which should not happen with my settings).  Otherwise, why compact the folder?  So I am considering unduping this bug report.

I have "ask" set so I get the compact prompt. Perhaps folder doesn't blank if I disable the prompt - I haven't tested that theory.
Summary: "Compact folders" closes message pane and list-of-messages pane → "Compact folders" when in newsgroup closes message pane and list-of-messages pane
(Reporter)

Comment 6

6 years ago
Yes, I have retention set to forever for the newsgroups server.  I also have it download everything for offline use.

I never delete newsgroup messages (filters use "mark as read" instead), so I never get a prompt to compact a newsgroup folder.  However, when I compact (usually triggered by messages in subfolders of Local Folders that have passed their retention date), Thunderbird compacts (or at least behaves as though it is compacting) ALL folders, including newsgroups and others that have retention set to forever.  If Thunderbird's "compact folders" logic were smart enough not to clear the screen of data it isn't going to affect, this bug would not have been necessary.

Updated

6 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 7

6 years ago
relatively reproducible for me, for now
1. mail.purge.ask = true
2. delete enough messages to induce automatic compact
3. switch to a newsgroup
Status: REOPENED → NEW
Component: Mail Window Front End → Backend
Keywords: reproducible
Product: Thunderbird → MailNews Core

Comment 8

6 years ago
Created attachment 652073 [details]
compact newsgroup screenshot

thread pane only blanks for newsgroup (so far) - though I know that's not everyone's experience.

tested imap, no problem

tested pop, thread pane does not blank. But message pane does blank, and  selection of current is lost. Similar to bug 479064
Component: Backend → Networking: NNTP

Updated

4 years ago
Duplicate of this bug: 1025787

Updated

4 years ago
Duplicate of this bug: 880580

Comment 11

4 years ago
same concept as bug 494752?
(but for the sake of not further complicating so many symptoms in one bug, I'd rather keep this one open for newsgroups)
Blocks: 498274
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Updated

9 months ago
Duplicate of this bug: 1372765
You need to log in before you can comment on or make changes to this bug.