Sidebar/Bookmarks: right click menu is still tiny & empty

VERIFIED FIXED in mozilla0.9.1

Status

P1
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: burnus, Assigned: fabian)

Tracking

({regression})

Trunk
mozilla0.9.1
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Mozilla/5.0 (X11; U; Linux 2.2.18 i686; en-US; m18), build 2001020706

Now that bug 67435 is fixed I would like to get a working menu back for the
sidebar bookmarks. (The sidebar/history works: It doesn't show any menu. The
bookmark manager right-click menus work (now) like a charm.)

Observed: A right click in the sidebar/bookmarks produces a 3x5 pixel wide empty
menu.

Expected: The same as if I would right click in the bookmark manager: A fully
working menu.

Comment 1

18 years ago
I see it on win98 2001020704

A small comment to the reporter, you do not need to CC yourself.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 2

18 years ago
See bug 67427.

Comment 3

18 years ago
I see this too, but hasn't it been like this all the time?

cc'ing ben who are doing bookmark stuff...

Comment 4

18 years ago
Cc ben, bookmarks owner.

This is a regression: bookmark sidebar context menu used to have
- new bookmark, new folder, new separator
- delete bookmark
- properties...
- (for folders) set as [new bookmark, new internet search, personal toolbar] 
folder
Keywords: regression

Comment 5

18 years ago
Mozilla 0.8
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8) Gecko/20010215

Similar problem, i.e. no context menu in bookmarks sidebar, but I don't see a
3x5 empty menu, I see nothing.  I coulda sworn this was working in 0.7.

Comment 6

18 years ago
*** Bug 69093 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
The part that empty menus are tiny is bug 33723.

Comment 8

18 years ago
*** Bug 69571 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
*** Bug 69692 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Created attachment 26012 [details] [diff] [review]
partial fix

Comment 11

18 years ago
I made a partial fix that restores Properties menuitem if there is
any use for it. It also does some clean up to bookmarks.properties file.

Comment 12

18 years ago
Why does it remove the ellipsis ("...") on some of the strings? Those are there
for a purpose;

if the user needs to do any input after choosing that action, like Print (you
need to press "Print" in the new dialog to print), there should be an ellipsis.

If on the other hand, the user doesn't need to do anything in order to execute
that action (i.e Find Again) then it shouldn't have an ellipsis.

Please reconsider some of those string changes.. thanks.

Comment 13

18 years ago
I removed ellipsis from Rename because it doesn't open a new dialog window in
Bookmark Manager.

But if the new dialog window is not the issue but the additional keyword
interaction then you are right it should have the ellipsis.

Comment 14

18 years ago
s/keyword/keyboard/

Comment 15

18 years ago
Created attachment 26020 [details] [diff] [review]
partial fix without removing ellipsis from cmd_rename

Comment 16

18 years ago
leave the ellipsis of properties.

Comment 17

18 years ago
*** Bug 70679 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
ben owns sidebar bookmarks.
Assignee: matt → ben

Comment 19

18 years ago
Created attachment 27477 [details] [diff] [review]
updated fix for cmd_properties and redundant cmd_rename

Comment 20

18 years ago
Sidebar's bookmarks seems to be fixed (rewritten) in trunk so I updated the
patch. It fixes the ellipsis of cmd_properties and removes redundant cmd_rename.

Comment 21

18 years ago
This bug is fixed, it seems. If you don't create a new profile: edit your
existing profile's panels.rdf and change the bm-panel.xul to bookmarksPanel.xul
WFM.

Comment 22

18 years ago
You can also fix current profile like this.

  1. Select My Siderbar: Tabs: Customize My Siderbar...
  2. Remove Bookmarks from Tabs
  3. Add bookmarks to Tabs

Comment 23

18 years ago
Should I open a new bug for the bookmark.properties patch?

Comment 24

18 years ago
On my system (2001031304) this bug is fixed with respect to the context menu
appearing on right click. But the menu is not working, e.g. nothing happens when
clicking on "properties"

Comment 25

18 years ago
WFM with Linux build. Properties dialog also appears.

Comment 26

18 years ago
WFM too on winNT, build 2001-03-16

Comment 27

18 years ago
Opened a new bug 72798 for the bookmark.properties patch.

Comment 28

18 years ago
Is there a bug on the bookmarks context menu not doing anything?
(Most items are perm disabled - those who aren't don't work.)

Comment 29

18 years ago
I had this bug, but it seems to be working okay for me now (since at least build
20010312??, for Win98SE).

Comment 30

18 years ago
the menu comes up OK, but nothing does anything (2001-03-30) - another bug?

Comment 31

18 years ago
time to close this bug? (wfm with PC Linux 2001041505)

Comment 32

18 years ago
Marking worksforme as per user comments.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 33

18 years ago
verified in 4/12 build.
Status: RESOLVED → VERIFIED

Comment 34

18 years ago
Reopening : I'm seeing this again with 2001041805 linux
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 35

18 years ago
Gilles, are you seeing that the context menu is tiny & empty (the original bug),
or are some of the menu items non-functional (which should be a different bug)?

Comment 36

18 years ago
This has regressed at today's build (PC Linux 2001041805):

*** BAD! EVIL! WICKED! NO! ACK! ARGH! ORGH!
JavaScript error: 
chrome://communicator/content/bookmarks/bookmarksOverlay.js line 272: aNodeID is
not defined

Comment 37

18 years ago
Oliver: I see a tiny and empty context menu

Comment 38

18 years ago
*** Bug 77407 has been marked as a duplicate of this bug. ***
nominating for nsbeta1. 
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.1
nsbeta1+, P2.
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
(Assignee)

Comment 41

18 years ago
Attaching patch (one-liner)... like someone used to tell me.. "Duh!"
Taking from Ben marking P1, CC'ing reviewers. Please r=/sr=, thanks.
Assignee: ben → hidday
Status: REOPENED → NEW
Keywords: patch, review
Priority: P2 → P1
(Assignee)

Comment 42

18 years ago
Created attachment 33376 [details] [diff] [review]
One-liner for bug 68018.
r=doron

Comment 44

18 years ago
sr=alecf

Comment 45

18 years ago
if fabian needs cvs help/access, reassign this bug to me and I can check changes in.
(Assignee)

Comment 46

18 years ago
That's very kind of you, but hwaara already volunteered to check them in once
the tree opens. Thanks though :)
(Assignee)

Comment 47

18 years ago
Fix checked in. Marking FIXED.
Thanks for the reviews.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 48

18 years ago
currently bookmarks don't even load in the sidebar.

so I can't verify this bug until 71685 is fixed, right?

correct me if I'm wrong...I just tried context menu
in my empty bookmark tab, nothing comes up.

(Assignee)

Comment 49

18 years ago
Right nothing will come up if the display is blank. If you have bookmarks in
there the context menu will appear (although the menu items don't work, but
that's another bug).
I'm sorry to hear you are also experience bug 71685 :(

Comment 50

18 years ago
verified in 5/23 build..
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.