Closed Bug 71685 Opened 24 years ago Closed 23 years ago

Bookmarks in sidebar don't load

Categories

(SeaMonkey :: Bookmarks & History, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: vincent-moz, Assigned: bugs)

References

Details

(Keywords: regression, relnote, smoketest, Whiteboard: (working in mozilla builds?))

Attachments

(2 files)

After starting Mozilla 2001031121, the bookmarks area in the sidebar
shows: "Loading...". And when I move a window over this area, nothing
is redrawn in this area. The "Bookmarks" menu is OK.
I'm seeing this as well on build 20010311120 under Win2000.
Edit your panels.rdf in profile directory. Change bm-panel.xul to bookmarksPanel.xul
sending to ben... ben it seems you forgot panels.rdf in your new sidebar panel..
marking critical nominating for moz0.8.1
Assignee: matt → ben
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Sidebar → Bookmarks
Ever confirmed: true
Keywords: mozilla0.8.1
QA Contact: sujay → claudius
vfm in a just-compiled cvs build so it seems fixed
*** Bug 71731 has been marked as a duplicate of this bug. ***
I did check in a new defaults panels.rdf file. You need to hand edit your
profile version, or create a new profile. 
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → INVALID
seems bug 68018 is also fixed: right-click now brings up context-menu again.
VERIFIED invalid. "Duh" to me for being silly. :-)
Status: RESOLVED → VERIFIED
Uumm excuse me, did BenG just say everyone's sidebar Bookmarks are broken unless they
'hand-edit' panels.rdf or create a new profile??? What're you kidding? Surely, you jest.
Is that file overwritten on a new install w/existing profiles? I'm crossing my fingers and hoping
so.
I'm getting reports from all over that this _does_not _work_ in current builds
(20010313) on all platforms - even , or especially with a new profile.
Status: VERIFIED → REOPENED
OS: Linux → All
Hardware: PC → All
Resolution: INVALID → ---
Asko Tontii in bug 68018:

You can also fix current profile like this.

  1. Select My Siderbar: Tabs: Customize My Siderbar...
  2. Remove Bookmarks from Tabs
  3. Add bookmarks to Tabs
Last comment fixed my bookmarks (2001031304), but I've realized that "Tabs in my
Sidebar" don't show, even though they are there... I can select them, but no
text is displayed. This does not happen when I create a new user profile. Does
it also have to do with the new panels.rdf or should I file a seperate bug?
*** Bug 71949 has been marked as a duplicate of this bug. ***
I agree with claudius. What are you going to say real end-users? I hope, we
didn't drop the concept of a seamless migration.
Keywords: regression
*** Bug 71929 has been marked as a duplicate of this bug. ***
I have a crazy idea.

How about making bm-panel.xul symbolic link to bookmarksPanel.xul?
I seems to work with Linux but I don't know if it works with windows and mac.
(jar don't seem to understand symbolic links so bm-panel.xul is normal file
inside jar package).

Or can you import bookmarksPanel.xul to bm-panel.xul with the methods of
xml or xul?


symlinks don't work, jar.mn could create a copy, but unless zip is very good 
someone will complain about bloat.  
Hi ...

I am using build 2001031404 and the bookmarks side bar doesn't show anything.

I have tried to remove it and add it and the same result.
I checked the panels.rdf, and the it is there bookmarksPanel.xul.

My way to install mozilla as been by getting the zip file with build and unzip
it always to the same directory, so my bookmarks, and similar things are always
there.

Bye and a nice weekend

Frederico
Same result - empty sidebark bookmark window - for trunk Win32 installer
2001031514 build on WinME.
bloat: 2050 bytes (0.3%)

I think that fix could work as a temporary fix for 0.8.1?
*** Bug 72336 has been marked as a duplicate of this bug. ***
Ben: do we want to take this fix for .8.1?
This is mozilla-2001031304 on WinNT 4.

I have removed the Bookmarks sidebar and the added again. It worked... and then
it started to behave erratically - for instance the expanding/shrinking of
bookmarks folders didn't work.

I have closed mozilla and then started it again. It appears but doesn't load the
home page nor the bookmarks sidebar. And eats lots of memory then crashes.
Makring nsbeta1+, p1, mozilla0.9
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9
Florin Iucha: I think what you see is bug 71768, where single/double-click on
twisty/folder swopped place. A single click on twisty in bookmarks sidebar thus
does nothing right now - you have to double-click.
No. we do not see any bookmarks. Its' only "Loadin.." without end or just a
white rectangle.

BTW, removing bookmarks, rebooting (both Mozilla and the PC itself) and choosing
them again did not helpin my case. Tested on 20010316 and 20010319 Win32 trunk
installer builds.
It might be getting worse. I can't even add the bookmarks to my sidebar. using
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; 0.8.1) Gecko/20010316 & WinME here,
but it doesn't matter what I try, the bookmarks won't go into my sidebar.

Just as my bookmarks in the bookmark drop down bar don't have the scrollers
anymore. 

Jorden.
Ooops, I figured there'd be an easier way around this and it turns out there 
isn't. I'm going to rename the file to bm-panel.xul again. 
Status: REOPENED → ASSIGNED
*** Bug 72978 has been marked as a duplicate of this bug. ***
Removing panels.rdf is another (rather extreme?) way to fix the problem of
bookmarks not appearing in the Sidebar, but (as someone else reported), I still
don't get any text in the 'Customise My Sidebar'->'Tabs in my Sidebar' list, but
you can still select and remove items from this list.

Should this non-appearance be another bug? (Or is it already?)
The "text not appearing in the 'Customise My Sidebar'" problem was, I 
believe, fixed on 3/22 (see bug 71963).
*** Bug 72474 has been marked as a duplicate of this bug. ***
*** Bug 73776 has been marked as a duplicate of this bug. ***
Asa: is this relnoted?
Keywords: relnote
yes, this is release noted.  test as follows:

"Older Profiles may not display the bookmarks tab in the sidebar properly. The
workaround is to click on the "Tabs" button in My Sidebar and select the
"Customize My Sidebar" menu item. In the resulting window remove the bookmarks
tab, hit OK and restart Mozilla. Go back to the Customize window and add the
bookmarks tab. (Bug 71685)"
reading the smoketest results this bug is continually listed (via dupe 72474), so adding
smoketest keyword since it fails it's smoketest.
Keywords: smoketest
*** Bug 75601 has been marked as a duplicate of this bug. ***
Anyone willing to give r/sr on the basis of me saying I'm just renaming the 
file? (cvs remove old file, cvs add back bm-panel.xul, adjust jar.mn 
appropriately)? 

sr=sfraser
Hmm, I think it would be better to keep the current filename because it
has taken so long to fix this. Probably almost all Mozilla users are now
using the new filename.

Only problem I could see is the Netscape 6 users.

Some solutions for that:

1) profile manager fixes profile when it is ran
2) at startup mozilla checks profile and fixes it
3) when sidebar loads mozilla checks profile and fixes it
4) jar trick (see attachment id=27994)

Only one pre-1.0 milestone has been shipped with this. I do not have a problem 
breaking this for .8.1 users. I'd rather keep compatibility with NS 6 and older 
Mozilla milestones. 
curious: why the switch to non force in jar.mn?
[r=timeless]
r=pchen if you need it
The Force was some cruft in my tree that got accidentally checked in a while 
back. Just cleaning up after myself because jag gave me a hard time ;) 
in kerz's words, "Horrah."
Status: ASSIGNED → RESOLVED
Closed: 24 years ago23 years ago
Resolution: --- → FIXED
*** Bug 76454 has been marked as a duplicate of this bug. ***
Whiteboard: relnote0.9
Cc: twalker.
still not working in 4/20 build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
*** Bug 77045 has been marked as a duplicate of this bug. ***
Does this depend on bug 76623 ?
adding Paul to the Cc list - Paul, can you help with this? 
Can someone explain what the problem here is?  i've got three brand new profiles
and 3 really old (been around since 0.7 or so) profiles and all of them display
bookmarks in the sidebar for me on Mac, win32 and linux.  
executive summary todate for Asa (others please correct if I've missed something):

sometime before 0.8 someone (Ben?) changed bm-panel.xul to bookmarksPanel.xul.
realising the incompatibility this introduced with old profiles they now want to
change it back. All builds between the two changes can't import a pre-change
profile's bookmarks, the panel simply is never rendered. Builds after the second
change would not be able to load bookmark panels created (or updated) by any of
the interim builds. (this is I think what you mention relnoting for 0.9, as all
0.8 build users will be affected when they upgrade to 0.9, either because they
created a new profile under 0.8, or because they did one of the migration fixes
to get bookmarks working again.)

I had thought the corrective change went in sometime last month... but I gather
it hasn't.

oh yeah, in addition to that this has been a dumping ground for a few odds and
ends of bizare bookmark related bug reports which make little sense.
There's only one problem there for me.  I did the "funky workaround" (remnove
the panel and readd it) to make my bookmarks show up with 0.8.1 and they still
work fine with the latest 0.9 candidate builds.   
right, because the second change (back to bm-panel.xul) which is needed to get
compatibility with ns6 and moz < 0.8 hasn't gone in yet.
a=drivers
Chris Abbey, Ben changed the resolution of this bug to 'resolved fixed' on 4.17 after getting
the patch approved and whatnot. To the casual and trained eye that typically means the
checkin that fixes the bug has been committed. Now in truth I must admit I haven't cracked
open the .jar file to simnply look and see the name of the xul file so I can't be sure.

Nonetheless this bug is reopened 'cuz it don't work'.

Asa, sadly ever since the first change I haven't had sidebar bookmarks on any platform.
The 'workaround' didn't work for me and I suspect trying during the inbetween time has
put me in the current state I'm in. -->Still no sidebar bookmarks, even w/ a new profile.
claudius: I didn't even know about this workaround 'til now and was being 
quietly annoyed that this defect was lingering. I'm wondering if you did the 
workaround right. My first attempt did not work. Just removing and readding did 
not work for me. Then I tried removing the old one, clicking OK in the dialog, 
then I brought the dialog up again, and *then* added the new one. And it worked 
that time. *Actually* I pressed 'preview' before adding it. Maybe preview made a 
difference?
Claudius: I just checked: comm.jar contains
content/communicator/bookmarks/bookmarksPanel.xul, so *if* the quote from kerz
on the 17th was in fact a checkin celebration then it either went awry, or has
since been regressed. :( eitherway if your profile's panels.rdf has bm-panel.xul
then you'll be missing the bookmarks sidebar and not be a very happy camper.

jband: the act of clicking OK in between (to write out the panels.rdf file?)
seems to be needed in between the remove and re-add. if you don't do that
someone somewhere must be "smart enough" to realize you didn't change it.

having said all that... my panels.rdf contains
"communicator/content/bookmarks/bm-panel.xul" (as I suspect does the default,
since this is a nearly virgin profile...yup) note the different tree structure?

Hey Ben? wtf??
Work around for MOZILLA Build ID: 2001032112:
- rename BOOKMARKS.HTML to OLD-BOOKMARKS.HTML
- delete PANELS.RDF
- start MOZILLA
- select Bookmarks -> Manage Bookmarks...
- import OLD-BOOKMARKS.HTML

My Sidebar -> Tabs -> Customize My Sidebar ... opens the window "Customize My
Sidebar" but there is nothing in the two sub windows

I get the message:
JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x804b000a [nsIRDFService.GetDataSource]"  nsresult: "0x804b000a (<unknown>)" 
location: "JS frame :: chrome://communicator
/content/sidebar/customize.js :: sidebar_customize_init :: line 72"  data: no]

*** Bug 77273 has been marked as a duplicate of this bug. ***
Re: ------- Additional Comments From Florin Iucha 2001-03-19 09:06 -------

Saw similar problems in 0.8.1. Turned out that the bookmarks.html file
contained heaps of duplicate entries (was about 5x larger than it should be).
After removing the duplicates by hand, everything worked fine again.

No, I don't know how the duplicates got into bookmarks.html. May have been
there since before I installed 0.8.1.
Are we waiting for ben to checkin? We've got two r=, an sr=, and an a=. What's
holding things up?
nothing happening here. not critical to 0.9. pushing out to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
 Branko Èibej: No duplicate entries in my bookmarks file. That's something
different.
Nobody is responding to this bug anymore..

can we reassign to someone else to fix?
Seems this bug should have a whiteboard "fix in dead hand" status :-(
The fix has been in for some time now. For those who have a profile from 0.8.1
the workaround of opening the Customize Sidebar dialog, removing bookmarks,
closing the dialog, reopening it, adding bookmarks, reclosing it will work.
*** Bug 79428 has been marked as a duplicate of this bug. ***
*** Bug 79614 has been marked as a duplicate of this bug. ***
2001050804 opt. build.
New Profile
Sidebar-->Tabs-->Customize Sidebar
Recommended>Bookmarks
[Add]
[OK]
Click on Bookmarks tab.
No damn bookmarks in my sidebar.
Fix that(please).
Worksforme new profile buildid 2001050904 win2k. Anyone CC'ed in this bug please
care to test this? It's really important, thanks.
Claudius: The workaround has worked for all the users to whom I've given this
trick, including the reporter from the dup just above your comment (got a reply
on personal email).
It doesn't work for me yet. I'm usding : Mozilla/5.0 (Windows; U; Win98; en-US;
rv:0.9+) Gecko/20010509 (18:09).
I have _not_ been able to get the workaround to fix this on windows, linux or 
mac.
I am still seeing this too.  Claudius, does your testing show that someone
upgrading from 6/6.01 to 6.x would be affected by this?
On the workaround: it won't work unless you first CLOSE the "Customize Tabs"
dialogue box after removing the Bookmarks tab.  Then reopen it and add
booksmarks.  Does this help?
add cc: sujay
BTW, my point in asking about whether or not 6.0 users are affected is that
there's no way we can go out the door and ask average users to use this workaround.
Tried the workaround with all suggestions - still doesn't work.
OK I did a little test on *another* machine than the one I usually test on. This
one is a Cyrix133 with 48MB RAM (shudder) running win95. I installed a fresh
NS6.01, and a fresh Mozilla0.9. I created a *new* profile in NS6.01. I closed
NS6.01. I launched Mozilla 0.9 with the profile created in NS6.01. (The UI was
horked but that is expected due to the numerous chrome changes (and switching
themes fixed it)).
I opened the sidebar, surprise, my bookmarks appeared in the sidebar.
(now I'll stop spamming this bug, since obviously I can't see any bug you guys
are seeing)
WFM on 2001-05-09, winNT - has worked for several weeks now.
I have this problem too.  Wasn't the root cause a renaming of a file?  Why can't
we just put that file back to it's old name until this problem has been properly
debugged?  *That's* the fix I'd like to see for beta!
selmer: I believe Ben already went that route(just revert the filename). That's when this bug
was marked 'fixed'. I reopened it because it didn't work for me and several others.

todd: I'm looking into it. I'm afraid there may be some commercial vs. moz. issues here
as I have been able to make a clean moz install and new profile work. IF that turns out to
be the case I'll update accordingly.
Whiteboard: relnote0.9 → fix in hand, cvs problems, relnote0.9
Yay! Leaf just told me how to work around the cvs problem. Fix will be checked 
in this evening.
Status: REOPENED → ASSIGNED
Whiteboard: fix in hand, cvs problems, relnote0.9 → ETA: check in this evening (05/21)
awesome!
Ram time, sucka!
Status: ASSIGNED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → FIXED
Pulled a fresh tree with ben's changes. The compilation is failing (Win2K).
Do you also need to update jar packaging or something?

+++ make: install in C:\Mozilla\src\mozilla\xpfe\components
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\public
+++ make: installing typelib '.\_xpidlgen\mozcomps.xpt' to components directory
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks\public
+++ make: installing typelib '.\_xpidlgen\bookmarks.xpt' to components directory
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks\src
nsBookmarksService.cpp
    Installing WIN32_D.OBJ\bookmarks_s.lib into ..\..\..\..\dist\WIN32_D.OBJ\lib
\bookmarks_s.lib
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks\resources
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks\resources\
locale
+++ make: install in C:\Mozilla\src\mozilla\xpfe\components\bookmarks\resources\
locale\en-US
+++ making chrome /cygdrive/c/Mozilla/src/mozilla/xpfe/components/bookmarks/reso
urces  => ..\..\..\..\dist\WIN32_D.OBJ\bin\chrome/comm.jar
file not found: ./content/communicator/bookmarks/bm-panel.xul at ..\..\..\..\con
fig\make-jars.pl line 175, <STDIN> line 31.
NMAKE : fatal error U1077: 'perl.exe' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\N
MAKE.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\N
MAKE.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\N
MAKE.EXE"' : return code '0x2'
Stop.
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\N
MAKE.EXE"' : return code '0x2'
Stop.
Filed bug 82061 on the build problem.
ok, I've had it with this bug. Now, either a) somebody fixes the cvs server so 
that clients can pull this file, or b) this bug is WONTFIXed. 

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We HAVE to fix this for beta.  Can someone help Ben out with CVS?  Leaf/John?
ok, so to make sure I understand what's going on here, the file bm-panel.xul was
renamed to bookmarksPanel.xul, and now we're switching it back to bm-panel.xul,
right?

Looking at lxr, bm-panel.xul is still in the Attic so that means it's dead on
the trunk so it won't be checked out.  I believe this requires cvs fu on the
server in order to preserve the revision history and since I have no access to
cvs.mozilla.org, leaf will have to handle this.
Is the only problem that you want to "unremove" a CVS file. IIRC, you can do
that on the client. Something like
  - cvs log <file>
  - cvs up -r <ver> <file>, while <ver> is the last version before the removal
  - cvs add <file>
  - cvs commit <file>
I think ben said it best when he commented: "@#$!%$#@#$!%"

The file, when i looked this weekend, i thought it was not in the Attic. I was 
able to update  it without specifying any revision.

It was in the Attic, but the latest revision is not marked "Dead", so doing an 
update of the filename specifically pulls it. This explains why already 
pulled trees weren't getting it when everyone else could pull it manually.

I've done some cvs magic and put it back outside the Attic, and you, Ben 
Goodger, can copy whatever contents you want into it (though i suspect it 
already has all the contents you want in it).

It really seems like cvs has gotten more flaky in the last three months.
Thanks! Trying again now...
Roight. Let's see if it works this time. 
Status: REOPENED → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → FIXED
Does that mean we all have to do the 3/13/2001 workaround again? If so, should
there be an announcement on the newsgroups?
Yes, I believe this means that folks who previously used the workaround or
created new profiles after the first change will have to use the workaround. 

Workaround:  
1. open browser
2. view sidebar
3. click "Tabs" button at top right of sidebar
4. select "Customize Sidebar" menuitem
5. select "Bookmarks" from "Tabs in My Sidebar" list
6. click the "Remove" button below the list of "Tabs in My sidebar"
7. click OK
8. click "Tabs" button at top right of sidebar
9. select "Customize Sidebar" menuitem
10 select "Bookmarks" from "Available Tabs" list
11 click the "Add" button below the list of "Available Tabs" list
12 click OK

note: just unchecking the tab from the "Tabs>" menu and rechecking it will not
fix the problem.
Claudius - can you determine what the user experience for 6/6.01 upgraders is -
i.e. will their bookmarks tab work without having to go through the workaround?
In response to the last post, I upgraded from Netscape 6.0 and had to use the
workaround to fix this problem.
Tekin, you upgraded from 6.0 to today's build (20010523xx)? I would assume that
no workaround was necessary since today's build (not yesterday's though) reverts
us to the same name from the mozilla0.6 and 0.7 days.  
yes, using today's 5/23 build, I didn't use the workaround
and it seems to work fine now...I tried a couple old profiles and
it loaded the bookmarks fine...
In response to ASA: I used the workaround on build #20010508 and since the
problem was corrected back then, I never tested it with the new build. However,
it sounds like Sanjay has indeed confirmed that the new build solves the problem.
*** Bug 82416 has been marked as a duplicate of this bug. ***
Yeah it works for me now with Build 2001052308 on Linux.
Okay I just installed today's build (20010523) and now the bookmarks are not
showing up again in My Sidebar.  I upgraded from 20010508.  The workaround
brings them back, again.  For people who were using the previous post 0.9
nightly builds like myself, it would appear this could become a problem again. 
I didn't use an automatic installation routine (there isn't one for nightly
builds, right?), which could of course check for this problem and correct it
during the install.
Korhan Tekin, correct. That is the behaviour Asa was predicting.

We now have the three "era"s that I was talking about a month ago in this bug:

1. Before first change  ( <= ~11 March )
2. Between changes      ( ~11 March - 23 May )
3. After second change  ( >= 23 May )

if you cross an *odd* number of boundaries between eras you'll need the
workaround each time. if you cross an even number of boundaries you don't need
any workaround.

So a profile from before 11 March will now work just fine. This is the case Todd
was asking about, and (I think) Sujay was confirming.

If you had a profile from before 11 March and did the workaround sometime
between 11 March and 23 May your profile is no longer a "pre 11 March"
profile... it is now a "sometime in April" profile and you will have to do the
workaround *again*.
Sigh. Ben when you went through whatever trials and tribulations you had to to get this fixed
did you do the same for the NScommercial tree? I ask because my comm.jar file in a new opt.
comm. build(2001052404) still contains the file bm-panel.xul with a last mod date of
5/22/01 10:09 pm.

I therefore have no bookmarks in my sidebar.

I created a _virgin_ install of NS6 with the 2001052404 Win98 build and still see this error.

On the Moz side this bug appears fixed and i think we'll just need to relnote the workaround
for those users who may be affected (the good folks who regulary downloaded builds).

Todd, I installed a trunk build on top of a 6.01 build and somehow it works fine - i still only see a
bm-panel.xul but I DO see bookmarks in my Sidebar. It is important to note that a new clean install
still does NOT work however, that's why this bug is REOPENED.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
slight misunderstanding on my part above. bm-panel.xul IS the original name and the one
we should be seeing (i had it mixed up). My results are still valid though. A new, clean
install contains the right file but bookmarks still do not show up in the sidebar.
mmm... sweet netscape-only bugs in bugzilla.mozilla.org. ben, do you still have
access to the ns/ tree? and, claudius, could you open a bugscape bug to track this?
Claudius: was this with an existing profile or creating a new one? Assuming an
existing profile, when was it created and/or "workaround'ed"? I just started up
a build of the current (frozen for verification builds) tree without problem; it
created a brand new .mozilla directory, profile, everything. (my real profile
isn't a valid testcase because I smacked it around after making my append to
this bug on 24 April and effectively changed it back to the way it shoulda been.)
clearing status whiteboard, since "ETA: check in this evening (05/21)" doesn't
make sense any more.
Whiteboard: ETA: check in this evening (05/21)
Ben, any update on this fix?  
This is fixed. 
-> samir
Assignee: ben → sgehani
Status: REOPENED → NEW
This is not fixed when launching with a new profile.  
Worksforme with 053004 mozilla win32 build on win2K and win98, 053008 mozilla
linux build on RedHat 6.2 and 053008 mozilla mac build on OS 9.1 

I created a new profile on each OS and the default bookmarks appeared in the
sidebar and were completely usable.
Whiteboard: (working in mozilla builds?)
This is fixed in mozilla.  Final tweaking needs to be done to the commercial
panels.rdf profile default.  Filed bugscape bug 5539 regarding the same.

Since ben fixed this let's leave it assigned to him and mark it fixed.
Assignee: sgehani → ben
Fixed by Ben.
Status: NEW → RESOLVED
Closed: 23 years ago23 years ago
Resolution: --- → FIXED
this is VERIFIED Fixed in Mozilla builds and has been for some time (since at least 5/15).
netscae types can follow the internal version at 5539
Status: RESOLVED → VERIFIED
*** Bug 83606 has been marked as a duplicate of this bug. ***
*** Bug 83649 has been marked as a duplicate of this bug. ***
*** Bug 84146 has been marked as a duplicate of this bug. ***
*** Bug 84761 has been marked as a duplicate of this bug. ***
*** Bug 85648 has been marked as a duplicate of this bug. ***
*** Bug 85763 has been marked as a duplicate of this bug. ***
*** Bug 88754 has been marked as a duplicate of this bug. ***
*** Bug 90708 has been marked as a duplicate of this bug. ***
*** Bug 104595 has been marked as a duplicate of this bug. ***
*** Bug 100532 has been marked as a duplicate of this bug. ***
*** Bug 108863 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: