Closed Bug 682096 Opened 9 years ago Closed 9 years ago

Address Book opens empty. Appears to be missing/lost. tree is undefined Source File: chrome://messenger/content/jsTreeView.js

Categories

(Thunderbird :: Address Book, defect, major)

x86_64
Windows 7
defect
Not set
major

Tracking

(thunderbird7+ fixed, thunderbird8+ fixed)

RESOLVED FIXED
Thunderbird 9.0
Tracking Status
thunderbird7 + fixed
thunderbird8 + fixed

People

(Reporter: wsmwk, Assigned: mconley)

References

()

Details

(Keywords: regression, Whiteboard: [gs][datalossy])

Attachments

(2 files)

Shredder 8.0a1 2011-08-16
Approximate steps (reproduced only twice, so must not have exact step)


1) open 3pane with 2 imap accounts A and B, only log into one account A. 
2) open compose for both accounts with some text 
[from here it's a little fuzzy] 
3) try to save draft for account B, it fails "There was an error saving the message to Drafts. Retry?"
4) close 3pane 
5) open 3pane from one of the open compose windows 
6) open AB

results:
- AB window shows no contacts and no ABs
- Error console shows
Error: tree is undefined
Source File: chrome://messenger/content/jsTreeView.js
Line: 198

requires restart to get AB display back
Attached image screen shot
seen again, and I have no idea what the steps are to reproduce. But I did nothing like comment 0.

And I may have encountered a report on getsatisfaction. Waiting for confirming feedback.
I'm seeing this more frequently. And I didn't have this problem when using pre version 6.  Further, it is unclear 
a) when this regressed
b) whether there are multiple AB problems regressions of this type, because I see many reported for v6 [1], but there also seems to be a few for v5.  

[1] 20+ reports in gfsn http://getsatisfaction.com/mozilla_messaging/tags/bug_682096  (I haven't totally vetted this list)


regression from:
Bug 422845?  Replace rdf-driven addressbook directory tree with js one
Bug 652855?  De-RDF the address book


(and other issues
http://getsatisfaction.com/mozilla_messaging/tags/abkeep
http://getsatisfaction.com/mozilla_messaging/tags/absidebar
http://getsatisfaction.com/mozilla_messaging/tags/abf9
)
Severity: minor → major
Keywords: regression
Summary: Address Book opens empty → Address Book opens empty. Appears to be missing/lost.
Whiteboard: [gs][datalossy]
Wayne:

Hey, I've started looking into this, but I'm having trouble recreating on Linux.  Is it your impression that this problem is mostly occurring for Windows users?

-Mike
Still no luck reproducing.

If anybody knows a way of reliably reproducing this bug, please comment and let me know!

Thanks,

-Mike
xref Bug 682797 - Address Book disappears after upgrade to V6
Summary: Address Book opens empty. Appears to be missing/lost. → Address Book opens empty. Appears to be missing/lost. tree is undefined Source File: chrome://messenger/content/jsTreeView.js
First pass at this bug.  Based on workaround for bug 658534.
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Attachment #556824 - Flags: review?(dbienvenu)
Comment on attachment 556824 [details] [diff] [review]
Patch v1 - Workaround

might be worth trying to get into tb 7 b2, which will get built real soon.
Attachment #556824 - Flags: review?(dbienvenu)
Attachment #556824 - Flags: review+
Attachment #556824 - Flags: approval-comm-beta?
Attachment #556824 - Flags: approval-comm-aurora?
given comments in bug 658534 comment 13 about startup cache, what bug caused the regression?
(In reply to Wayne Mery (:wsmwk) from comment #8)
> given comments in bug 658534 comment 13 about startup cache, what bug caused
> the regression?

I think the startup cache just affects the jit somehow, though we won't know until the js folks figure out the underlying issue.
Duplicate of this bug: 682797
Checked in: http://hg.mozilla.org/comm-central/rev/e0953facfcfc
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 9.0
Attachment #556824 - Flags: approval-comm-beta?
Attachment #556824 - Flags: approval-comm-beta+
Attachment #556824 - Flags: approval-comm-aurora?
Attachment #556824 - Flags: approval-comm-aurora+
Hi All

I have just downloaded TB6.01 and access to address book appears to be operating normally.  Have opened and closed address book 3 or 4 times without any problems.
Duplicate of this bug: 682802
Just had the problem on TB17 / Win XP. The addresses are there, the address lists appear e.g when I add a new contact. However: The address books are not visible.
You need to log in before you can comment on or make changes to this bug.