Closed Bug 658534 Opened 9 years ago Closed 8 years ago

can't collapse+expand accounts in folder pane, tree is undefined

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86_64
Linux
defect
Not set

Tracking

(thunderbird6+ fixed, thunderbird7 fixed)

RESOLVED FIXED
Thunderbird 8.0
Tracking Status
thunderbird6 + fixed
thunderbird7 --- fixed

People

(Reporter: tuukka.tolvanen, Assigned: Bienvenu)

References

()

Details

(Whiteboard: [gs])

Attachments

(1 file)

tbird trunk circa 2011-05

1. collapse an account in folder pane (click on plusminus/arrowthing next to it)
2. expand an account in folder pane ( --"-- )

expected: account folders expanded

result: Error: uncaught exception: [Exception... "'[JavaScript Error: "tree is undefined" {file: "chrome://messenger/content/folderPane.js" line: 889}]' when calling method: [nsITreeView::toggleOpenState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: changeOpenState :: line 241"  data: yes]
(expanding works the first time, when things are collapsed at startup.)
This works for me with Miramar Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:5.0) Gecko/20110522 Thunderbird/3.3a4pre. Can you paste your UA string ?
I also observe this problem

Error: uncaught exception: [Exception... "'[JavaScript Error: "tree is undefined" {file: "chrome://messenger/content/folderPane.js" line: 889}]' when calling method: [nsITreeView::toggleOpenState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: changeOpenState :: line 241"  data: yes]


LastVersion=7.0a1_20110531030014/20110531030014
LastOSABI=Linux_x86_64-gcc3
Shredder/7.0a1/x86_64
What folder views are you guys using ?
Good morning

I'm Using the "All Folders View", so, in the meantime i've found these actions as well:


1) When, by mistake i collapse some folder it's impossible to expand it, the only way to make it expand it's close Shredder and then run it on safe mode, expanding the folder and then quitting to normal mode. (altought most of the time running Shredder in safe mode expands all folders in the default view set by the user, in my case it's an "all folder" view), of course, this also doesn't work 100% of the time.

2) When switching views all follders colapse, so i have to do (1) above.


Being that this happens when having extensions or not, don't think that this is the culprit, but i'll list my extensions anyway:

- Lighting Nightly 1.1a1pre (x86_64)
- Enigmail 1.2a1pre (x86_64)
- es_ES dictionary 1.5
- es_ES langpack


Good day.
I believe this is an issue with Lightning. Does anyone have any evidence to the contrary?
But what is Lightning doing that could cause this? We have nothing to do with the folder pane...
(In reply to comment #7)
> But what is Lightning doing that could cause this? We have nothing to do
> with the folder pane...

No idea, though errors sometimes cascade in weird ways. But Julio says it happens w/o Lightning. Julio, can you recreate the issue in safe-mode? And by "some folder", do you mean a particular folder, or just some random folder?
Well, after today's update to i can't really reproduce it since it works with or without lightning enabled. Maybe it went away?
Sorry, typo: was "After today's update to shredder".
Back again.

Looks like Lighting it's indeed causing this. Working in safe-mode or just by disabling lighting and restarting causes the issue.

The error it's still the same JS from the error console.
Component: Mail Window Front End → Lightning Only
Product: Thunderbird → Calendar
QA Contact: front-end → lightning
I think this problem isn't related to Lightning because I have the same problem and no extension installed. After TB starts I see:

Error: tree is undefined
Source code: chrome://messenger/content/folderPane.js
Line: 889

Thunderbird 7.0a (latest nightly).

After startup I don't see folder tree when I have "all folders view". When I change view to "unread folders" and restart Thunderbird then all works fine and I can switch back to "all folders view". But after a while I cannot expand some folder with error:

Chyba: uncaught exception: [Exception... "'[JavaScript Error: "tree is undefined" {file: "chrome://messenger/content/folderPane.js" line: 889}]' when calling method: [nsITreeView::toggleOpenState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: changeOpenState :: line 241"  data: yes]

It is interesting that I cannot reproduce this problem in safe mode. Not sure why. I don't have extensions and my profile is new. If you need some special info just say.
I have a suspicion about this. After ruling out other persistent state like folderPane.json, localstore.rdf, etc - I suspect this might have to do with the fastload cache (now known as the startup cache). It's in the C:\Users\<User Name>\AppData\Local\Thunderbird\Profiles\<random string>\startupCache directory now. If I delete that file before re-running, the problem goes away. I believe starting in safe mode ignores the startup cache.

The error happens here:

http://mxr.mozilla.org/comm-central/source/mail/base/content/folderPane.js#876

where we assign this to a local var "tree", but tree doesn't appear to be defined in the scope of recursivelyAddToMap, when this bug occurs.

Brendan, I can reproduce this fairly easily (open TB, open address book, close 3-pane, close address book, restart). If it is possible that the startup cache is involved, is there any diagnostic info I can gather that would help track this down?
Component: Lightning Only → Folder and Message Lists
Product: Calendar → Thunderbird
QA Contact: lightning → folders-message-lists
With this patch, I can't recreate the issue anymore. The core issue, whatever it is, should be fixed, but I'd like to help our users by having the work around in tb 7, at least.
Assignee: nobody → dbienvenu
Attachment #546595 - Flags: review?(bwinton)
I have this issue with Thunderbird 6B1.
View -> All Folder 
If I collapse a folder tree (Local Folder or Imap account), I  can't expand it anymore, in console I have this:

Errore: uncaught exception: [Exception... "'[JavaScript Error: "tree is undefined" {file: "chrome://messenger/content/folderPane.js" line: 889}]' when calling method: [nsITreeView::toggleOpenState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: changeOpenState :: line 241"  data: yes]
Ok, in safe-mode the issue disappears, I have solved disabling mail-tweak. I think this issue is caused by some extension.
bug 653393 is a duplicate?
Duplicate of this bug: 653393
platform => All because it happens to me also in Windows 7
OS: Linux → All
Duplicate of this bug: 673809
OS: All → Linux
Comment on attachment 546595 [details] [diff] [review]
proposed workaround

r=me, but I think we should get a bug on this in js land as well, so that it is tracked there at least.
Attachment #546595 - Flags: review?(bwinton) → review+
Duplicate of this bug: 669801
Duplicate of this bug: 674008
http://hg.mozilla.org/comm-central/rev/d5812a6f28b9

Fixed on trunk - I'll file a bug on js land.
Target Milestone: --- → Thunderbird 8.0
Comment on attachment 546595 [details] [diff] [review]
proposed workaround

getting on TB 6 and 7 radar.
Attachment #546595 - Flags: approval-comm-beta?
Attachment #546595 - Flags: approval-comm-aurora?
Blocks: 674055
Duplicate of this bug: 673897
Duplicate of this bug: 673663
Attachment #546595 - Flags: approval-comm-beta?
Attachment #546595 - Flags: approval-comm-beta+
Attachment #546595 - Flags: approval-comm-aurora?
Attachment #546595 - Flags: approval-comm-aurora+
comm-aurora - http://hg.mozilla.org/releases/comm-aurora/rev/808d304bffad
comm-beta - http://hg.mozilla.org/releases/comm-beta/rev/f67f7a7027a7
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Will the fix be included in 6.0 Beta 2 please? Or is there a recompiled installer for Win32? It's urgently needed by the average user.

Thank you in advance
status-thunderbird6 is set to "fixed" so it will be included in the next beta.
When is the next beta due? This bug is recurring for me regularly. The only simple workaround I've found is to start in safe-mode, exit then start normally. For the rest of the session TB is fine
Duplicate of this bug: 674729
I believe next beta will be out late this week or early next week.
David - good to hear.

I had another install yesterday automatically update itself to this broken build.  I think this sort of critical bug is a good example of the type of issue that should cause the current TB6 release to be pulled, so that more customers don't get their mail broken by an update.

The number of duplicate reports of this issue I think is a good indication of the impact it's having out there.  People who can't use their mail client end up moving to another one.

Is there a protocol at Mozilla for this sort of thing?
TB 6 is currently in beta.
David - understood.

I think quite a few people are running it, and even though it is marked beta, they still rely on it, since up to this issue it was reliable.

Also, I had been running 5 beta 2 prior to it updating itself to 6, which I didn't get a choice about.

I don't know if your average beta tester would expect a "mature" .2 beta release to be updated to a next-gen immature major release automatically.
We're trying to ship a beta with a fix asap (eta, Tuesday). 

Re the beta channel update issue, we did not know how common this bug would be when we updated people who had opted in for the 5.0 beta program. In fact, we weren't sure that it actually happened in TB 6 (as opposed to TB 7). That's what beta feedback is for, unfortunately.
Duplicate of this bug: 676490
Duplicate of this bug: 673861
You need to log in before you can comment on or make changes to this bug.