If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow multiple keywords for a single bookmark

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
17 years ago
2 months ago

People

(Reporter: Matthew Cline, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

17 years ago
The bookmarks system should allow a single bookmark to have multiple keywords.
For example, you could enter "foo,bar" as the keyword for a bookmark, so
either "foo" or "bar" would expand to that bookmark.

Comment 1

17 years ago
My first point is why?
My second is the obvious workaround is to simply have two bookmarks.

Comment 2

17 years ago
I can't see how this would be usable? If you already have "foo" then why also
map "bar" to that URL? Why not always use "foo"? This is useless AFAIK.

In my opinion, this should be a WONTFIX.
(Reporter)

Comment 3

17 years ago
I want this for keywords where I can't quite remember what the keyword
is; if I had this feature, I could put in a comma separated list of
likely keywords, so that any of them that I happened to remember would work.

Comment 4

17 years ago
Håkan Waara: This is very useful. For example on irc #mozilla #mozillazine and
the newsgroups bug references are often in the form "bug 12345". What I do is to
create a bookmark with the keyword "bug" that would bring me to the bug page.
However, lots of times "bug" is misstyped as "but", "buf" and "buh" (mostly
"but"), it would be nice to be able to have all these as keywords to the same
bookmark.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 6

16 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 7

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 8

16 years ago
remove self
Product: Browser → Seamonkey

Comment 9

13 years ago
see also: bug #265401
on this rare occasion I agree with the resolution of the FF equivalent bug - WONTFIX. Really now:
* how many people need this?
* do we need bookarks code to accommodate people's spelling mistakes?

And in the off chance that you're like me and sometimes forget which bm's have keywords you can add (keyword=xxx) to the name so it's searchable).
Assignee: bugs → p_ch
QA Contact: claudius → bookmarks

Comment 11

12 years ago
The problem got misrepresented with the discussion about mistyping and all that.
Why is http://del.icio.us/ so popular?
as people add more entries to their bookmarks, they want the ability to search
the collection of their bookmarks in an efficient way. YOu shouldnt ask people to remember all their keywords. For that matter why is google popular?
people want to search the vast collection of things. Not categorize. And then remember the categories and browse into categories, ensure it is rightly categorized, etc. If something can fall into multiple categories, then tag them with multiple keywords and then search. 

This is a straightforward request, nothing mysterious. 

Also look in: 
http://wiki.mozilla.org/Bookmarks_Use_Cases#Multiple_Keywords
(i did not add this entry by the way). Seems like more people are interested in
this enhancement.

Comment 12

12 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody

Comment 13

8 years ago
I agree with Matthew Cline in comment 3. Sometimes I change keywords. Then, I forget that I changed them and use the old ones. Being able to have multiple keywords for a single bookmark would be helpful, although I believe that the keywords should be formatted like "foo bar" instead of "foo,bar." Yeah, I could use multiple bookmarks, but that would be repetitive and unorganized.
Having this would be very useful. I'll never understand why keywords (not tags) are so neglected a feature in FF. I guess most people don't even know they can make their life easier by just typing "g searchword" into location bar to google for something. This is one of the coolest FF features. I use them every day for rapid searches in the location bar (google (g), wikipedia (wp), amazon (a) etc. etc.)), and get to often used pages with unmatched ease and precision.

E.g. I have a keyword "bzntb" to go straight to creating a (n)ew bug on (b)ug(z)illa.mozilla.org with (T)hunder(b)ird preset as product. Right now I sometimes feel like "bztbn" would be more easy to remember. So I'd like to have both "bzntb" and "bztbn" as a keyword for the same bookmark.

(In reply to comment #13)
> I believe that the keywords should be formatted like "foo bar"
> instead of "foo,bar."
No, we shouldn't use space as a separator for multiple keywords, for several reasons. Let's just have comma as we now do for separating tags, which will also make the behaviour consistent.

> Yeah, I could use multiple bookmarks, but that would be repetitive and 
> unorganized.
Absoluteley. Therefore this bug.

Comment 15

6 years ago
You can use tags in bookmarks now. Closing as WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Tags and keywords might have intersections in their use, yet they are also fundamentally different. This bug is clearly about keywords, not tags.
So it's not working, and it's still valid (see my comment 14).

I can have hundreds of bookmarks with the same tag, but only one bookmark with a certain keyword. So keywords are url shortcuts, but tags are not (although they help to find URLs, with some extra keystrokes). Basically, it's always a 1:1 relation between keyword and bookmarks (even after this bug, which requests the option of multiple 1:1 relations); but it's usually (and conceptually) a 1:n relation between tag and bookmarks: the same tag on multiple bookmarks, so as to group them together, including easier retrieval.

Furthermore, and more importantly, tags can never have that ingenious location bar search facility where you can just type things like "bz 123456" into location bar and press enter to open bug 123456 (and it only takes a few secs to set that up, using the "add keyword for this search" command from the context menu of search fields). So the request here is for more flexibility with defining URL (search) shortcuts, e.g. to allow both "bz <bug_no>" and "bmo <bug_no>" as location bar shortcuts for the same search URL.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 17

6 years ago
Fair enough. However I don't see this being implemented this side of the 21st century.
Status: REOPENED → NEW

Comment 18

6 years ago
BTW the equivalent bug for Firefox, bug 377736, was WONTFIXed in 2009.

Comment 19

5 years ago
(In reply to Thomas D. from comment #14)
> E.g. I have a keyword "bzntb" to go straight to creating a (n)ew bug on
> (b)ug(z)illa.mozilla.org with (T)hunder(b)ird preset as product. Right now I
> sometimes feel like "bztbn" would be more easy to remember. So I'd like to
> have both "bzntb" and "bztbn" as a keyword for the same bookmark.
Too artificial situation, as for me, if you already learn keyword and remember it, what's the point of changing it?
Second for WONTFIX making this it not only de facto, but also de jure.
Priority: P5 → --
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?]

Comment 20

5 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WONTFIX
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?] → [2012 Fall Equinox]

Comment 21

2 months ago
As for me, this missing feature is a really annoying thing.
I very often have to switch between different keybord layouts (e.g. english and cyrillic) and would like to be able to call the same search engine with different keywords (e.g. english "g" and cyrillic "г" for the google search, "gi" and "ги" for google images, "gm" and "гм" for google maps etc.
The current workaround is to install several search engines in different languages, which is quite annoying. But unfortunately even this is also not enough. The reason is that in different languages the respective letters are located on diferent keyboard buttons, which often leads to errors if you type the keyword using a wrong layout. Currently you need to install multiple search engines or to create several (actually unnecessary) bookmarks in order to cover all combinations (not to speak about different shortcuts, such as "w" and "wiki").
Allowing multiple keywords for a search would drastically simplify this situation.

Also, allowing multiple comma-separated shortcuts would be only consequent due to the fact that the keyword feature is considered as a replacement of the fermerly very popular Instantfox Addon (see https://addons.mozilla.org/en-US/firefox/addon/instantfox/reviews/848131/). But the Instantfox Addon allowed assignment of multiple keywords to the same search!
You need to log in before you can comment on or make changes to this bug.