Last Comment Bug 687139 - Nightly 2011-09-16 (rev 39b192706927) updater crashes with "Library not loaded: @executable_path/libmozutils.dylib"
: Nightly 2011-09-16 (rev 39b192706927) updater crashes with "Library not loade...
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Application Update (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Mike Hommey [:glandium]
:
Mentors:
: 687289 (view as bug list)
Depends on: 687234
Blocks: 688760
  Show dependency treegraph
 
Reported: 2011-09-16 12:25 PDT by Philipp von Weitershausen [:philikon]
Modified: 2011-10-04 01:57 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid linking the updater against libmozutils (956 bytes, patch)
2011-09-16 14:03 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Review

Description Philipp von Weitershausen [:philikon] 2011-09-16 12:25:32 PDT
I'm running Nightly 2011-09-16 (rev 39b192706927) and the updater crashes every single time, even after rebooting the system:

Process:         updater [62457]
Path:            /Applications/Nightly.app/Contents/MacOS/updates/0/updater.app/Contents/MacOS/updater
Identifier:      updater
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  ??? [1]

Date/Time:       2011-09-16 12:09:58.827 -0700
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          426600 sec
Crashes Since Last Report:           1
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      8FA6A325-52EA-42DF-A5AA-4EA066F40A80

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: @executable_path/libmozutils.dylib
  Referenced from: /Applications/Nightly.app/Contents/MacOS/updates/0/updater.app/Contents/MacOS/updater
  Reason: image not found

Binary Images:
    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <B536F2F1-9DF1-3B6C-1C2C-9075EA219A06> /usr/lib/dyld

Model: MacBookPro6,2, BootROM MBP61.0057.B0C, 2 processors, Intel Core i7, 2.66 GHz, 8 GB, SMC 1.58f15
Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 512 MB
Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (5.10.131.42.4)
Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS545050B9SA02, 465.76 GB
Serial ATA Device: SAMSUNG MMCRE28G5MXP-0VB, 119.24 GB
USB Device: Hub, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2
USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 5
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8218, 0xfa113000 / 8
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0236, 0xfa120000 / 4
USB Device: Internal Memory Card Reader, 0x05ac  (Apple Inc.), 0x8403, 0xfa130000 / 3
USB Device: Hub, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0xfd110000 / 4
USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8242, 0xfd120000 / 3
Comment 1 Nick Thomas [:nthomas] 2011-09-16 13:41:35 PDT
Confirmed.

Updates OK: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-15-03-08-45-mozilla-central/firefox-9.0a1.en-US.mac.dmg
Fails to update: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-16-03-09-07-mozilla-central/firefox-9.0a1.en-US.mac.dmg

Windows updates OK from the first build today, need to check Linux. We've disabled updates on Mac to prevent any further people from updating to broken builds.
Comment 2 Nick Thomas [:nthomas] 2011-09-16 13:45:34 PDT
When we apply an update we use the updater.app from the existing build, so the regression window is
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f2a2adaaacba&tochange=39b192706927

Fallout from bug 680440 changes ?
Comment 3 Mike Hommey [:glandium] 2011-09-16 13:58:42 PDT
(In reply to Nick Thomas [:nthomas] from comment #2)
> When we apply an update we use the updater.app from the existing build, so
> the regression window is
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=f2a2adaaacba&tochange=39b192706927
> 
> Fallout from bug 680440 changes ?

Indeed.

(In reply to Nick Thomas [:nthomas] from comment #1)
> Confirmed.
> 
> Updates OK:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-15-03-08-45-
> mozilla-central/firefox-9.0a1.en-US.mac.dmg
> Fails to update:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-09-16-03-09-07-
> mozilla-central/firefox-9.0a1.en-US.mac.dmg
> 
> Windows updates OK from the first build today, need to check Linux. We've
> disabled updates on Mac to prevent any further people from updating to
> broken builds.

Linux shouldn't be affected because libmozutils is statically linked in the binaries, there. On Windows, the updater is most probably in the same directory as the library, which makes it not be a problem. On mac, it appears the updater is in a separate directory, for a reason I ignore, so it can't find the library in that directory.

Two possible fixes here: changing the link path to libmozutils for the linker to be the right one, or not linking the updater against libmozutils at all, since it really doesn't need it. I'd go for the latter.
Comment 4 Mike Hommey [:glandium] 2011-09-16 14:01:09 PDT
I guess this also means our updater tests don't use the final paths on mac, and failed to catch that error... :-/
Comment 5 Mike Hommey [:glandium] 2011-09-16 14:03:00 PDT
Created attachment 560619 [details] [diff] [review]
Avoid linking the updater against libmozutils
Comment 6 Mike Hommey [:glandium] 2011-09-16 23:58:41 PDT
https://hg.mozilla.org/mozilla-central/rev/d14291158db7
Comment 7 Ben Hearsum (:bhearsum) 2011-09-17 10:14:19 PDT
This made it into the latest nightly, so I've re-enabled Mac Nightly updates.
Comment 8 Nick Thomas [:nthomas] 2011-09-18 20:22:21 PDT
*** Bug 687289 has been marked as a duplicate of this bug. ***
Comment 9 Nick Thomas [:nthomas] 2011-09-18 20:48:58 PDT
Since we got a dupe, I blogged to help out the ~350 people stuck on busted builds:
 https://blog.mozilla.com/nthomas/2011/09/19/broken-updater-for-mac-nightly-builds/
Comment 10 Devon Hubbard 2011-09-24 08:27:36 PDT
fwiw, I had been experiencing the updater crash every day since 9/19.  Yesterday, I installed the new baseline nightly build (from comment #9) and today a new nightly update was detected and installed without any crash.  thanks!

Note You need to log in before you can comment on or make changes to this bug.