{sink} [4.xP] Site displays twice in the same browser window

VERIFIED FIXED in M14

Status

()

P2
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: ccf, Assigned: vidur)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
When viewing the site listed above, the site contents will be displayed twice in
the browser window. I navigated to the URL listed above. When I arrrived the
site showed up twice in the browser window. One instance of the site was in the
top of the window and if I scrolled down there was a second instance of the
site. The links in both "sites" worked fine. The ad banner only worked in the
upper "site" but was blank in the second "site". Using a link from the second
"site" did not create a problem and no other pages in the site showed a similar
behavior.

Using build 1999050423 (May 5) on May 21,1999 14:01

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M7

Updated

20 years ago
Target Milestone: M7

Comment 1

20 years ago
Some notes:

1) The duplicate content is caused by '<script> inside the <body>' (bug #2701)
Attaching a 'patched' version of the same content; moved the <style> into the
<head> (where it _must_ be, but what can you do ;).

2) The attached file's layout is still not entirely correct, because the
content uses 'document.layers' in javascript (no actual LAYER tags are in the
HTML).  (somewhat like bug #3996 but clearly part of the whole
LAYER/document.layer issue).

3) msnbc.com sends out HTML customized by Nav/MSIE and version. The HTML sent
to Mozilla/5.0 is the same as the HTML sent to Mozilla/3.0 (I faked a script
to check this). CC:ing ekrock so he is aware of another site to pester ;)

Comment 2

20 years ago
Created attachment 241 [details]
testcase; msnbc.com 'patched' for 'style-in-body' #2701

Comment 3

20 years ago
Yup -- this is a dup of 2701. I'll look a bit deeper though. Here's the minimum
case:

<HTML><BODY>
    <TABLE border=1>
      <TR><TD>cell</TD></TR>
    </TABLE>
    <style><!-- td {background-color:red;} --></style>
</BODY></HTML>

Updated

20 years ago
Assignee: rickg → harishd
Status: ASSIGNED → NEW

Comment 4

20 years ago
Assigning to myself

Updated

20 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M7

Updated

20 years ago
Priority: P2 → P1

Updated

20 years ago
Assignee: harishd → peterl
Status: ASSIGNED → NEW
Priority: P1 → P2

Comment 5

20 years ago
Significant amount of work needs to be done in the content sink to avert bugs
like this.  Assigning bug to peterl@netscape.com

Comment 6

20 years ago
*** Bug 7416 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

20 years ago
*** Bug 5371 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 8

19 years ago
*** Bug 9046 has been marked as a duplicate of this bug. ***
Summary: 4.xP Site displays twice in the same browser window → [4.xP] Site displays twice in the same browser window
Took self off cc: list for this. Created new bug report #10451 to remind me to
evangelize msnbc about useragent sniffing. Thanks!

Comment 10

19 years ago
*** Bug 11121 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
*** Bug 10726 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Summary: [4.xP] Site displays twice in the same browser window → {sink} [4.xP] Site displays twice in the same browser window
Target Milestone: M9 → M10

Comment 12

19 years ago
*** Bug 11061 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
Moving all content sink issues to M14.

Comment 14

19 years ago
Make that M14.

Comment 15

19 years ago
Thanks for taking this Vidur. Many of these are likely dups. I haven't marked
them as such to make sure I had the testcases handy...

Updated

19 years ago
Blocks: 16950
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

19 years ago
Fixed with sink changes on 10/26/1999.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 17

19 years ago
With the Oct 29th build, this problem has been fixed.

Comment 18

19 years ago
*** Bug 16634 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.