Last Comment Bug 690668 - TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\passwordmgr\test\unit\test_storage_legacy_2.js | test failed (with xpcshell return code: 0), see following log:
: TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\xpcshell\tests\toolkit\compo...
Status: VERIFIED FIXED
: intermittent-failure, regression
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86_64 Windows Vista
: -- normal with 9 votes (vote)
: mozilla10
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
: 690843 692102 692116 692233 692282 (view as bug list)
Depends on:
Blocks: 438871 675553 690843
  Show dependency treegraph
 
Reported: 2011-09-29 23:21 PDT by Makoto Kato [:m_kato]
Modified: 2012-11-25 19:31 PST (History)
24 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.08 KB, patch)
2011-09-30 05:04 PDT, Makoto Kato [:m_kato]
benjamin: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2011-09-29 23:21:01 PDT
After landing bug 675553, this perma-orange occurs on Win64.  But this doesn't occurs if using VC10SP1.
Comment 1 Makoto Kato [:m_kato] 2011-09-30 05:03:33 PDT
This depends on compiler.  This occurs when script uses boolean type.  When casting to bool, the value is converted to true except to 0.  We need cast to PRUint8 at first, then cast to bool.
Comment 2 Makoto Kato [:m_kato] 2011-09-30 05:04:41 PDT
Created attachment 563712 [details] [diff] [review]
fix
Comment 3 Makoto Kato [:m_kato] 2011-10-03 08:12:43 PDT
*** Bug 690843 has been marked as a duplicate of this bug. ***
Comment 4 alanjstr 2011-10-03 13:36:53 PDT
Since this broke up/down/tab in all dropdowns on x64, should the severity be increased?
Comment 5 Anh Le 2011-10-04 21:38:13 PDT
How to apply the patch?
Comment 6 Dão Gottwald [:dao] 2011-10-05 07:47:47 PDT
*** Bug 692102 has been marked as a duplicate of this bug. ***
Comment 7 Veritas 2011-10-05 08:21:50 PDT
I can confirm (as the author of bug 692102) that it does indeed kill all of the drop down tab/arrow ordering.  I just had only thus far noticed it on the location bar.
Comment 8 Kevin Brosnan [:kbrosnan] 2011-10-05 08:35:37 PDT
*** Bug 692116 has been marked as a duplicate of this bug. ***
Comment 9 Anh Le 2011-10-05 08:50:52 PDT
I have the same issue with form in the web page, such as I input my username in Gmail login
Comment 10 Justin Wood (:Callek) (Away until Aug 29) 2011-10-05 09:33:35 PDT
(In reply to Makoto Kato from comment #2)
> Created attachment 563712 [details] [diff] [review] [diff] [details] [review]
> fix

Possibly sending this through try, would help Ben with his review ;-)
Comment 11 Kevin Brosnan [:kbrosnan] 2011-10-05 14:38:02 PDT
*** Bug 692282 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Brosnan [:kbrosnan] 2011-10-05 14:40:32 PDT
*** Bug 692233 has been marked as a duplicate of this bug. ***
Comment 13 Makoto Kato [:m_kato] 2011-10-05 21:18:30 PDT
https://hg.mozilla.org/mozilla-central/rev/8c82de08425d
Comment 14 David Chalkley 2011-10-06 05:02:18 PDT
Is this fix included in a future Firefox nightly update OR do we need to apply the fix ourselves (and if so how?)?
Comment 15 Kevin Brosnan [:kbrosnan] 2011-10-06 08:28:48 PDT
Verified fixed - Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1

Note You need to log in before you can comment on or make changes to this bug.