Closed Bug 690843 Opened 9 years ago Closed 9 years ago

Up/Down does not navigate dropdown correctly in Win x64. For example arrow/pgdwn/pgup/tab in URL address history

Categories

(Core :: General, defect)

10 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 690668

People

(Reporter: jack, Unassigned)

References

Details

(Keywords: dogfood, regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110930 Firefox/10.0a1
Build ID: 20110930030850

Steps to reproduce:

After typing in the awesome bar and seeing a history entry I wanted to return to, I tried to select the first entry by using the down arrow on my keyboard.


Actual results:

The last entry in the list was highlighted.
Using the arrow keys again only switched between the first, last, and no highlight.


Expected results:

The first suggestion should have been highlighted.

I had been using a 64 bit windows build, I tested again with the latest 32 bit windows build, and I did not have the same problem. I was able to reproduce the problem every time, on my own and a fresh profile, in the 64 bit build, but it always worked correctly with the 32 bit build.
Here's the build id from an affected version (I'd posted the bug from a 32)

http://hg.mozilla.org/mozilla-central/rev/b5b082d183d0
target
x86_64-pc-mingw32
Duplicate of this bug: 690844
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690828
I do not see the connection between this (or my 690844) and bug 690828.
Our bugs are about arrow key misbehavior in the awesomebar.
690828 is about dropdown boxes on web pages failing to open.

Do you have additional information that links these bugs, or was this closed purely on title resemblance?

I also object to our bugs being resolved as duplicates of each other, leaving no open bug about it.
Duplicate of this bug: 690861
This is not the same thing as bug 690828. The description doesn't seem all that similar, that one is not 64 bit only, I can't reproduce that error with their test case either.

Bug 690844 & Bug 690861 are the same though.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Yep the task is currently broken it seems :(
It may be fixed by bug 690668.
Depends on: 690668
Duplicate of this bug: 690995
Seems not part of latest Nightly still broken
The Tab key is also affected, with exactly the same traversal behavior as Down and Up.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 690919
Duplicate of this bug: 691037
Duplicate of this bug: 691099
Duplicate of this bug: 690931
Completely sorry, my summary did not display this bug:
-I can safely say that this bug still exists in build 20111001030845
-TAB works perfectly fine for me
-It seems that the up and down arrow keys act like the page up and page down keys in the URL address bar
(In reply to David from comment #16)
> -TAB works perfectly fine for me
Why is there not edit button?.. Didn't release that you where referring to the awesomebar, CORRECTION TAB does not work and the up and down arrows seem to mimic the page up key
Still happening.  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111001 Firefox/10.0a1 ID:20111001030845

I've checked, and yes, the up/down keys are acting just like the page up/down keys.  TAB is not working for me, and acts just like the down key.
Duplicate of this bug: 691131
The description for this bug is wrong.
And it's way more major, then it is described there.
Down/up arrow keys just don't switch to the prev/next entries anymore. And this is happening just in awesomebar. This also happens when using the drop-down lists of search' and forms' history.
I'm having the same issue, running 

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111002 Firefox/10.0a1

Interestingly the

Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111002 Firefox/10.0a1

build doesn't have the issue.
Duplicate of this bug: 691182
Same issue, running 
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111002 Firefox/10.0a1

It happened 2 - 3 nights ago.
Duplicate of this bug: 691207
Keywords for better search results (less duplicates):
locationbar adressbar urlbar awesomebar location address url awesome bar up down key keys cursor arrow keyboard x64 64bit 64-bit Win64 history autocomplete entry entries
Still happennig, Windows 7 x64, Nightly 64 bits, just downloaded the latest build.

Happens everywhere when a drop down list opens...
Summary: The arrow keys don't work on the history drop-down from the awesomebar on 64 bit windows firefox → Up/Down does not navigate dropdown correctly in Win x64
Up/down and TAB are actually invoked if i understood it right i actually never used TAB to highlight the first entry but according to https://bugzilla.mozilla.org/show_bug.cgi?id=690843#c11 TAB should also work with this task and indeed it would make it even more easy to use TAB for that task as down is most times harder to reach :)
start typing + TAB + ENTER sounds perfect thx Lars :)
Lars was it like that the first Tab press selects the first entry and another Tab press the last ? i have to check in 32 bit, funny you can still learn through bug reports ;) :D
Component: Location Bar → General
Product: Firefox → Core
QA Contact: location.bar → general
Today, although I test on try server and talk by IRC, this is same as bug 690668.  This is xpconnect bug by PRBool -> bool landed.
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
No longer depends on: 690668
Resolution: --- → DUPLICATE
Duplicate of bug: 690668
Duplicate of this bug: 691356
I can also verify that Tab performs just as incorrectly as the up/down keys.
Depends on: 690668
Keywords: dogfood, regression
Summary: Up/Down does not navigate dropdown correctly in Win x64 → Up/Down arrow does not navigate URL address dropdown correctly in Win x64
Wayne Mery (:wsmwk),

the bug is not just about URL address, stop changing the bug's summary if you don't know the it's details.
(In reply to Sean Newman from comment #32)
> Wayne Mery (:wsmwk),
> 
> the bug is not just about URL address, stop changing the bug's summary if
> you don't know the it's details.

Sean, I'm generally aware of such things, thank you. The fact that I couldn't find this bug trivially (consider the summaries of all the dups) with the previous summary indicates it needs improvement. I trust this change will suit.
Summary: Up/Down arrow does not navigate URL address dropdown correctly in Win x64 → Up/Down does not navigate dropdown correctly in Win x64. For example arrow/pgdwn/pgup/tab in URL address history
This bug is still apparent in build:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111003(080738) Firefox/10.0a1
Duplicate of this bug: 691544
Duplicate of this bug: 691649
Duplicate of this bug: 691708
Still in the following build:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111003 Firefox/10.0a1 ID:20111003080738
(In reply to David Chalkley from comment #34)
> This bug is still apparent in build:
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111003(080738)
> Firefox/10.0a1

(In reply to admin from comment #38)
> Still in the following build:
> Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111003
> Firefox/10.0a1 ID:20111003080738

bug 690668 will fix this problem, and you will get bugmail when it is fixed (as long as 690668 is kept as a blocker). until then, there is no need to comment.
Duplicate of this bug: 691816
Duplicate of this bug: 692327
Duplicate of this bug: 692228
Duplicate of this bug: 692034
Duplicate of this bug: 692661
Bug was fixed in this build Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1. Thanks a lot ^_^
You need to log in before you can comment on or make changes to this bug.