Closed Bug 692149 Opened 8 years ago Closed 7 years ago

Blocklist the npmozax.dll plugin

Categories

(Toolkit :: Blocklist Policy Requests, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: rayproudfoot, Unassigned)

References

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Visit http://www1.skysports.com/news-wire/11669.


Actual results:

Although the page loads correctly a crash report is generated and places in C:\Documents and Settings\Ray\Application Data\Mozilla\Firefox\Crash Reports\pending


Expected results:

No crash report should have been generated presumably. I do have a Forefox 'theme' installed but otherwise it's a standard install.
I came across this folder by accident and was horrified to discover it contained over 23,000 files. Why doesn't Firefox monitor this and advise when it reaches certain limits? There was no hint these error reports were being generated.
Do you have a npmozax.dll plugin installed ?
You should see it either in tools/addons/plugins or if you type about:plugins
I forgot: Please open about:crashes (enter as URL) and click the last (top) report once. The crash ID should now contain a leading bp- . Please post this ID.
Here is the entry from the top-most entry.

bp-9386e64f-dc09-457f-87ae-a02ab2111005

It may not relate to the skysports site as I now have 150 files in that folder since 17:00 today! Clearly Firefox doesn't like a lot of sites but doesn't give me any indication it doesn't.
I'm using the addon Classic Compact 4.0.9.3 which is available from this site.

http://blog.environmentalchemistry.com/2008/03/firefox-theme-classic-compact.html

Just in case it helps.
Does the crash still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Crash Signature: [@ pr_FindSymbolInLib ]
Keywords: crash
Ray: It seems that you get the crashes because of the Plugin "npmozax.dll" .
This is an old Mozilla Active X Plugin and should not work in recent Firefox versions.
Can you please deactivate or remove it ? 
You can deactivate it under (alt key)/tools/addons/plugins
The plugin itself is probably crashing and it may crash very frequently and that will create a pending crash report everytime.  

I think we should do 2 things if that fixes your problem:
Blocklist the plugin
Spin-off bug for the thousands of crash reports in pending
> Spin-off bug for the thousands of crash reports in pending

Bug 690841 and bug 691432 handles that issue,
so let's make this bug be about blocklisting npmozax.dll
Summary: Visiting http://www1.skysports.com/news-wire/11669 causes pending crash report → Blocklist the npmozax.dll plugin
Hi Matti,

I disabled the plugin named Mozilla ActiveX control and plugin support 1.0.0.4 and this has cured the problem of crash reports being generated. Thank you very much!

Please advise if I ned to take any further action.

Regards,
Ray.
Status: UNCONFIRMED → NEW
Component: General → Blocklisting
Ever confirmed: true
Product: Firefox → addons.mozilla.org
QA Contact: general → blocklisting
Version: 7 Branch → unspecified
Ray: thank you for the report and there is no further action needed.
We will use your report to get the Plugin blocked for all Firefox users.
Matti,

Glad to have helped. Thanks for an excellent service.

Regards,
Ray.
Duplicate of this bug: 692685
Crash Signature: [@ pr_FindSymbolInLib ] → [@ pr_FindSymbolInLib ] [@ PR_FindFunctionSymbol ]
Blocks: 695927
Depends on: 716345
Blocks: 693363
Is this fixed and closeable ?
What do we know about this plugin? When did it stop working? Which Firefox versions should it work on?
This bug can be closed as I filed on request a new block request with bug 695927 (still unfixed!)
Jorge: bug 695927 contains all the information
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.