Last Comment Bug 694353 - "Warning: package error or possible missing or unnecessary file:" : freebl3.chk + nssdbm3.chk + softokn3.chk
: "Warning: package error or possible missing or unnecessary file:" : freebl3.c...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: P1 normal (vote)
: mozilla12
Assigned To: Serge Gautherie (:sgautherie)
:
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on:
Blocks: 683441 713132 713133 713134
  Show dependency treegraph
 
Reported: 2011-10-13 10:03 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-02-05 14:58 PST (History)
4 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
wontfix
affected


Attachments
(Av1-FF) Don't explicitely package the 3 NSS .chk files which are now directly created in the staging directory, Reorder PSM files (2.57 KB, patch)
2012-01-04 06:03 PST, Serge Gautherie (:sgautherie)
no flags Details | Diff | Splinter Review
(Av1a-FF) Don't explicitely package the 3 NSS .chk files which are now directly created in the staging directory, Reorder PSM files (2.76 KB, patch)
2012-01-04 06:24 PST, Serge Gautherie (:sgautherie)
ted: review-
Details | Diff | Splinter Review
(Av2-FF) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files [Checked in: Comment 20] (2.46 KB, patch)
2012-01-10 08:52 PST, Serge Gautherie (:sgautherie)
ted: review+
Details | Diff | Splinter Review
(Bv1-CC) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files [Checked in: Comment 23] (6.60 KB, patch)
2012-01-18 12:54 PST, Serge Gautherie (:sgautherie)
standard8: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2011-10-13 10:03:14 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=6831811&tree=Mozilla-Inbound
WINNT 5.2 mozilla-inbound build on 2011-10-13 07:24:24 PDT for push 9cda258f822f
{
Warning: package error or possible missing or unnecessary file: bin/components/dom_threads.xpt (package-manifest, 97).

Warning: package error or possible missing or unnecessary file: bin/components/plugin.xpt (package-manifest, 150).

bin/softokn3.dll
bin/freebl3.dll
bin/ssl3.dll
Warning: package error or possible missing or unnecessary file: bin/freebl3.chk (package-manifest, 384).
Warning: package error or possible missing or unnecessary file: bin/softokn3.chk (package-manifest, 385).
bin/nssdbm3.dll
Warning: package error or possible missing or unnecessary file: bin/nssdbm3.chk (package-manifest, 387).
}

***

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1318429599.1318448919.16271.gz
WINNT 5.2 comm-central-trunk build on 2011/10/12 07:26:39
has these too.
Comment 1 Serge Gautherie (:sgautherie) 2011-12-30 03:43:14 PST
Bug 713415 fixed dom_threads.xpt case.
Comment 2 Serge Gautherie (:sgautherie) 2012-01-01 08:20:59 PST
(In reply to Serge Gautherie (:sgautherie) from comment #0)
> Warning: package error or possible missing or unnecessary file:
> bin/components/plugin.xpt (package-manifest, 150).

https://tbpl.mozilla.org/php/getParsedLog.php?id=8261507&tree=Firefox&full=1
WINNT 5.2 mozilla-central build on 2011-12-31 21:17:01 PST for push d77b056ed4bd
https://tbpl.mozilla.org/php/getParsedLog.php?id=8263433&tree=Firefox&full=1
WINNT 5.2 mozilla-central nightly on 2012-01-01 03:10:16 PST for push d77b056ed4bd
https://tbpl.mozilla.org/php/getParsedLog.php?id=8256615&tree=Mozilla-Aurora&full=1
WINNT 5.2 mozilla-aurora build on 2011-12-31 05:51:01 PST for push e2fe885dce01
https://tbpl.mozilla.org/php/getParsedLog.php?id=8238248&tree=Mozilla-Beta&full=1
WINNT 5.2 mozilla-beta build on 2011-12-30 08:54:22 PST for push 29a99f414124
+
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1325395137.1325414342.5676.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2011/12/31 21:18:57
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1322879916.1322887198.30601.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/12/02 18:38:36

don't report this error anymore.
(Ftr, I have no idea what/when fixed this error.)
Comment 3 Serge Gautherie (:sgautherie) 2012-01-01 09:04:59 PST
(In reply to Serge Gautherie (:sgautherie) from comment #0)
> bin/softokn3.dll
> bin/freebl3.dll
> bin/ssl3.dll
> Warning: package error or possible missing or unnecessary file:
> bin/freebl3.chk (package-manifest, 384).
> Warning: package error or possible missing or unnecessary file:
> bin/softokn3.chk (package-manifest, 385).
> bin/nssdbm3.dll
> Warning: package error or possible missing or unnecessary file:
> bin/nssdbm3.chk (package-manifest, 387).
> }

These errors are still reported.

Could it be a "regression" caused by bug 683441?
(If so, I assume applications should simply not try to package these files anymore/ftb...)
Comment 4 Mark Banner (:standard8) 2012-01-02 12:09:06 PST
If we don't include these files in the package manifest, do they still get included in the resultant builds?
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-01-03 05:28:43 PST
No. Only things in the package manifest get packaged into the final build.
Comment 6 Serge Gautherie (:sgautherie) 2012-01-03 05:57:52 PST
(In reply to Serge Gautherie (:sgautherie) from comment #3)
> (If so, I assume applications should simply not try to package these files
> anymore/ftb...)

Firefox 12a1 and SeaMonkey 2.9a1 (and ...) still actually package theses 3 files.

If that is still what we want (as I assume), then some other kind of workaround/fix is needed.
Comment 7 Mike Hommey [:glandium] 2012-01-03 23:24:38 PST
(In reply to Mark Banner (:standard8) from comment #4)
> If we don't include these files in the package manifest, do they still get
> included in the resultant builds?

(In reply to Ted Mielczarek [:ted, :luser] from comment #5)
> No. Only things in the package manifest get packaged into the final build.

Actually, yes. The libraries are signed in the staging directory, meaning the .chk files are created there directly. Packaging manifest are used to copy files from dist/bin to the staging directory before that.
Comment 8 Serge Gautherie (:sgautherie) 2012-01-04 05:53:50 PST
(In reply to Mike Hommey [:glandium] from comment #7)
> Actually, yes. The libraries are signed in the staging directory, meaning
> the .chk files are created there directly. Packaging manifest are used to
> copy files from dist/bin to the staging directory before that.

Ah, good!

Yet, does that mean that local builds can't be run from dist/bin anymore?
(as in, they now require 'make install' or the like.)
Or are/should .chk files be (back-)copied to dist/bin?
Comment 9 Serge Gautherie (:sgautherie) 2012-01-04 06:03:18 PST
Created attachment 585721 [details] [diff] [review]
(Av1-FF) Don't explicitely package the 3 NSS .chk files which are now directly created in the staging directory, Reorder PSM files

I commented out the 3 .chk lines, as documentation.
I could remove them completely if you prefer.

Submitted to Try...
Comment 10 Serge Gautherie (:sgautherie) 2012-01-04 06:24:25 PST
Created attachment 585729 [details] [diff] [review]
(Av1a-FF) Don't explicitely package the 3 NSS .chk files which are now directly created in the staging directory, Reorder PSM files

Av1-FF, with 2 nits and Solaris part too.
Comment 11 Ted Mielczarek [:ted.mielczarek] 2012-01-04 07:49:37 PST
The only thing the .chk files are used for are as checksums for running in FIPS mode. Firefox (and NSS) will run just fine without them unless you attempt to enable FIPS.
Comment 12 Mozilla RelEng Bot 2012-01-04 09:21:02 PST
Try run for 0d686d2521b7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0d686d2521b7
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-0d686d2521b7
Comment 13 Mozilla RelEng Bot 2012-01-04 09:21:09 PST
Try run for 0d686d2521b7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0d686d2521b7
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-0d686d2521b7
Comment 14 Mozilla RelEng Bot 2012-01-04 09:21:16 PST
Try run for 0d686d2521b7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0d686d2521b7
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-0d686d2521b7
Comment 15 Mozilla RelEng Bot 2012-01-04 09:21:25 PST
Try run for 0d686d2521b7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0d686d2521b7
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-0d686d2521b7
Comment 16 Mozilla RelEng Bot 2012-01-04 09:21:30 PST
Try run for 0d686d2521b7 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=0d686d2521b7
Results (out of 14 total builds):
    success: 14
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/sgautherie.bz@free.fr-0d686d2521b7
Comment 17 Serge Gautherie (:sgautherie) 2012-01-04 10:20:28 PST
(In reply to Ted Mielczarek [:ted, :luser] from comment #11)
> The only thing the .chk files are used for are as checksums for running in
> FIPS mode. Firefox (and NSS) will run just fine without them unless you
> attempt to enable FIPS.

Then, iiuc, the only "broken" case is "enabling FIPS mode when running from dist/bin", which I assume is acceptable as WontFix.


(In reply to Mozilla RelEng Bot from comment #12)
> Try run for 0d686d2521b7 is complete.
>     success: 14

No more warnings, and the 3 .chk files are still in the "application archive" :-)
Comment 18 Ted Mielczarek [:ted.mielczarek] 2012-01-10 05:31:28 PST
Comment on attachment 585729 [details] [diff] [review]
(Av1a-FF) Don't explicitely package the 3 NSS .chk files which are now directly created in the staging directory, Reorder PSM files

Review of attachment 585729 [details] [diff] [review]:
-----------------------------------------------------------------

If you're going to remove them, just remove them and don't comment them out, please.
Comment 19 Serge Gautherie (:sgautherie) 2012-01-10 08:52:15 PST
Created attachment 587336 [details] [diff] [review]
(Av2-FF) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files
[Checked in: Comment 20]

Av1a-FF, with comment 18 suggestion(s).
Comment 20 Serge Gautherie (:sgautherie) 2012-01-18 12:28:38 PST
Comment on attachment 587336 [details] [diff] [review]
(Av2-FF) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files
[Checked in: Comment 20]

https://hg.mozilla.org/mozilla-central/rev/58e933465c36
Comment 21 Serge Gautherie (:sgautherie) 2012-01-18 12:54:24 PST
Created attachment 589611 [details] [diff] [review]
(Bv1-CC) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files
[Checked in: Comment 23]
Comment 22 Serge Gautherie (:sgautherie) 2012-01-18 13:01:39 PST
/b2g/installer/package-manifest.in
/mobile/android/installer/package-manifest.in
/mobile/xul/installer/package-manifest.in
are left for someone else to fix, if need be.
Comment 23 Serge Gautherie (:sgautherie) 2012-01-20 03:23:58 PST
Comment on attachment 589611 [details] [diff] [review]
(Bv1-CC) Stop explicitly packaging NSS .chk files which are now created in the staging directory directly, Reorder PSM files
[Checked in: Comment 23]

http://hg.mozilla.org/comm-central/rev/f50b1ec0a5c1
Comment 24 Serge Gautherie (:sgautherie) 2012-01-20 07:37:17 PST
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1327066666.1327068956.20300.gz&fulltext=1
Linux x86-64 comm-central-trunk build on 2012/01/20 05:37:46

V.Fixed

Note You need to log in before you can comment on or make changes to this bug.