PDF file attachments disappear when clicking on mail message (HTML view) - paper clip in message list shows, but then disappears

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
7 years ago
6 months ago

People

(Reporter: familie.maechler, Unassigned)

Tracking

7 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 567484 [details]
Problematic mail which is now ok - after changing the view to text

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I opened a mail in Thunderbird 7.0.1 which has an attachment (2 PDFs) by clicking on its mail line (with subject, from etc. in the list pane)


Actual results:

The yellow paper clip in the mails list disappears and there is no attachment in the mail. The size is correct.
Also, the last three lines of the original mail are not showing up, instead another mail is added (including envolope infos and body) - strange...
When I moved the mail to another folder, the mail line showed the paper clip again, until I clicked on the mail to see a preview. I did this a few times. Until I changed the view from HTML to simple HTML (still no attachment), but then when I changed to simple text, the attachment appeared and stayed even when I chose afterwords HTML... So, since then the mail is ok :-)


Expected results:

obvious
(Reporter)

Updated

7 years ago
Severity: normal → critical

Comment 1

7 years ago
Is this the same as Bug 693942 ?
(Reporter)

Comment 2

7 years ago
I'm not sure. From what I understood in the other bug reports is that TB has problems with non standard (Outlook, rtf?) formats. But my observation is that once I choose plain text (?) (In the german version it is "Reiner Text") and then change back to HTML, the attachments are and stay there! That means that TB is generally capable to interprete such an email correctly.
Attachment #567484 - Attachment mime type: application/octet-stream → text/plain
IMAP? (I guess yes)
Is folder of offline-use=on? off?
  Folder Properties/Synchronization, [ ? ] Select this folder for offline use
When did you view the mail first? Just after arrival of the mail?
(Reporter)

Comment 4

7 years ago
Yes,I use the server imap.googlemail.com

Apart from one unimportant subfolder, all folders are enabled for offline reading.

Can't remember exactly, but I opened this email not immediately, but a few hours after arrival. (I opened it in TB first - only later in the web interface to look for the attachments.)
(In reply to familie.maechler from comment #0)
> Also, the last three lines of the original mail are not showing up, instead
> another mail is added (including envolope infos and body) - strange...

The strange "including envolope infos and body" was "message header data and body data of the shown mail himself", wasn't it?
If data of his own mail, message source which Tb used for first display of the mail(HTML mode) was probably similar one to bug 587528, bug 604620, bug 608529, bug 647562, and phenomenon you observed can occur.

Was next <img> in html shown when you saw problem?
> serif"'><img border=3D0 width=3D377 height=3D104 id=3D"Bild_x0020_1" src=3D=
> "cid:image003.jpg@01CC89CA.0F5B1BD0" alt=3D"FMG Schriftzug"><o:p></o:p></sp=
The image should be shown at [cid:image003.jpg@01CC89CA.0F5B1BD0] position of next last part of text/plain data, if correct data is used.  
> Mit bestem Dank und freundliche Gr=FCsse
> Ihr Foto M=E4chler Team
> Joylyn Hugentobler
> [cid:image003.jpg@01CC89CA.0F5B1BD0]
> 
> Foto M=E4chler Galgenen
> Kantonsstrasse 54
> 8854 Galgenen
> ___________________________________
> Tel.  055 440 50 00
> Fax. 055 440 15 36
> 
> Mail:       info@fotomaechler.ch<mailto:info@fotomaechler.ch>
> Website: http://www.fotomaechler.ch<http://www.fotomaechler.ch/>
> Neu Hochzeit: www.fotomaechler.com
> ___________________________________

(In reply to familie.maechler from comment #4)
> Can't remember exactly, but I opened this email not immediately, but a few
> hours after arrival.

However, because of "a few hours after arrival" in your case, mail is already downloaded to offline-store file(Inbox, not Inbox.msf, if Inbox) usually, and if same phenomenon as those bugs, corrupted(merged) data should be used even after "View/Message Body As" change to "Plain Text" mode. And, mail data obtained by "save as .eml" should be corrupted(merged) one. To recover from problem, one of next is needed to force re-download of whole mail data.
  - Repair Folder (Folder Poperties/General)
  - Move mail to folder of same account, and move back to original folder

Was message header pane display correct when you saw problem?
How about when you changed to View/Message Body As/Plain Text?
How did you get mail data(.eml file) which you attached to this bug?
(Reporter)

Comment 6

7 years ago
(In reply to WADA from comment #5)
> The strange "including envolope infos and body" was "message header data and
> body data of the shown mail himself", wasn't it?
No, it was header and body data of another email (which was also in the inbox, as I remember).

> Was next <img> in html shown when you saw problem?
> > serif"'><img border=3D0 width=3D377 height=3D104 id=3D"Bild_x0020_1" src=3D=
> > "cid:image003.jpg@01CC89CA.0F5B1BD0" alt=3D"FMG Schriftzug"><o:p></o:p></sp=
> The image should be shown at [cid:image003.jpg@01CC89CA.0F5B1BD0] position
> of next last part of text/plain data, if correct data is used.  
> > Mit bestem Dank und freundliche Gr=FCsse
> > Ihr Foto M=E4chler Team
> > Joylyn Hugentobler
> > [cid:image003.jpg@01CC89CA.0F5B1BD0]
> > 
> > Foto M=E4chler Galgenen
> > Kantonsstrasse 54
> > 8854 Galgenen
> > ___________________________________
> > Tel.  055 440 50 00
> > Fax. 055 440 15 36
> > 
> > Mail:       info@fotomaechler.ch<mailto:info@fotomaechler.ch>
> > Website: http://www.fotomaechler.ch<http://www.fotomaechler.ch/>
> > Neu Hochzeit: www.fotomaechler.com
> > ___________________________________
I did not have such a close look at it, sorry.
 

> (In reply to familie.maechler from comment #4)
> > Can't remember exactly, but I opened this email not immediately, but a few
> > hours after arrival.
> 
> However, because of "a few hours after arrival" in your case, mail is
> already downloaded to offline-store file(Inbox, not Inbox.msf, if Inbox)
> usually, and if same phenomenon as those bugs, corrupted(merged) data should
> be used even after "View/Message Body As" change to "Plain Text" mode. And,
> mail data obtained by "save as .eml" should be corrupted(merged) one. To
> recover from problem, one of next is needed to force re-download of whole
> mail data.
>   - Repair Folder (Folder Poperties/General)
>   - Move mail to folder of same account, and move back to original folder
I'm sure that before I changed the "View/Message Body As" to "Plain Text" mode, I moved the mail a few times between different folders (from inbox to another folder {on the same account - I only use one account} and back to the inbox and then yet to another folder and back to the inbox) and after every move the mail showed the yellow paper clip in the message header pane only until (but it did till then!) I clicked on the mail in the message header pane to view the content of the mail.
And once I changed the "View/Message Body As" to "Plain Text" mode, the mail was ok. I saw the attachments and the uncorrupted body. I then changed back to HTML mode and the mail was still ok! I could not go back to a corrupted view anymore. Could it be that by forcing an interpretation of the mail as Plain Text, TB has cleared some bad formats in the mail?

> Was message header pane display correct when you saw problem?
> How about when you changed to View/Message Body As/Plain Text?
I hope these questions are answered by my above answer.

> How did you get mail data(.eml file) which you attached to this bug?
I simply clicked the (cured) mail and chose save as... I have not saved the email before it was "corrected". As soon as I encounter the same problem (with another mail) again, I will save it immediately so that you can analyze that.

Updated

7 years ago
Blocks: 705249
Wada ?

Comment 8

7 years ago
Does this still happen in TB 10?
(Reporter)

Comment 9

7 years ago
I am now on Windows 7 and have not yet installed TB at all. I will come back in case it happens again.
(In reply to familie.maechler from comment #6)
> No, it was header and body data of another email (which was also in the
> inbox, as I remember).

Similar phenomenon was reported in other bug.
While Tb is downloading a new mail(call UID=A, perhaps by auto-sync), click other new mail at thread pane(call UID=B) => Content of UID=A was shown for mail of UID=B.
I suspect problem like following.
New mails arrive -> auto-sync requests uid A,B,C,... fetch body[](written to offline-store) -> while downloading mail data of UID=A, mail of UID=B is clicked -> fetch by auto-sync is inturrpted -> fetch of UID=B is invoked(written in Disk Cache? offline-store?) -> data for UID=A is used.

Please check offline-store file content(bottom part is for newest mails) when you see problem again.
This looks very similar to bug 673488. Dupe?
See Also: → bug 673488
Summary: Attachments disappear when clicking on mail (HTML view) → PDF file attachments disappear when clicking on mail message (HTML view)
Opening test msg of attachment 567484 [details] in TB12 on WinXP works flawlessly for me for any of View Message Body as > Original HTML, Simple HTML, Plain Text.
Whiteboard: [dupeme against 673488]
Bug 596280 Comment 4 has a more comprehensive list of bugs with same problem, which need consolidation and confirmation.
No longer blocks: 705249
Whiteboard: [dupeme against 673488] → [dupeme]
familie, do you still see this issue?
A folder, containing a single message would be preferable testcase
Flags: needinfo?(familie.maechler)
Summary: PDF file attachments disappear when clicking on mail message (HTML view) → PDF file attachments disappear when clicking on mail message (HTML view) - paper clip in message list shows, but then disappears
(Reporter)

Comment 15

3 years ago
Thank you for your care, but I'm using since a while the mail client "Postbox", where this problem has never occured. So I can't tell if TB still would have this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(familie.maechler)
Resolution: --- → WORKSFORME
Incomplete may be more appropriate because you haven't tested a recent thunderbird. But I'll leave it WFM because postbox is *based on Thunderbird*.  Thanks for the update.
You need to log in before you can comment on or make changes to this bug.