Enable incremental linking on 64-bit Windows, but not on 32-bit

RESOLVED FIXED in Firefox 10

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: sid0)

Tracking

({regression})

Trunk
mozilla11
x86
Windows Server 2003
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox10 fixed)

Details

(Whiteboard: fixed-in-bs [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Per bug 653662 and bug 696627 discussions.
(Reporter)

Comment 1

6 years ago
Fwiw:

(In reply to neil@parkwaycc.co.uk from bug 653662 comment #24)
> What's actually tipping the ilk over the limit? MOZ_DEBUG is a sledgehammer,
> so if you do subsequently tweak the condition you might want to consider
> conditioning on MOZ_DEBUG_SYMBOLS or MOZ_OPTIMIZE instead as appropriate.
(Assignee)

Comment 2

6 years ago
Created attachment 573156 [details] [diff] [review]
patch

http://social.msdn.microsoft.com/Forums/en-US/vcgeneral/thread/c34d5c37-ca4a-4580-9c7c-4379a8c76d1f/ indicates that enabling it should be fine on VC9/64 too.
Assignee: nobody → sagarwal
Status: NEW → ASSIGNED
Attachment #573156 - Flags: review?(ted.mielczarek)
(Assignee)

Comment 3

6 years ago
Created attachment 573163 [details] [diff] [review]
better patch
[Checked in: Comment 10 & 11]
Attachment #573156 - Attachment is obsolete: true
Attachment #573156 - Flags: review?(ted.mielczarek)
Attachment #573163 - Flags: review?(ted.mielczarek)
Comment on attachment 573163 [details] [diff] [review]
better patch
[Checked in: Comment 10 & 11]

Review of attachment 573163 [details] [diff] [review]:
-----------------------------------------------------------------

Ugh. GNU Make makes me sad. :-(
Attachment #573163 - Flags: review?(ted.mielczarek) → review+

Comment 5

6 years ago
Can we take this patch on Aurora? Otherwise some supported build setups won't work for some people in fx10.
Blocks: 696627
No longer depends on: 696627
Keywords: regression
(Reporter)

Updated

6 years ago
Attachment #573163 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 6

6 years ago
https://hg.mozilla.org/projects/build-system/rev/a7b08c15904b
Whiteboard: fixed-in-bs
(Assignee)

Comment 7

6 years ago
If this needs to land in Aurora urgently could someone else land it please? I'm on mobile internet until Monday and don't have a fresh Aurora checkout.
(Assignee)

Comment 8

6 years ago
Oh, and this should be low risk enough because it doesn't affect any tinderbox builds.

Updated

6 years ago
Attachment #573163 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 9

6 years ago
Ftr, mozilla-beta is not affected (yet):
http://mxr.mozilla.org/mozilla-beta/source/toolkit/library/Makefile.in#131

Updated

6 years ago
Target Milestone: --- → mozilla11
https://hg.mozilla.org/mozilla-central/rev/a7b08c15904b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/dfc153c765b8
status-firefox10: --- → fixed
(Reporter)

Updated

6 years ago
Attachment #573163 - Attachment description: better patch → better patch [Checked in: Comment 11]
(Reporter)

Updated

6 years ago
Flags: in-testsuite-
Whiteboard: fixed-in-bs → [ToDo: check in to m-a] [fixed-in-bs]
(Reporter)

Updated

6 years ago
Attachment #573163 - Attachment description: better patch [Checked in: Comment 11] → better patch [Checked in: Comment 10 & 11]
(Reporter)

Updated

6 years ago
Whiteboard: [ToDo: check in to m-a] [fixed-in-bs] → fixed-in-bs
(Reporter)

Updated

6 years ago
Blocks: 703852
Marking qa- as I don't think this is something QA needs to verify. Please set to qa+ if this is not the case.
Whiteboard: fixed-in-bs → fixed-in-bs [qa-]
You need to log in before you can comment on or make changes to this bug.